You are not logged in.

#1 2005-03-15 01:06:31

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

XMMS, BMP - volume control ineffectual, volume always max

I've run into an unusual problem with XMMS and BMP: the volume control does not work, no matter what output plugin I use. With ALSA output, the volume control does not work, period; with OSS output, XMMS/BMP is muted by setting its volume to zero, but other than that volume control does nothing.

Interestingly, this problem affects not only Arch Linux, but also Damn Small Linux (stripped-down KNOPPIX). This leads me to think it's some sort of hardware compatibility problem, though I can't see how.

Any info?

Offline

#2 2005-03-15 05:47:51

shadowhand
Member
From: MN, USA
Registered: 2004-02-19
Posts: 1,142
Website

Re: XMMS, BMP - volume control ineffectual, volume always max

Does that mean you can't get sound? At all?


·¬»· i am shadowhand, powered by webfaction

Offline

#3 2005-03-15 10:44:48

mico
Member
From: Slovenia
Registered: 2004-02-08
Posts: 241

Re: XMMS, BMP - volume control ineffectual, volume always max

In alsa plugin options choose "use software volume control"

or for OSS plugin if you use OSS, choose "control master, not PCM", or something like that.

Offline

#4 2005-03-15 21:01:11

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: XMMS, BMP - volume control ineffectual, volume always max

Ahh... Thanks. I'll see if that works.

Yep... Perfect! Thanks!

Offline

#5 2005-03-19 12:58:45

drojid
Member
Registered: 2005-02-21
Posts: 13

Re: XMMS, BMP - volume control ineffectual, volume always max

Hi,

I have the same problem with an i915 chipset.
I'd like to find the way to use the HW mixer, because the volume is set to a medium level somehow, and the SW mixing can only set volume between zero and a quite low level, so this is not a solution for me.

Any ideas?  sad

Offline

Board footer

Powered by FluxBB