You are not logged in.

#1 2010-11-05 18:33:07

From: UK
Registered: 2010-10-21
Posts: 34

[SOLVED] Problem whilst trying to build kernel26-ck from source

I've spent some time reading about kernel patch sets, and after some research and valuable info from the Arch community, I've decided that the ck patchset is most appropriate for my system, however,  I receive the following error after issuing a mkpkg -sc command:


==> Validating source files with md5sums...
    linux-2.6.36.tar.bz2 ... Passed
    patch-2.6.36-2-ARCH.bz2 ... Passed
    config ... Passed
    config.x86_64 ... Passed
    kernel26.preset ... Passed
    patch-2.6.36-ck2.bz2 ... Passed
    0001-bfq_iosched-block-prepare_IO_context_code-v1-2.6.36.patch ... Passed
    0002-bfq_iosched-block-add-cgroups-kconfig-and-build-bits-for-BFQ-v1-2.6.36.patch ... Passed
    0003-bfq_iosched-block-introduce_BFQ-v1-2.6.36.patch ... Passed
==> Extracting Sources...
  -> Extracting linux-2.6.36.tar.bz2 with bsdtar
  -> Extracting patch-2.6.36-2-ARCH.bz2 with bzip2
  -> Extracting patch-2.6.36-ck2.bz2 with bzip2
==> Starting build()...
==> Patching source with-ARCH patches
patching file drivers/video/logo/logo_linux_clut224.ppm
patching file drivers/video/logo/logo_linux_mono.pbm
patching file drivers/video/logo/logo_linux_vga16.ppm
patching file fs/file_table.c
patching file fs/namei.c
patching file fs/namespace.c
patching file fs/notify/group.c
patching file fs/notify/mark.c
patching file fs/open.c
patching file fs/splice.c
patching file fs/statfs.c
patching file include/linux/fs.h
patching file include/linux/namei.h
patching file include/linux/splice.h
patching file security/commoncap.c
patching file security/device_cgroup.c
patching file security/security.c
==> Patching source with BFQ patches
patching file block/Kconfig.iosched
patching file block/blk-ioc.c
patching file block/cfq-iosched.c
patching file fs/ioprio.c
patching file include/linux/iocontext.h
patching file block/Makefile
patching file include/linux/cgroup_subsys.h
patching file block/bfq-cgroup.c
patching file block/bfq-ioc.c
patching file block/bfq-iosched.c
patching file block/bfq-sched.c
patching file block/bfq.h
==> Patching source with ck1 patch set
patching file arch/powerpc/platforms/cell/spufs/sched.c
patching file Documentation/scheduler/sched-BFS.txt
patching file Documentation/sysctl/kernel.txt
patching file fs/proc/base.c
patching file include/linux/init_task.h
patching file include/linux/ioprio.h
patching file include/linux/sched.h
patching file init/Kconfig
patching file init/main.c
patching file kernel/delayacct.c
patching file kernel/exit.c
patching file kernel/kthread.c
patching file kernel/posix-cpu-timers.c
patching file kernel/sched_bfs.c
patching file kernel/sched.c
patching file kernel/sysctl.c
patching file lib/Kconfig.debug
patching file mm/vmscan.c
patching file include/linux/swap.h
patching file mm/memory.c
patching file mm/swapfile.c
patching file include/linux/mmzone.h
patching file include/linux/mm_inline.h
patching file mm/filemap.c
patching file mm/swap.c
patching file mm/page-writeback.c
patching file arch/x86/Kconfig
patching file kernel/Kconfig.hz
patching file arch/x86/kernel/cpu/proc.c
patching file arch/x86/kernel/smpboot.c
patching file include/linux/nfsd/stats.h
patching file include/net/inet_timewait_sock.h
patching file init/calibrate.c
patching file kernel/Kconfig.preempt
patching file drivers/cpufreq/cpufreq_ondemand.c
patching file Makefile
==> Running make mrproper to clean source tree
==> Running make prepare for you to enable patched options of your choosing
  HOSTCC  scripts/basic/fixdep
/bin/sh: scripts/basic/fixdep: Permission denied
make[2]: *** [scripts/basic/fixdep] Error 1
make[1]: *** [scripts_basic] Error 2
make: *** No rule to make target `include/config/auto.conf', needed by `include/config/kernel.release'.  Stop.
[taylor-unix@Legion kernel26-ck]$


Issuing a mkpkg command '--asroot' fails to make any difference whatsoever.

Am I missing something here?

Last edited by edward.taylor89 (2010-11-09 22:38:29)

'The perfect blossom is a rare thing. You could spend your life looking for one, and it would not be a wasted life.'


#2 2010-11-09 17:15:13

From: UK
Registered: 2010-10-21
Posts: 34

Re: [SOLVED] Problem whilst trying to build kernel26-ck from source


The trick was to remove 'noexec' along the mount options for /home from fstab.


Last edited by edward.taylor89 (2010-11-09 17:22:01)

'The perfect blossom is a rare thing. You could spend your life looking for one, and it would not be a wasted life.'


#3 2010-11-10 03:26:13

From: Australia
Registered: 2008-06-10
Posts: 2,164

Re: [SOLVED] Problem whilst trying to build kernel26-ck from source

Good that you worked it out but just as a side note, running makepkg --asroot is never a solution.



Board footer

Powered by FluxBB