You are not logged in.

#126 2011-02-04 09:11:02

From: Serbia
Registered: 2007-09-11
Posts: 30

Re: Xfce 4.8 pre1


Still haven't solved the problem with fixed CPU scaling governor. Stays on performance all the time, does not matter if it's plugged in or not. ACPI handler (/etc/acpi/ script does not work either. Seems like a permission problem to me. My user is a member of wheel, games, network, audio, storage, scanner, camera, power...

I can change the scaling governor with sudo cpufreq-set.

I have resolved all other issues that appeared after upgrading to XFCE 4.8, found most of the answers on the forum, and this is the only one left.

EDIT: Found out what the problem with acpid handler script was (undefined events: BAT1 instead of BAT0 and ACAD instead of AC). After I had fixed those switch values in /etc/acpi/ it started working again.

The other problem, setting CPU frequency at boot time, was solved by adding this to /etc/rc.local:

AC=$(cat /proc/acpi/ac_adapter/ACAD/state | awk '{print $2'})
if [ "$AC" = "off-line" ]; then
    cpufreq-set -c 0 -g powersave
    cpufreq-set -c 1 -g powersave
elif [ "$AC" = "on-line" ]; then
    cpufreq-set -c 0 -g ondemand
    cpufreq-set -c 1 -g ondemand

So, I guess I did not need xfce4-power-manager to manage my CPU frequency after all. The only rotten thing here is that xfce4-cpufreq-plugin still won't let me change governors. And I have that notorious exec ck-launch-session dbus-launch startxfce4 line in my .xinitrc.

Last edited by teMplaryum (2011-02-05 09:18:41)

Online at:
Twit | Facebook | Blog

Registered Linux user #469726


Board footer

Powered by FluxBB