You are not logged in.

#1 2005-03-16 10:48:14

From: Åsele, Lappland, Sweden
Registered: 2005-03-13
Posts: 29

Problem to get 3d work on HP Compaq Business Desktop dx2000

I bought a brand new HP with linux - mandrake - a month ago. I installed mandrake but then I got so confused that I through it all away and started on again with Archlinux that I have become used to.

Everything (well, of course not everything but most :? ) works all right but a few things doesn't.

First I couldn't get CUPS to work properly but that I solved - but don't ask me how. I think I did the same things over 5 times and then suddenly it worked as it should.

Then I had problems with the sound - but that worsk now after following the wiki.

Then I had problems with playing CD and DVD but that I managed to get to work.

But now I am stuck.

The 3d doesn't work. I tried to install all 3d modules I could find in arch but no result. I tried through hwd -e and lokalsed the modules named there with no result. I even tried NVIDIA (the computer have a intel graphics on board and no Nvidia-card) with the result that now the CD can't play sound-CD and the DVD doesn't work for multimedia despite newest xine and mplayer, koffeine etc I installed.

So I have 3 major problems:

1) the 3d card I want to start working
2) the CD-rom should be able to play sound-CD
3) the DVD should be able to play dvd-films.

Some hard-data:
HP Compaq Business Desktop dx2000
Intel celeron with MMX technology 2.6 Ghz and 400 Mhz system bus
Integrated ADI AD1888 Audio
Integrated Intel extreme Graphics 2 with GDI/GDI+ and Direct Show controller
Graphics memory 16 Mb + extra through Intel Dynamic Video Memory. Complete OpenGL 1.3 support.
2 DVD-drives installed Toshiba Samsung

Any one that could giv me a hint on how to start the solving of this?


#2 2005-03-17 10:46:05

From: Åsele, Lappland, Sweden
Registered: 2005-03-13
Posts: 29

Re: Problem to get 3d work on HP Compaq Business Desktop dx2000

These modules I have loaded:
% lsmod
odule                  Size  Used by
dummy                   3460  0
ehci_hcd               35332  0
i810                   86420  0
snd_pcm_oss            56612  0
snd_mixer_oss          21120  1 snd_pcm_oss
snd_intel8x0           34336  1
snd_ac97_codec         78176  1 snd_intel8x0
snd_pcm               101252  3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_timer              27140  1 snd_pcm
snd                    59108  8 snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
soundcore              10848  1 snd
snd_page_alloc         10244  2 snd_intel8x0,snd_pcm
parport_pc             28996  1
lp                     12296  0
parport                38600  2 parport_pc,lp
usb_storage            71232  0
uhci_hcd               34576  0
eepro100               30988  0
e100                   36992  0
mii                     5760  2 eepro100,e100
usbserial              31336  0
usbcore               125560  5 ehci_hcd,usb_storage,uhci_hcd,usbserial

when I try hwd -e this results come:
% hwd -e
Starting... (expert mode)
Detecting pci, usb, and pcmcia devices.

VendID  DevID   Module          Description
8086    1050    "e100"  "Intel Corp.|82801EB (ICH5) PRO/100 VE Ethernet Controller"
8086    1229    8086    1050    "eepro100"      "Intel Corp.|EtherExpress PRO/100 S Server Adapter"
8086    244e    "hw_random"     "Intel Corp.|82820 815e (Camino 2) Chipset PCI"
8086    24d0    "i810-tco"      "Intel Corp.|82801EB ISA Bridge (LPC)"
8086    24d2    "usb-uhci"      "Intel Corp.|USB Controller"
8086    24d3    "i2c-i801"      "Intel Corp.|82801EB SMBus"
8086    24d4    "usb-uhci"      "Intel Corp.|USB Controller"
8086    24d5    "snd-intel8x0"  "Intel Corp.|82801EB AC'97 Audio"
8086    24d7    "usb-uhci"      "Intel Corp.|USB Controller"
8086    24db    "ata_piix"      "Intel Corp.|82801EB ICH5 IDE"
8086    24dd    "ehci-hcd"      "Intel Corp.|USB Enhanced Controller"
8086    24de    "unknown"       "Intel Corp.|82801EB USB EHCI Controller #2"
8086    2570    "intel-agp"     "Intel Corp.|82865G [Springdale-G] Chipset HostBridge"
8086    2572    "Card:Intel 865"        "Intel Corp.|865 Chipset Graphics Controller"

no pcmcia driver in /proc/devices
VendID  DevID   Module          Description

VendID  DevID  Module  Description

Press any key to continue...
/dev/hda  /dev/hda1  /dev/hda2  /dev/hda3  /dev/hdc  /dev/hdd

dummy  ehci_hcd  i810  snd_pcm_oss  snd_mixer_oss  snd_intel8x0  snd_ac97_codec snd_pcm  snd_timer  snd  soundcore  snd_page_alloc  parport_pc  lp  parport  usb_storage  uhci_hcd  eepro100  e100  mii  usbserial  usbcore

hwd -s  - generates howto and sample X configure.

% hwd - s
Starting...  : (simple mode)
  Kernel     : 2.6.10-ARCH
  CPU & Cache: Processor 0 is Intel(R) Celeron(R) CPU 2.53GHz 2534MHz, 256 KB Cache

  ALSA(sound): Intel Corp.|82801EB AC'97 Audio module: snd-intel8x0
  Video      : Intel Corp.|865 Chipset Graphics Controller server: Xorg (i810)
  Monitor    : MAX1b6c H:28.0-96.0kHz V:50.0-75.0Hz
  Mouse      : Generic PS/2 Wheel Mouse device: /dev/psaux

  Hard Disk  : SAMSUNG SP0411N device: /dev/hda
  SCSI       : No scsi disk
  Swap       : Swap found device: /dev/hda2
  Scanner    : No scanner
  CDROM 1    : TSSTcorpDVD-ROM TS-H352A device: /dev/hdc
  CDROM 2    : TSSTcorpDVD-ROM TS-H352A device: /dev/hdd
  Floppy     : 3.5  1.44MB floppy drive device: /dev/fd0
  USB        : USB found module: ehci-hcd

  Ethernet   : Intel Corp.|82801EB (ICH5) PRO/100 VE Ethernet Controller module: e100 device: eth0
  PCMCIA     : Detect PCMCIA cards run hwd -d
  Modem      : No pci modem

  Howto      : View howto run hwd -h
  Testing    : File /etc/X11/xorg.conf already exist!!
             : Read more in howto.
in hwd - h the following part is about monitor:
       Video Card   : Intel Corp.|865 Chipset Graphics Controller
       Monitor      : MAX1b6c
       H kHz        : 28.0-96.0
       V Hz         : 50.0-75.0
       Xserver      : Xorg
       Xmodule      : i810
       Mouse        : Generic PS/2 Wheel Mouse at /dev/psaux module: msintellips
anyone that can help me on?



#3 2005-03-17 10:57:52

Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,622

Re: Problem to get 3d work on HP Compaq Business Desktop dx2000 … 17457.html
Looks like your graphics card is:
Intel® Extreme Graphics 2 (integrated with Intel 865GV chipset)

if you are adventurous, you might try one of the binary linux drivers from intel.. … s+865main&

"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍


#4 2005-03-17 18:55:36

From: Åsele, Lappland, Sweden
Registered: 2005-03-13
Posts: 29

Re: Problem to get 3d work on HP Compaq Business Desktop dx2000

Well, adventurous I don't think I am - but maybee to silly to understand what might happen.

I have tried that too. I downloaded it, compiled it and tried to install it. When installing one module can't be installed automatically - probably since the installer doesn't recognize the Arch architecture. But I can't either understand what module to install where...

But the installer README says that one should be able to use i810 module i.e the module I've been using...


Board footer

Powered by FluxBB