You are not logged in.

#101 2010-12-02 21:45:56

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: [kde-unstable] KDE 4.6

jxy wrote:

This is great news.  Apart from screen brightness, everything works.

That is going to be a problem for all laptops where xbacklight does not work, that is most laptops using the nvidia blob.
Safest solution: use hal until it is fixed. I think gnome-power-manager uses the same method.

Offline

#102 2010-12-02 21:56:45

Zom
Member
From: Sweden
Registered: 2007-10-27
Posts: 406

Re: [kde-unstable] KDE 4.6

zephyr wrote:

I have found a solution to enable sleep/suspend to ram without hal running by editing /usr/share/kde4/services/powerdevilupowerbackend.desktop .
In line 5 InitialPreference=200 change 200 to 20 or any value below 100.
This should be fixed in 4.6 Beta 2.

Source: http://www.afiestas.org/one-step-closer … -hal-free/

Oh my, thank you! big_smile

Offline

#103 2010-12-02 21:58:34

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 568
Website

Re: [kde-unstable] KDE 4.6

@zephyr
great! Thanks for the info. I'd like to include that patch but they (yet) didn't commit anything

Offline

#104 2010-12-02 22:37:25

Zom
Member
From: Sweden
Registered: 2007-10-27
Posts: 406

Re: [kde-unstable] KDE 4.6

bash wrote:

@zephyr
great! Thanks for the info. I'd like to include that patch but they (yet) didn't commit anything

You could just add the edited file to the relevant package I suppose, but that might not be the arch way(tm).

Offline

#105 2010-12-02 22:38:44

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: [kde-unstable] KDE 4.6

bash wrote:

@zephyr
great! Thanks for the info. I'd like to include that patch but they (yet) didn't commit anything

No problem!

The info I posted  works as it should without any problems.
However drf has implemented a nicer solution statically loading the backends in trunk. That is why the patch must be "heavier" than a simple change in the .desktop file. big_smile

I think this is the commit implementing this:

http://websvn.kde.org/?view=revision&revision=1199129

Offline

#106 2010-12-03 09:33:28

hellnest
Member
From: $ dmesg | grep ATA
Registered: 2010-11-11
Posts: 194
Website

Re: [kde-unstable] KDE 4.6

Anyone facing a filesystem problem?? today i've got twice filesystem error i guess it caused by nepomuk >.<" it makes me can't enter KDE


roll Snapping my own life roll
hmmgithubhmm
coolMyBlogcool

Offline

#107 2010-12-03 09:44:18

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 568
Website

Re: [kde-unstable] KDE 4.6

zephyr wrote:

I think this is the commit implementing this:

http://websvn.kde.org/?view=revision&revision=1199129

Added in kdebase-workspace 4.5.80-3

Offline

#108 2010-12-03 13:10:55

tuxador
Member
From: algeria
Registered: 2010-07-08
Posts: 45

Re: [kde-unstable] KDE 4.6

can you please add the option for "instant nepomuk" like in this article?
it seems that the other distros have this by default :-/


laptop LENOVO Ideapad Z570 i7 / 6GO RAM/GeForce 540
ARCHLINUX+KDE frameworks 5.3 (working great !)

Offline

#109 2010-12-03 13:26:10

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 568
Website

Re: [kde-unstable] KDE 4.6

@tuxador
I read that post time ago, but that's a kernel option and I can't do anything (and I know nothing about).

Feature request opened at https://bugs.archlinux.org/task/21969
EDIT: Well, has been rejected and if you read the comments you understand why. The wiki page has been updated anyway.
BTW, beta2 tagged; release day is 7th!

Offline

#110 2010-12-03 21:35:51

tuxador
Member
From: algeria
Registered: 2010-07-08
Posts: 45

Re: [kde-unstable] KDE 4.6

thanks! je answer is clear smile
thank you bash for the effort


laptop LENOVO Ideapad Z570 i7 / 6GO RAM/GeForce 540
ARCHLINUX+KDE frameworks 5.3 (working great !)

Offline

#111 2010-12-04 00:55:25

scio
Member
From: Buffalo, NY
Registered: 2008-08-05
Posts: 366

Re: [kde-unstable] KDE 4.6

bash wrote:

Added in kdebase-workspace 4.5.80-3

I just updated and it looks like it erased my  /usr/share/kde4/services/powerdevilupowerbackend.desktop

Was that intentional?

Edit:

I'm also getting:"No valid Power Management backend plugins are available. A new installation might solve this problem." on start up.  Re-installed kdebase-workspace, but no change.

Last edited by scio (2010-12-04 01:00:02)

Offline

#112 2010-12-04 14:15:05

hellnest
Member
From: $ dmesg | grep ATA
Registered: 2010-11-11
Posts: 194
Website

Re: [kde-unstable] KDE 4.6

BETA 2 is out? Just talk with anmma in IRC, he's run beta 2 right now


roll Snapping my own life roll
hmmgithubhmm
coolMyBlogcool

Offline

#113 2010-12-04 14:34:41

Zom
Member
From: Sweden
Registered: 2007-10-27
Posts: 406

Re: [kde-unstable] KDE 4.6

hellnest wrote:

BETA 2 is out? Just talk with anmma in IRC, he's run beta 2 right now

This is the release schedule. Beta 2 is tagged, but not yet released. You can however install it from SVN AFAIK.

Offline

#114 2010-12-04 21:44:09

hellnest
Member
From: $ dmesg | grep ATA
Registered: 2010-11-11
Posts: 194
Website

Re: [kde-unstable] KDE 4.6

I just now realize that my internal DVD-RW isn't detected. K3B said that i need HAL to be running smile is there any clue to bypass it & make my drive work again?


roll Snapping my own life roll
hmmgithubhmm
coolMyBlogcool

Offline

#115 2010-12-05 02:08:27

scio
Member
From: Buffalo, NY
Registered: 2008-08-05
Posts: 366

Re: [kde-unstable] KDE 4.6

Is anyone else running HAL-less and getting: "No valid Power Management backend plugins are available. A new installation might solve this problem."?

Offline

#116 2010-12-05 03:35:40

hellnest
Member
From: $ dmesg | grep ATA
Registered: 2010-11-11
Posts: 194
Website

Re: [kde-unstable] KDE 4.6

It's just happen to me now... >.<"


roll Snapping my own life roll
hmmgithubhmm
coolMyBlogcool

Offline

#117 2010-12-05 10:40:03

RufusD
Member
Registered: 2010-03-21
Posts: 86

Re: [kde-unstable] KDE 4.6

do I really need all of these repos?

[kde-unstable]
Include = /etc/pacman.d/mirrorlist

[testing]
## Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[core]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[extra]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[community-testing]
## Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[community]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

The reason for asking is that my kmail2 sucks horribly. To an extent that I'm thinking I fucked up something pretty seriously (I guess if *noone* was able to delete mails from kmail2, I would have heard about it). Besides, I vaguely remember not using that many repo's when I tested KDESC 4.5 beta. My mirrors are the following, maybe they have gone bad?

Server = http://ftp5.gwdg.de/pub/linux/archlinux/$repo/os/i686
Server = http://ftp.halifax.rwth-aachen.de/archlinux/$repo/os/i686
Server = ftp://ftp.uni-kl.de/pub/linux/archlinux/$repo/os/i686
Server = ftp://mirrors.kernel.org/archlinux/kde-unstable/

I tried re-installing kde, but maybe not in the right way (still trying to find my way through pacman after having used apt-get for many a year). How would I go on about removing KDESC and installing it again? I tried finding the one lib to rule them all (taking down all of KDESC if removed), but couldn't find it. How do I remove KDESC for good? What's the best metapackage to install afterwards?

Best regards,
Rufus D

Last edited by RufusD (2010-12-05 10:40:28)

Offline

#118 2010-12-05 12:15:58

SS4
Member
From: !Rochford, Essex
Registered: 2010-12-05
Posts: 699

Re: [kde-unstable] KDE 4.6

RufusD wrote:

do I really need all of these repos?

[kde-unstable]
Include = /etc/pacman.d/mirrorlist

[testing]
## Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[core]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[extra]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[community-testing]
## Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[community]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

The reason for asking is that my kmail2 sucks horribly. To an extent that I'm thinking I fucked up something pretty seriously (I guess if *noone* was able to delete mails from kmail2, I would have heard about it). Besides, I vaguely remember not using that many repo's when I tested KDESC 4.5 beta. My mirrors are the following, maybe they have gone bad?

Server = http://ftp5.gwdg.de/pub/linux/archlinux/$repo/os/i686
Server = http://ftp.halifax.rwth-aachen.de/archlinux/$repo/os/i686
Server = ftp://ftp.uni-kl.de/pub/linux/archlinux/$repo/os/i686
Server = ftp://mirrors.kernel.org/archlinux/kde-unstable/

I tried re-installing kde, but maybe not in the right way (still trying to find my way through pacman after having used apt-get for many a year). How would I go on about removing KDESC and installing it again? I tried finding the one lib to rule them all (taking down all of KDESC if removed), but couldn't find it. How do I remove KDESC for good? What's the best metapackage to install afterwards?

Best regards,
Rufus D

I don't use kmail so I cannot be sure but have you tried installing the old version either from source or using a package stored in cache.

ls -A /var/cache/pacman/pkg | grep kmail

will tell you if you have any kmail in cache and if so you can always use pacman -U /var/cache/pacman/pkg/kmail-version (use tab completion to find the package)

If you want to uninstall kde

pacman -Rnsu kde

and then

pacman -S kde

to reinstall.

If you want to roll back to stable kde then edit /etc/pacman.conf and comment [kde-unstable] and maybe [testing] and then run

pacman -Syyuu

which will manually refresh your repos and roll back


Rauchen verboten

Offline

#119 2010-12-05 13:18:21

Zom
Member
From: Sweden
Registered: 2007-10-27
Posts: 406

Re: [kde-unstable] KDE 4.6

scio wrote:

Is anyone else running HAL-less and getting: "No valid Power Management backend plugins are available. A new installation might solve this problem."?

I've been running HAL-less for a couple of days (Like, 4 days or so) without any trouble. Though, the battery applet fails to read the charge some times, but this usually fixes itself after a suspend-resume.

E: I'm suspending by using pm-utils though, and not by upower.

Last edited by Zom (2010-12-05 13:18:58)

Offline

#120 2010-12-05 13:33:56

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 499

Re: [kde-unstable] KDE 4.6

hellnest wrote:

I just now realize that my internal DVD-RW isn't detected. K3B said that i need HAL to be running smile is there any clue to bypass it & make my drive work again?

Same problem here. I tried installing k3b-svn and still happens.


Excuse my poor English.

Offline

#121 2010-12-05 18:23:54

tuxador
Member
From: algeria
Registered: 2010-07-08
Posts: 45

Re: [kde-unstable] KDE 4.6

k3b depends on HAL, it isn't a part of the "software distribution" , juste a "cousin" or sometihng like that, (like amarok)
i hope je k3b team will remove this dependency, it's almost the last thing hal-related.
i have the power-managment issue too, when i check solid,there is only hal in the  power mamagement item. i dont know how to switch to upower.
the applet shows correctly the battery-status but when i switch between different profiles ( performance, powersave) i dont notice any difference in the screen brithness for example


laptop LENOVO Ideapad Z570 i7 / 6GO RAM/GeForce 540
ARCHLINUX+KDE frameworks 5.3 (working great !)

Offline

#122 2010-12-06 11:51:59

zephyr
Member
Registered: 2008-03-20
Posts: 103

Re: [kde-unstable] KDE 4.6

I have opened a bug to have the GStreamer backend split from libcanberra since that adds gstreamer -dependencies on kdebase-runtime. You can use the PKGBUILD attached on the report and files from ABS/svn to build a gstreamer-free libcanberra.

FS#21996

Offline

#123 2010-12-06 20:10:43

mangus
Member
From: Bologna, Italy
Registered: 2007-04-07
Posts: 289

Re: [kde-unstable] KDE 4.6

I have a windows7 partition not mounted in fstab and it comes up in dolphin but I cant mount it as I always done in the past , dolphin throws a permission error for udisks. It used to work with hal (Im hal free now)
Has anybody a clue about this? Am I missing something in udisks , polkit or other configuration?
thanks

Offline

#124 2010-12-06 20:32:32

ChALkeR
Member
Registered: 2010-10-27
Posts: 63

Re: [kde-unstable] KDE 4.6

Repository     : kde-snapshots
Name           : kdelibs
Version        : 4.5.82svn1202684-2
URL            : http://www.kde.org
Licenses       : GPL  LGPL  FDL
Groups         : kde-snapshots
Provides       : kdelibs-experimental
Depends On     : qt>=4.7.0  shared-mime-info  hal  xz-utils  heimdal  enchant  jasper  openexr  kdesupport-strigi  libxtst  giflib  kdesupport-soprano  ca-certificates  xdg-utils  kdesupport-polkit-qt
                 qca  libxss  hicolor-icon-theme  fam  kdesupport-libattica  kdesupport-phonon  kdesupport-oscaf  dbusmenu-qt-git  libwebkit  grantlee  libpulse
Optional Deps  : None

Why does it still depend on hal?
It works fine without hal for me now.

Offline

#125 2010-12-06 20:38:18

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: [kde-unstable] KDE 4.6

1. It's not the kde-snapshot thread here, it's for the semi-official [kde-unstable]

2. HAL-less KDE 4.6 is still a pain, unless they fix it soon. Dolphin is very slow with Udisks enabled.

Offline

Board footer

Powered by FluxBB