You are not logged in.

#1 2005-03-20 21:58:10

Registered: 2004-02-15
Posts: 61

megaraid and Arch 0.7

I was helping a friend install Arch on his HP Server that has six scsi drives on a megaraid device.  Problem is that the drives were not found when we went to partition them.  However, some suggestions said to use 0.6 to install, using arch-scsi boot kernel (we tried that with 0.7, but arch-scsi was not found).  This worked and we were able to reboot.  On to the next step.

We then ran pacman -Syu, then rebooted to see if it would work.  It didn't.  We got kernel panic errors saying that we should fix what root= line in grub was pointing to.  It was correct.  Hadn't changed in many reboots.  The only difference was that we updated the system.  This includes the kernel (2.6 - latest one for scsi).

So I have three questions.  First, why doesn't the 0.7 install CD allow to boot into scsi?  And second, if the kernel is it going to grab a scsi kernel if that's what is on the system, or will it grab the IDE one?  Finally, do the latest Arch SCSI kernels have megaraid enabled?  Megaraid is the raid controller on his server.

To recap, we had no problem installing Arch with 0.6, but 0.7 failed miserably.  Also tried the FTP install with 0.6 CD and every server we went to failed to download pacman.  We tried correcting the server paths and still failed to download pacman.

Thanks for any help.


Board footer

Powered by FluxBB