You are not logged in.

#1 2005-03-21 04:45:16

dk
Member
Registered: 2004-04-20
Posts: 106

xfprint4 cups_plugin.so module error

I just upgraded xfce4-4.2.1-1 after the upgrade I receive the following error from xfprint:

** ERROR **: Unable to load printing system module cups_plugin.so
aborting...
Aborted

it's there

$ find /opt/xfce4/ -name "cups*"
/opt/xfce4/lib/xfce4/xfprint-plugins/cups_plugin.la
/opt/xfce4/lib/xfce4/xfprint-plugins/cups_plugin.so
/opt/xfce4/lib/xfce4/xfprint-plugins/cups_plugin.a

How to get xfprint working again?

Offline

#2 2005-03-21 07:54:32

JGC
Developer
Registered: 2003-12-03
Posts: 1,660

Re: xfprint4 cups_plugin.so module error

Run ldd over te .so file you see there and report the things marked as "not found" in the bugtracker?

Offline

#3 2005-03-21 09:33:13

orelien
Forum Fellow
From: France
Registered: 2002-12-05
Posts: 220
Website

Re: xfprint4 cups_plugin.so module error

Indeed, there is an issue with xfprint. I got in touch with Xfce folks about this problem... but nothing came of it yet.
I also investigated a little bit, and it seems that it is a call to g_module_open that fails, but I still can't figure why.
As a consequence, it seems the issue is linked with glib.
Maybe, it would be interesting to try to use an older version of glib to see if it's not a regression...

Offline

#4 2005-03-21 22:22:35

ozar
Member
From: USA
Registered: 2005-02-18
Posts: 1,681

Re: xfprint4 cups_plugin.so module error

I did two fresh installs with the latest Arch Xfce4 packages and get the same error with xfprint:

"unable to load printing system module cups_plugin.so"

In addition to that, Xffm crashes when I try to use it to look at the properties of any file.  The error message that shows in terminal window:

"g-module_open (/opt/xfce4/lib/xfce4/xffm_prop.so"

One more thing, when trying to "quit" from the right-click menu, I get:

"xfceDesktopMenu:  unable to find "quit" symbol in parent executable"

The "quit" button posititioned on the panel works just fine.

Note that I also run Debian on another box.  The latest Xfce4 packages fetched with apt-get from www.os-works.com seem to work fine.  It's only the Arch Xfce4 packages giving me these problems.

Hope some of this might help in determining the fix...    :?


oz

Offline

#5 2005-03-21 23:34:39

JGC
Developer
Registered: 2003-12-03
Posts: 1,660

Re: xfprint4 cups_plugin.so module error

If you have unresolved symbols, the g_module_open will fail. Please test the thing I described to find out if it's a broken dependency or something, and if so, file a bug.

Offline

#6 2005-03-21 23:50:36

KalephOne
Member
From: Fortaleza, Brasil
Registered: 2004-04-02
Posts: 99

Re: xfprint4 cups_plugin.so module error

I'm having the same problems of ozar, but when I try to look at the properties of a file in xffm, this is the error that i get:
** ERROR **: g_module_open(/opt/xfce4/lib/xfce4/xffm/libxffm_prop.so) == NULL

And none of the libs (cups_plugin.so or libxffm_prop.so) have broken dependencies.


Kaleph
jabber: kaleph@jabber.org

Offline

#7 2005-04-04 00:48:00

Net@Worm
Member
From: Moscow, Russia
Registered: 2004-05-02
Posts: 214

Re: xfprint4 cups_plugin.so module error

KalephOne wrote:

I'm having the same problems of ozar, but when I try to look at the properties of a file in xffm, this is the error that i get:
** ERROR **: g_module_open(/opt/xfce4/lib/xfce4/xffm/libxffm_prop.so) == NULL

And none of the libs (cups_plugin.so or libxffm_prop.so) have broken dependencies.

I have the same problem.

Offline

#8 2005-04-14 18:24:28

orelien
Forum Fellow
From: France
Registered: 2002-12-05
Posts: 220
Website

Re: xfprint4 cups_plugin.so module error

xfprint 4.2.1-2 is out and it should fix the issue with plugin that couldn't be loaded.
The root cause was an unfortunate regression in xfprint Makefiles...

Offline

Board footer

Powered by FluxBB