You are not logged in.

#1 2010-12-13 21:12:13

DasFox
Member
Registered: 2010-11-24
Posts: 107

Mouse Cursor Disappears In Gnome After Certain Time Idle

I'm running Arch 2010.05 i686 with Gnome 2.32.1 with the default Metacity 2.30.3-1 and I only did a base install of Gnome.

I've noticed this problem happens typically after I let the box sit idle for around 15mins., say walk away from it, then come back to move the mouse and notice the cursor is gone.

It's a Logitech MX500 plugged in USB.

I have these pkgs installed, for what I believe affects the mouse;

xf86-input-evdev-2.5.0-1-i686
xf86-input-mouse-1.6.0-1-i686
libxcursor-1.1.11-1-i686

I'm running the Nouveau drivers so not sure if this could be causing the problem.

xf86-video-nouveau-0.0.16_git20100819-1-i686
nouveau-dri-7.9-1-i686

This is the Xorg log;
http://pastebin.com/njhvXQAu

I looked through dmesg, messages and syslog and didn't see anything related to any mouse problems...

I read on one forum post that someone downgraded libxcursor to version 1.1.10, so I went looking to see if there was a pkg somewhere of this version I could install and try but didn't find any.



THANKS

Last edited by DasFox (2010-12-13 22:48:52)


12 Year Linux Vet, Don't Let The Post Count Fool Ya! But Sure I Don't Know Everything, Who Does? That's Why I Ask. smile

Offline

#2 2010-12-14 00:55:05

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: Mouse Cursor Disappears In Gnome After Certain Time Idle

1. Does this only happen in Gnome?

2. Try the NVIDIA driver and see if it still happens.

Offline

#3 2010-12-14 01:50:49

DasFox
Member
Registered: 2010-11-24
Posts: 107

Re: Mouse Cursor Disappears In Gnome After Certain Time Idle

anonymous_user wrote:

1. Does this only happen in Gnome?

2. Try the NVIDIA driver and see if it still happens.


Going down the video driver road is not the road I want to, hehe...

Need to recompile the kernel then rip out drivers and make other changes, because I'm using a HDTV as a monitor...

Yeah, this is not where I want to go and test first, I'd rather try and get the last version of libxcursor.

I actually have OpenBox installed so I'll run it awhile and see if it happens in there too...


THANKS


12 Year Linux Vet, Don't Let The Post Count Fool Ya! But Sure I Don't Know Everything, Who Does? That's Why I Ask. smile

Offline

#4 2010-12-14 01:52:48

thestinger
Trusted User (TU)
From: Toronto, Canada
Registered: 2010-01-23
Posts: 478

Re: Mouse Cursor Disappears In Gnome After Certain Time Idle

Nouveau has an issue on certain hardware where your mouse cursor will be hidden after the screen is turned off. You can "fix" it by using unclutter. There's a few bug reports you can find with a google search but no real fixes yet afaik.

It could also be an Xorg problem, and you could start by removing the legacy xf86-input-mouse driver and seeing if it works fine with just evdev.

Offline

#5 2010-12-16 03:22:01

DasFox
Member
Registered: 2010-11-24
Posts: 107

Re: Mouse Cursor Disappears In Gnome After Certain Time Idle

thestinger wrote:

Nouveau has an issue on certain hardware where your mouse cursor will be hidden after the screen is turned off. You can "fix" it by using unclutter. There's a few bug reports you can find with a google search but no real fixes yet afaik.

It could also be an Xorg problem, and you could start by removing the legacy xf86-input-mouse driver and seeing if it works fine with just evdev.


I have OpenBox besides Gnome and typically without fail the cursor will eventually disappear in Gnome but I did not see the problem in OpenBox.

What/where is this unclutter how does this work?

I'll try removing xf86-input-mouse...

So, in many cases the xf86-input-mouse driver isn't really needed?


THANKS

Last edited by DasFox (2010-12-16 03:23:09)


12 Year Linux Vet, Don't Let The Post Count Fool Ya! But Sure I Don't Know Everything, Who Does? That's Why I Ask. smile

Offline

#6 2010-12-16 04:15:02

thestinger
Trusted User (TU)
From: Toronto, Canada
Registered: 2010-01-23
Posts: 478

Re: Mouse Cursor Disappears In Gnome After Certain Time Idle

Openbox is probably not blanking the screen or starting a screensaver. Try setting the blanking time to like 15 seconds and see if you can replicate the problem.

x86-input-mouse and xf86-input-keyboard aren't used if you have hotplugging turned on.

According the the xorg log you use an xorg.conf, so posting that might help with troubleshooting.

Last edited by thestinger (2010-12-16 04:38:59)

Offline

#7 2010-12-17 01:25:52

DasFox
Member
Registered: 2010-11-24
Posts: 107

Re: Mouse Cursor Disappears In Gnome After Certain Time Idle

Ok I ran;

xset s blank
xset s 15

And this didn't do anything, if 15 is correct.

Here is xset q;

sar@arch ~]$ xset q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  30
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x20    BlackPixel:  0    WhitePixel:  16777215
Font Path:
  /usr/share/fonts/misc/,/usr/share/fonts/TTF/,/usr/share/fonts/OTF/,/usr/share/fonts/Type1/,/usr/share/fonts/100dpi/,/usr/share/fonts/75dpi/,built-ins
DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Enabled
  Monitor is On

This is what I use for xorg.conf;

Section     "Device"
Identifier  "n"
Driver      "nouveau"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "n"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
       Modes       "1680x1050" "1280x800" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection


Section "Monitor"
Identifier   "Monitor0"

# 1680x1050 59.95 Hz (CVT 1.76MA) hsync: 65.29 kHz; pclk: 146.25 MHz
Modeline "1680x1050_60.00"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync

HorizSync    30.0 - 81.0
VertRefresh  56.0 - 75.0
EndSection

Hotplugging support in the kernel, - 'Support for PCI Hotplug'? If so, I never compile in Hotplug support, I don't really have a need for it, all I ever plug in and out are USB drives...


THANKS


P.S. I tried - 'xset s noblank' and so far this has worked, I'll keep posted if it doesn't later...

Last edited by DasFox (2010-12-17 22:53:08)


12 Year Linux Vet, Don't Let The Post Count Fool Ya! But Sure I Don't Know Everything, Who Does? That's Why I Ask. smile

Offline

#8 2010-12-20 00:46:48

DasFox
Member
Registered: 2010-11-24
Posts: 107

Re: Mouse Cursor Disappears In Gnome After Certain Time Idle

How can I have 'xset s noblank' always set so when Arch starts blanking is always off?


THANKS


12 Year Linux Vet, Don't Let The Post Count Fool Ya! But Sure I Don't Know Everything, Who Does? That's Why I Ask. smile

Offline

#9 2010-12-20 00:53:43

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,316

Re: Mouse Cursor Disappears In Gnome After Certain Time Idle

Put it in your ~/.xinitrc immediately before the call that starts your wm.

Offline

#10 2010-12-20 00:55:02

DasFox
Member
Registered: 2010-11-24
Posts: 107

Re: Mouse Cursor Disappears In Gnome After Certain Time Idle

skunktrader wrote:

Put it in your ~/.xinitrc immediately before the call that starts your wm.


Ok I was thinking something like this might go instead in /etc/rc.local


THANKS


12 Year Linux Vet, Don't Let The Post Count Fool Ya! But Sure I Don't Know Everything, Who Does? That's Why I Ask. smile

Offline

Board footer

Powered by FluxBB