You are not logged in.

#1 2003-08-26 20:01:38

jskier
Member
From: Minnesota, USA
Registered: 2003-07-30
Posts: 361
Website

GL woes after upgrading packages

I upgraded to kernel 2.4.22-1 IDE and xfree86 4.3.0-6. I reinstalled the latest NVIIDIA drivers using "export IGNORE_CC_MISMATCH="1". I rebooted accordingly as needed. XWindows works fine but GL apps such as tuxracer load with scrambled, unreadable screens.
If anyone has any ideas on where to go with this, please post.

Thanks in advance,
Jay


--
JSkier

Offline

#2 2003-08-27 11:30:32

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: GL woes after upgrading packages

jskier wrote:

I upgraded to kernel 2.4.22-1 IDE and xfree86 4.3.0-6. I reinstalled the latest NVIIDIA drivers using "export IGNORE_CC_MISMATCH="1". I rebooted accordingly as needed. XWindows works fine but GL apps such as tuxracer load with scrambled, unreadable screens.

Hi,

I recompiled the Nvidia-driver too, to be honest I forgot to export the
mismatch flag, but it worked for me. But I didn't --upgrade it. I made an
--uninstall and than a new install.
What says glxinfo at your box?

If this is allright, I suggest to recompile the kernel, remove the nvidia
installation, reinstall nvidia (the mismatch-flag is then not needed)

bye neri

Offline

#3 2003-08-29 04:51:49

jskier
Member
From: Minnesota, USA
Registered: 2003-07-30
Posts: 361
Website

Re: GL woes after upgrading packages

No dice after recompiling and reinstalling without the export- still same scrabbled screen in with GL.

Jay


--
JSkier

Offline

#4 2003-08-29 06:29:54

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: GL woes after upgrading packages

well i don't use the arch nvidia package (if there is still one) i just used the binary nvidia installer and i am currently having no issue with those games after upgrading both x and the kernel. perhaps rebuild the packages (tuxracer).

unless you are not using the current gcc build you should not need to use the nvidia export line at all as the kernel was compiled with the current gcc.


AKA uknowme

I am not your friend

Offline

#5 2003-09-04 01:32:41

jskier
Member
From: Minnesota, USA
Registered: 2003-07-30
Posts: 361
Website

Re: GL woes after upgrading packages

An update on this problem- I'm an idiot and it comes down to what resolutions my monitor supports. Thanks for the help and sorry for the stupidity.

Jay


--
JSkier

Offline

Board footer

Powered by FluxBB