You are not logged in.

#1 2003-08-26 21:50:02

contrasutra
Member
From: New Jersey
Registered: 2003-07-26
Posts: 507

problem with new XFree86 package

I just updated to the new XFree86 (-6) package and I get this when installing it:

xfree86... could not extract usr/X11R6/lib/X11/fonts/100dpi/lutBS14-IS08859-15.pcf.gz: Invalid argument
errors occured while upgrading xfree86
done.
updating font cache... /usr/X11R6/bin/fc-cache: error while loading shared libraries: libfontconfig.so.1: cannot open shared object file: No such file or directory
done.

And X would not start afterward.

So I downgraded back to the old package.

Anyone else have these problems?

Also, my fonts go back to crappy non-AA when I reinstalled XFree86. Where do I go to change my fonts for X11, I must have done it before, and now I cant remember. tongue


And I wanted to post this in the bug tracker, but I never got my email with password, its been a little over an hour, maybe its just slow.


"Contrary to popular belief, penguins are not the salvation of modern technology.  Neither do they throw parties for the urban proletariat."

Offline

#2 2003-08-27 02:59:49

_JeffG_
Member
Registered: 2003-08-04
Posts: 61
Website

Re: problem with new XFree86 package

Worked fine for me.

Jeff

Offline

#3 2003-08-27 03:15:15

red_over_blue
Member
Registered: 2003-07-19
Posts: 152

Re: problem with new XFree86 package

contrasutra,

I had the exact errors.  I was just starting to try to figure out what was going on when my HD finally failed for good (it has been giving me issues lately).  Sorry I can't help, but I just wanted to let you know that you aren't the only one!


Don't forget to post your PKGBUILD in your thread when you announce a new package in incoming.
see HERE for details

Offline

#4 2003-08-27 03:31:45

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: problem with new XFree86 package

maybe it was a bad downloader from the server? which server did you grab it from? i grabbed mine from the archlinux server and it worked without issue?

or perhaps it is a kernel issue? did you install the new kernel too?

just some ideas (wildguesses more like it)


AKA uknowme

I am not your friend

Offline

#5 2003-08-27 04:13:14

contrasutra
Member
From: New Jersey
Registered: 2003-07-26
Posts: 507

Re: problem with new XFree86 package

yes, I got it from the arch server.

The package was corrupt.

I redownloaded it and its corrupt again.

Ive never had this problem before, so I think the problem is on the server end.


"Contrary to popular belief, penguins are not the salvation of modern technology.  Neither do they throw parties for the urban proletariat."

Offline

#6 2003-08-27 04:28:52

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: problem with new XFree86 package

possibly


AKA uknowme

I am not your friend

Offline

#7 2003-08-27 17:19:25

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: problem with new XFree86 package

this would not had happened with md5sum-check in pacman ... what about having checksums on servers also ... and pacman that downloads the package from one server and then chooses another to download the checksum and then compares them?


The impossible missions are the only ones which succeed.

Offline

#8 2003-08-27 17:29:19

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: problem with new XFree86 package

it is a feasture that has been in the works for some time. fear not a future pacman will have md5sum capabilities.


AKA uknowme

I am not your friend

Offline

Board footer

Powered by FluxBB