You are not logged in.

#1 2010-12-28 04:50:20

linux333
Member
Registered: 2010-12-28
Posts: 4

[SOLVED] SLiM: "Failed to execute login command"

Hello.

I've installed Arch Linux on a VirtualBox virtual machine today. I installed SLiM, along with Xfce4.

Right now, I have tried to login with SLiM, but every time I do, it returns back "Failed to execute login command".

Now, I'm not sure how to get back to a CLI login so I can possibly try and fix this. All the solutions I've Googled involve using Terminal. And also... I think I may have added slim to daemons in rc.conf.

So, how can I go back to a CLI log-in to fix this?

Last edited by linux333 (2010-12-28 05:57:18)

Offline

#2 2010-12-28 04:54:56

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,091
Website

Re: [SOLVED] SLiM: "Failed to execute login command"

Ctrl-Alt-F{1-6} will take you to the console...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#3 2010-12-28 05:00:50

linux333
Member
Registered: 2010-12-28
Posts: 4

Re: [SOLVED] SLiM: "Failed to execute login command"

I have tried that, but it does not seem to work for the virtual machine; it takes me to my native OS's console instead.

Offline

#4 2010-12-28 05:07:45

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,091
Website

Re: [SOLVED] SLiM: "Failed to execute login command"

My bad: missed the VM bit - boot into run level 3 - add ro 3 to the end of the kernel line when you boot


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#5 2010-12-28 05:18:41

linux333
Member
Registered: 2010-12-28
Posts: 4

Re: [SOLVED] SLiM: "Failed to execute login command"

SLiM is still loading even though I add a '3' at the end of the kernel line.

Offline

#6 2010-12-28 05:56:53

linux333
Member
Registered: 2010-12-28
Posts: 4

Re: [SOLVED] SLiM: "Failed to execute login command"

Update: I got it working. Turns out that I didn't have a .xinitrc file, so I created one, and it solved the problem.

Offline

Board footer

Powered by FluxBB