You are not logged in.

#1 2005-03-25 21:46:38

Registered: 2005-03-25
Posts: 8

Alsa problems

Hello! I tried installing alsa, using:

pacman -Sy alsa-driver alsa-lib alsa-oss alsa-utils

and then:


I then added myself to the audio group:

gpasswd -a username audio

Then I tried using alsamixer, but it gives me an error:

No mixer elems found

Alsa works excellent on all the distro's I've tried thusfar.

Yesterday I discovered:

alsamixer -c 1

gives me the mixer, however, xmms still gives me no sound.

uname -r


Module                  Size  Used by
uhci_hcd               33424  0
eth1394                22152  0
parport_pc             29252  0
parport                38600  1 parport_pc
pcspkr                  4044  0
rtc                    13260  0
nvidia               3917276  12
ohci1394               35716  0
ieee1394              111800  2 eth1394,ohci1394
sis900                 22020  0
ehci_hcd               36488  0
ohci_hcd               23048  0
usbcore               125560  4 uhci_hcd,ehci_hcd,ohci_hcd
snd_intel8x0           34624  0
snd_intel8x0m          19396  0
snd_ac97_codec         79224  2 snd_intel8x0,snd_intel8x0m
snd_pcm_oss            56224  0
snd_mixer_oss          21120  1 snd_pcm_oss
snd_pcm                98564  4 snd_intel8x0,snd_intel8x0m,snd_ac97_codec,snd_pc
snd_timer              27268  1 snd_pcm
snd                    59492  7 snd_intel8x0,snd_intel8x0m,snd_ac97_codec,snd_pc
soundcore              10848  1 snd
snd_page_alloc         10244  3 snd_intel8x0,snd_intel8x0m,snd_pcm
i2c_sis96x              5764  0
i2c_core               23296  1 i2c_sis96x
pci_hotplug            34760  0
tsdev                   8256  0
evdev                   9984  0
nls_cp437               6144  1
vfat                   14976  1
fat                    41884  1 vfat

Does anyone know what's going on?

Last edited by Golradir (2007-11-17 15:11:55)


#2 2005-03-25 22:39:28

From: Crescent City, CA
Registered: 2005-02-19
Posts: 77

Re: Alsa problems

You don't need to install alsa-driver since alsa is built-in for the 2.6 series of kernels.  Try removing it.

I have nothing to say, and I am saying it.


#3 2005-03-25 22:57:15

Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879

Re: Alsa problems

it's hotplug's fault: my laptop does the same thing... intel8x0 is your module, so you do that yourself... somehow hotplug adds in intel8x0m (maybe m==mobile?) which goofs it all up.... try blacklisting that module (or getting rid of yucky hotplug)


#4 2005-03-25 23:03:13

Registered: 2005-02-22
Posts: 138

Re: Alsa problems

Could this intel8x0m be a (sound)modem ?  If so, that driver will get in the way because it will load as the first soundcard and your normal soundcard/chip will be know as the second card. I don't have such a device but did read many problems with it on other forums.

Out / Gone
Mirgrating all my machines off ArchLinux . No longer part of the ArchLinux community / users .
Done. Goodbye.


#5 2005-03-25 23:05:36

Registered: 2005-03-25
Posts: 8

Re: Alsa problems

Blacklisting intel8x0m works excellent. Thank you!


#6 2005-03-25 23:09:50

Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879

Re: Alsa problems

puntmuts wrote:

Could this intel8x0m be a (sound)modem ?

maybe that's it!  I thought it was a laptop thing  (like pentium-m)... I feel dumb  :oops:  :oops:


#7 2005-03-26 09:23:13

From: Zaragoza/ESPAÑA (Spain)
Registered: 2005-01-27
Posts: 23

Re: Alsa problems

snd-intel8x0m is a module for the integrated MC97 modem on motherboards (Intel, SiS...).

I think the problem could be the modem is configured as /dev/dsp and the sound card (snd-intel8x0) as /dev/dsp1; that's why when you do alsamixer -c 1, the sound card mixer is shown (by default, when you type alsamixer is like if you type alsamixer -c 0, and, for you, it is the modem device which doesn't have a mixer).

So if you configure XMMS program to use /dev/dsp1 instead of /dev/dsp (the default), it will work properly.

You can also put snd-intel8x0m module into the hotplug blacklist if you don't use it.

And, finally, you can edit your /etc/modprobe.conf to use snd-card-0 (/dev/dsp) for snd-intel8x0, and snd-card-1 (/dev/dsp1) for snd-intel8x0m.

Good luck
Server =


Board footer

Powered by FluxBB