You are not logged in.

#1 2011-01-13 21:51:49

jededale
Member
Registered: 2010-12-31
Posts: 18

Dual Boot With FreeBSD

Im planing to dualboot my system with FreeBSD , I was wondering if anyone has done this and anyspecific hurdles or prolems to look out for. Would GRUB detect the UFS partition or would FreeBSD Bootloader recognize ext4 partition?
                                                                                                       Thanks, Jed

Last edited by jededale (2011-01-13 21:56:10)

Offline

#2 2011-01-14 07:59:31

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,859

Re: Dual Boot With FreeBSD

A simple search found this

http://forums.freebsd.org/showthread.php?t=5113


# edit: removed obfuscated link...

Last edited by jasonwryan (2011-01-14 08:26:01)


Mr Green

Offline

#3 2011-01-23 02:17:28

xdemo
Member
From: Bristol, UK
Registered: 2010-06-10
Posts: 42

Re: Dual Boot With FreeBSD

I used to run FreeBSD alongside Arch;

If you look in /boot/grub/menu.lst (on your arch install) you should see right at the bottom a commented section for adding a m$ windows option:

# (2) Windows
#title Windows
#rootnoverify (hd0,0)
#makeactive
#chainloader +1

You can adjust it to:

title FreeBSD
rootnoverify (hd0,2)
makeactive
chainloader +1

Thats if your UFS/BSD slice is on /dev/sda3 (in linux).

/dev/sda1 = hd0,0
/dev/sda2 = hd0,1
/dev/sda3 = hd0,2
etc

Just make sure you select "do not install bootloader" during FreeBSD install, because you want Arch's grub to deal with booting.

;-D


Linux 2.6.38-ck x86_64 / xfce

Offline

#4 2011-01-23 10:38:19

ferda
Member
Registered: 2010-02-05
Posts: 67

Re: Dual Boot With FreeBSD

grub2 can handle freebsd without chainloading.
You have to add something like this to your /etc/grub.d/40-custom:

menuentry "FreeBSD 8-STABLE GENERIC" {
    insmod ufs2
    insmod part_gpt
    set root='(hd1,2)'
    search --no-floppy --fs-uuid --set 4c65971a375a3875
    kfreebsd             /boot/kernel/kernel
    kfreebsd_loadenv     /boot/device.hints
    kfreebsd_module_elf /boot/modules/nvidia.ko
    set kFreeBSD.vfs.root.mountfrom=ufs:/dev/ad8p2
    set kFreeBSD.vfs.root.mountfrom.options=rw    
    set kFreeBSD.hw.psm.synaptics_support="1"
}

Booting from zfs worked only with

AUR/grub2-bios-bzr

The corresponding grub2 entry would look like this:

menuentry "FreeBSD 8.1-RELEASE BEASTIE on zfs:zroot" {
    insmod zfs
    insmod part_gpt
    search -s -l zroot
    kfreebsd /@/boot/kernel/kernel
    kfreebsd_module_elf /@/boot/kernel/opensolaris.ko
    kfreebsd_module_elf /@/boot/kernel/zfs.ko
    kfreebsd_module_elf /@/boot/modules/nvidia.ko
    kfreebsd_module /@/boot/zfs/zpool.cache type=/boot/zfs/zpool.cache
    set kFreeBSD.vfs.root.mountfrom=zfs:zroot
    set kFreeBSD.hw.psm.synaptics_support="1"
}

Offline

Board footer

Powered by FluxBB