You are not logged in.

#1 2011-01-27 13:09:56

splippity
Member
Registered: 2010-05-25
Posts: 144

[kde 4.6] not able to automount disks anymore[Solved]

When I would boot into kde before 4.6 my partitions were automounted without any issues. Now even with automounting selected in device manager I still have to manually go to mount and even then Im prompted for my root password.

What would I do to fix this??? Thanks.

Last edited by splippity (2011-01-27 13:34:51)

Offline

#2 2011-01-27 13:34:36

splippity
Member
Registered: 2010-05-25
Posts: 144

Re: [kde 4.6] not able to automount disks anymore[Solved]

ok I solved it..... had to modify the policykit but when I tried I didnt realize the problem was the following line:

    <allow_active>auth_admin_keep</allow_active>

I changed that to yes and now Im good to go.

Offline

#3 2011-01-27 18:31:16

foggybrain
Member
Registered: 2008-07-29
Posts: 84

Re: [kde 4.6] not able to automount disks anymore[Solved]

Could you explain what file or setting you changed in more detail as I am a polkit dummy ?

Thanks

Offline

#4 2011-01-27 19:20:18

devadittya
Member
From: Bangalore
Registered: 2009-11-16
Posts: 127
Website

Re: [kde 4.6] not able to automount disks anymore[Solved]

I have the same problem, and cannot find the file either.

Offline

#5 2011-01-27 20:03:52

devadittya
Member
From: Bangalore
Registered: 2009-11-16
Posts: 127
Website

Re: [kde 4.6] not able to automount disks anymore[Solved]

Thanks, got it.

It's this file:

/usr/share/polkit-1/actions/org.freedesktop.udisks.policy

Simply change:

<allow_active>auth_admin_keep</allow_active>

to

<allow_active>yes</allow_active>

Offline

Board footer

Powered by FluxBB