You are not logged in.

#1 2005-03-30 21:33:51

Eltnux
Member
Registered: 2005-02-01
Posts: 12

Error With ivman

I have been trying for the last few days to get automounting working with ivman but when i start ivman either as root or a user i get the following error message

Ikke's Volume Manager, http://ivman.sf.net
5847: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file dbus-message.c line 1723.
This is normally a bug in some application using the D-BUS library.
libhal.c 1856 : Couldn't allocate D-BUS message
5847: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file dbus-message.c line 1723.
This is normally a bug in some application using the D-BUS library.
libhal.c 1856 : Couldn't allocate D-BUS messa

Please can someone tell me what this means and how i can fix it. I have two DVD drives in my machine one is a DVD writter, the other is just a reader.

Thanks

Eltnux

Offline

#2 2005-03-30 23:06:18

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Error With ivman

I was told these messages were normal for user instances. It didn't make ivman not work for me but its kind of tricky setting up. Make sure that dbus hal and ivman are added to DAEMONS() in that order in your /etc/rc.conf. You'll also have to go and into your home/usrname/.ivman/ and uncomment (<!-- and -->) what you want enabled in the config files.

Offline

#3 2005-03-31 06:37:35

Eltnux
Member
Registered: 2005-02-01
Posts: 12

Re: Error With ivman

I have dbus, hal and ivman in my deamons section of my /etc/rc.conf file, i have also commented out the sections i think should be used from my ivman config files.

I have set the IvmConfigMappings.xml to the following entries is this correct

    <ivm:Map device="/dev/hda" maps="/dev/ide/host0/bus0/target0/lun0/cd"/>
    <ivm:Map device="/dev/hdc" maps="/dev/ide/host0/bus1/target0/lun0/cd"/>

Offline

#4 2005-03-31 11:06:22

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Error With ivman

I never touched that. Are you using udev?
http://wiki2.archlinux.org/index.php/UdevHowTo
Does anything work as root user?

Offline

#5 2005-04-02 09:23:17

Eltnux
Member
Registered: 2005-02-01
Posts: 12

Re: Error With ivman

Sorry i took some time to reply.

Ihave set up Udev as per the wiki and auto loading is working, but (there always a but  big_smile ) when i boot up the system fails when it initilizes the swap partiotion. This seemed to start after i set up Udev.

Also i dont get any sound when i play a CD but i do get sounds frem KDE (min max windows exc..)

Thanks for you help so far.

Offline

#6 2005-04-02 12:09:09

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Error With ivman

have you changed the dev labeling scheme from /dev/discs/disc0/part1 to hda1, etc. in /etc/fstab?
do you have something that looks like this:

/dev/hdxy swap swap defaults 0 0

where x is either a or b(for primary drives) in correspondance to the drive and y is the partion.
If that doesn't work please post your fstab

Also i dont get any sound when i play a CD but i do get sounds frem KDE (min max windows exc..)

has this happened after switching to udev as well? Did you add your user to the groups mentioned in the wiki?

Offline

#7 2005-04-02 12:51:10

Eltnux
Member
Registered: 2005-02-01
Posts: 12

Re: Error With ivman

Below is my /etc/fstab file.

# This file is edited by fstab-sync - see 'man fstab-sync' for details
#
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0
tmpfs                  /tmp          tmpfs     defaults            0      0
usbfs                  /proc/bus/usb usbfs     defaults            0      0

/dev/discs/disc0/part3 swap swap defaults 0 0
/dev/discs/disc0/part4 / reiserfs defaults 0 0
/dev/hdc                /media/cdrom            auto    user,exec,noauto,comment=managed 0 0
/dev/hda                /media/dvdwriter        auto    user,exec,noauto,comment=managed 0 0
/dev/fd0                /media/floppy           auto    user,exec,noauto,comment=managed 0 0

As i am using sata drives should the swap line read?

/dev/sda3 swap swap default 0 0

I hadn't tried to listen to a CD befor tryinh this so i dont know if the sound problem is due to Udev or notI have added my user to the groups as mentioned in the wiki.

Offline

#8 2005-04-02 13:45:03

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Error With ivman

no, I think you should leave it as hdxy not sdax....

/dev/discs/disc0/part3 swap swap defaults 0 0 
/dev/discs/disc0/part4 / reiserfs defaults 0 0 
/dev/hdc                /media/cdrom            auto    user,exec,noauto,comment=managed 0 0 
/dev/hda                /media/dvdwriter        auto    user,exec,noauto,comment=managed 0 0 
/dev/fd0                /media/floppy           auto    user,exec,noauto,comment=managed 0 0

I have set the IvmConfigMappings.xml to the following entries is this correct

<ivm:Map device="/dev/hda" maps="/dev/ide/host0/bus0/target0/lun0/cd"/>
<ivm:Map device="/dev/hdc" maps="/dev/ide/host0/bus1/target0/lun0/cd"/>

recomment these lines in the mappings file...it'll find the right device on its own. Right now your telling ivman to look into the same device for the cdrom as the hard drive. My guess is this is a causing a conflict with swap and your cdrom troubles.
Also change

/dev/discs/disc0/part3 swap swap defaults 0 0 
/dev/discs/disc0/part4 / reiserfs defaults 0 0 

to

/dev/hda3 swap swap defaults 0 0 
/dev/hda4 / reiserfs defaults 0 0 

and reboot.

Offline

#9 2005-04-02 19:16:38

Eltnux
Member
Registered: 2005-02-01
Posts: 12

Re: Error With ivman

I have got the CD to play now with xmms by using the xmms-arts plug in and the CD Audio player plug in and setting it to use Digital extraction.

Thanks very much for you help in getting the automount to work now i know i can hear something from a CD i can try and get it to use xmms when i put a cd in the tray.

Thanks again you were a great help.

Offline

Board footer

Powered by FluxBB