You are not logged in.

#1 2011-01-31 09:38:36

mrshpot
Member
Registered: 2010-08-29
Posts: 9

[SOLVED: fixed in upstream] TTF font garbling in Emacs

After today's upgrade I started getting redraw artifacts in Emacs.
Having poked around, I discovered that the artifacts happen with TTF fonts only.
Here are some examples taken with emacs -Q (i.e. without user's config) and with hl-line-mode (highlight current line) which makes the problem more obvious:
Fixed (bitmap font), no problem:
http://imgur.com/1dz6f
Andale Mono (TTF), ugh:
http://imgur.com/nztIK

EDIT: The artifacts occur on pretty much any text change, and a full redraw makes it go away (until the next action)
My machine is a laptop with integrated Intel video.

pacman wrote:

xf86-video-intel 2.14.0-1
xorg-server 1.9.3.901-1

Window manager: Xfwm with compositing

Does this seem like an upstream bug, or is it a packaging problem?

Last edited by mrshpot (2011-02-04 10:11:37)

Offline

#2 2011-01-31 15:42:09

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,082

Re: [SOLVED: fixed in upstream] TTF font garbling in Emacs

I think I am seeing this bug as well.   I am not at my machine, and did not try changing fonts.  I did establish that the problem goes away if you turn of Compositing (on my machine).  If you try without compositing, I'll try different fonts when I get home tonight.

A brief search indicates it may be an an upstream problem with the Intel drivers -- Several bug reports have appeared and date back to about mid-January.  I was also going to try rolling back the driver / dri stuff to the previous version.  I generally use Xfce4 with Compiz.  Kwin with effects turned on caused the same issue.  Also, KDE seems to through fits (Application crashes / disabling effects / turning off specific effects) with this driver.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2011-01-31 18:16:06

mrshpot
Member
Registered: 2010-08-29
Posts: 9

Re: [SOLVED: fixed in upstream] TTF font garbling in Emacs

Disabling compositing "fixes" the problem for me as well.
Could you point me at some bug reports? I have only managed to find stuff related to 2.12.

Offline

#4 2011-01-31 19:17:14

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,082

Re: [SOLVED: fixed in upstream] TTF font garbling in Emacs

https://bugs.freedesktop.org/show_bug.cgi?id=32734  Is the one that comes to mind.  I have more references at home.  I'll post them tonight [GMT-8]


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#5 2011-01-31 20:49:05

mrshpot
Member
Registered: 2010-08-29
Posts: 9

Re: [SOLVED: fixed in upstream] TTF font garbling in Emacs

Thanks.
In the mean time, threre's also https://bugs.freedesktop.org/show_bug.cgi?id=33253, which has been marked as a duplicate of that bug.

Offline

#6 2011-02-01 07:28:56

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,082

Re: [SOLVED: fixed in upstream] TTF font garbling in Emacs

Sorry it is so late... Helping my daughter with her calculus. 

I did verify that changing to a bit mapped font "fixed" the emacs problem.  I was experiencing system wide instability with emacs, Xfce4 / Compiz, KDE / kwin so I backed down just the Intel driver, leaving the updates to Xorg and Dri.  Emacs and Compiz returned to health, but KDE was confused to the extent I had to start with a clean profile. 

Unfortunately, I need a stable system for a few days, so I will not be able to experiment with the driver for now.

I checked my notes, and our previous bug reports pretty much cover it.  There was one other Gentoo bug that was the Genesis of the one that i had posted.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#7 2011-02-03 19:30:56

mrshpot
Member
Registered: 2010-08-29
Posts: 9

Re: [SOLVED: fixed in upstream] TTF font garbling in Emacs

The bug has been addressed.
The freedesktop bugzilla now mentions a commit in xf86-video-intel git.
I extracted it into a patch and it worked for me.
Just in case, the PKGBUILD and the patch I used:
PKGBUILD:   http://aur.pastebin.com/SqB9j8RC
uxa-damage.patch:   http://pastebin.com/MHvkTRuu

EDIT:
the uxa-damage.patch checksum won't match as pastebin has swallowed trailing new-lines.
for the checksum to match, two newlines should be added, like this:

1.7.4<ret>
<ret>

Last edited by mrshpot (2011-02-03 19:43:33)

Offline

#8 2011-02-04 18:16:23

simon-nicholls
Member
Registered: 2011-02-04
Posts: 2

Re: [SOLVED: fixed in upstream] TTF font garbling in Emacs

That worked great, thanks.

Offline

#9 2011-02-05 02:19:03

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,082

Re: [SOLVED: fixed in upstream] TTF font garbling in Emacs

Yep, That did it.  Emacs and KDE effects are both happy with the driver

Thank You


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#10 2011-02-05 05:27:44

africa
Member
Registered: 2011-02-05
Posts: 1

Re: [SOLVED: fixed in upstream] TTF font garbling in Emacs

Worked well for me too. Thanks!

Offline

Board footer

Powered by FluxBB