You are not logged in.

#1 2011-02-07 22:49:24

Registered: 2011-01-09
Posts: 25

[SOLVED] Several major issues after pacman -Syu to kernel 2.6.37

Hello -

I had just put up a beautiful Arch system, ran pacman -Syu which upgraded the kernel, and now on boot the machine seems to, among other things, have lost usb, network, & video functionality (at least these are the obvious issues, no doubt there are likely other, yet undiscovered issues). running lspci shows me the standard hardware, running lsusb gives me the following error:

'unable to initialize libusb: -99'

I am running kernel and version 1.0.8-1 of libusb. Reinstalling libusb and usbutils as per a previous post did NOT solve the problem and now i am stuck with a dead system. Google searching has turned up nothing. If anyone can help I would greatly appreciate it.



[SOLVED] - adding a ps/2 keyboard to system and then reinstalling kernel26 and kernel26-headers solved my problem. hopefully this can help the next person.

Last edited by Archieman (2011-02-07 23:27:45)

A good solution applied with vigor now is better than a perfect solution applied ten minutes later. - George S. Patton


#2 2011-02-15 01:43:07

From: Cambridge
Registered: 2009-05-02
Posts: 71

Re: [SOLVED] Several major issues after pacman -Syu to kernel 2.6.37


I have similar problem. lsusb fails to initialize with the same error. However, reboot fixes it, but after suspend to ram it is broken again.

my uname -a

Linux Archx200s 2.6.37-ARCH #1 SMP PREEMPT Sat Jan 29 20:00:33 CET 2011 x86_64 Intel(R) Core(TM)2 Duo CPU L9400 @ 1.86GHz GenuineIntel GNU/Linux

lsmod | grep usb:

usb_storage            43276  0 
usbcore               139048  2 uas,usb_storage
scsi_mod              125814  6 uas,usb_storage,sg,sr_mod,sd_mod,libata

BTW, I am using Thinkpad x200s. For suspend I simply use pm-suspend.

How can you add a ps/2 keyboard to solve this issue? Shouldn't hardware be transparent to the problem.

I have managed to find a work arround:

before the suspend I put in my /etc/acpi/

modprobe -r ehci-hcd

And after the suspend:

modprobe ehci-hcd

Last edited by Liuuutas (2011-02-16 21:46:19)


Board footer

Powered by FluxBB