You are not logged in.

#1 2011-02-14 02:39:46

Azriel
Member
Registered: 2008-01-23
Posts: 58

[SOLVED] VLC choppy video

Hi,

I've got a problem using VLC to read 720p or higher def videos. The video works, but it choppy. Depending on the file, it can be bearable (like little hiccups when the camera is moving fast, which is most cases) or really, really choppy video where it just freezes from a frame to another.

I originally thought the said files were the problem, but they read just fine with kaffeine, with absolutely no chopping at all.

VLC read SD videos just fine.

I've tried resetting the preferences in case I did something wrong, but it didn't bring any improvement.

I am running Arch64, my processor is an Intel Core 2 Duo at 2.66GHz (not overclocked), my video card is a GeForce 8800GT, I have 2GB of ram, and I am running X using only E17, so it really shouldn't be a configuration problem (plus as I said, kaffeine works just fine in every case).

I know I could just switch to Kaffeine, which is what I do in the worst cases, but I prefer VLC's interface, plus I haven't found how to set subtitles size in Kaffeine, which makes them appear very small, and i've just bought an application on my android phone to be able to control VLC, so i'd like to be able to use it !

I would really appreciate any help, because I really don't have a clue what's going on, I don't remember having troubles with my player a while ago, but since I haven't used it for the best part of december and january, I have no idea when it could have broken up...

Last edited by Azriel (2011-03-05 20:59:24)

Offline

#2 2011-02-14 12:28:22

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: [SOLVED] VLC choppy video

I've had the same experience myself lately, switching to mplayer (with an h.264 576p rip) did the trick. But VLC worked before, even with 720p material (my hardware is not performant enough to decode 720p in hardware - Core 2 Duo 1,2 GHz). VLC's command line output doesn't seem to give any interesting info though...


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#3 2011-02-14 13:44:15

stqn
Member
Registered: 2010-03-19
Posts: 1,189
Website

Re: [SOLVED] VLC choppy video

VLC very recently started behaving like that here too, with some h264-encoded videos... Intel Core i3 with integrated Intel HD Graphics. I'm guessing it's a new bug in the latest VLC update, but I didn't bother reinstalling the previous version as the videos work fine in SMPlayer.

BTW after re-encoding such a video with Handbrake, it plays fine...

Offline

#4 2011-02-16 19:13:13

BelgiumArcher
Member
Registered: 2010-07-12
Posts: 17

Re: [SOLVED] VLC choppy video

Same problem here.
VLC used to work fine with H264 720p.
Now it is choppy when camera movements. I guess the problems exists about 3 to 4 weeks.
My hardware : dell xps M1530 laptop intel dual core T9300 at 2500 mhz, 3gb ram, nvidia GeForce 8600M GT

mplayer works fine.
I also prefer vlc since it is easier to play with subtitles

Offline

#5 2011-02-16 19:38:13

Azriel
Member
Registered: 2008-01-23
Posts: 58

Re: [SOLVED] VLC choppy video

Well i'm glad to see i'm not the only one for who vlc is misbehaving ! I've browsed the internet before posting here, and have only found thread of 2008 or 2009.

I guess itcan be assumed to be vlc-related then, i'll try getting an older version, see if it fixes anything, and if it does it'll mean we just have to wait for the update.

Offline

#6 2011-02-17 03:29:15

stqn
Member
Registered: 2010-03-19
Posts: 1,189
Website

Re: [SOLVED] VLC choppy video

Could it be this bug?
Playback skips when playing MKV file with subtitles derived from closed captions

I don't know what closed captions are, but I've tried a dozen videos and the problem only occured on 720p h/x264 mkv videos with integrated subtitles (even when the subtitles are not shown.)

I did find some videos with the same caracteristics that don't exhibit this problem though.

Edit: I also found a video without subtitles with slight skips under VLC and none under SMPlayer... But this might be another problem...

Last edited by stqn (2011-02-17 03:45:01)

Offline

#7 2011-02-17 04:16:50

Azriel
Member
Registered: 2008-01-23
Posts: 58

Re: [SOLVED] VLC choppy video

In my case, none of my files had integrated subtitles, all had external. Srt file, and i tried renaming those srt file so vlc wouldn't load them, but it doesn't improve the output. So i guess it's not the same bug.

Offline

#8 2011-02-24 18:17:20

nimless
Member
Registered: 2011-02-24
Posts: 1

Re: [SOLVED] VLC choppy video

New version of vlc didn't solve this Issue for me.

Offline

#9 2011-02-26 23:59:21

CMatomic
Member
Registered: 2011-02-26
Posts: 3

Re: [SOLVED] VLC choppy video

hi

I have nvidia and able to play videos in 1080p blu-ray dics in vlc,  must have installed the libva "vaapi"
because vlc does not use directly VDPAU
after installing the VDPAU and  libva "vaapi"and shall compile a new version of ffmpeg
then on vlc you should enable the hardware acceleration function

see the image
" enable graphics acceleration in Vlc  "  http://dl.dropbox.com/u/2143569/VlcLibva.png

and can also see my video on youtube
http://www.youtube.com/watch?v=PWPHaVDWODw

and then must configure mplayer like this
in /etc/mplayer

#
# MPlayer configuration file
#
# Configuration files are read system-wide from /usr/local/etc/mplayer.conf
# and per-user from ~/.mplayer/config, where per-user settings override
# system-wide settings, all of which are overrriden by the command line.
#
# The configuration file settings are the same as the command line
# options without the preceding '-'.
#
# See the CONFIGURATION FILES section in the man page
# for a detailed description of the syntax.
#
# Profiles should be placed at the bottom of the configuration file to ensure
# that settings wanted as defaults are not restricted to specific profiles.


##################
# video settings #
##################

# Specify default video driver (see -vo help for a list).
vo=vdpau
#xv,x11

# Use SDL video with the aalib subdriver by default.
#vo = sdl:aalib

# FBdev driver:
#
# mode to use (read from fb.modes)
#fbmode = 640x480-120
#
# location of the fb.modes file
#fbmodeconfig = /etc/fb.modes

# Specify your monitor timings for the vesa and fbdev video output drivers.
# See /etc/X11/XF86Config for timings. Be careful; if you specify settings
# that exceed the capabilities of your monitor, you may damage it.
#
# horizontal frequency range (k stands for 1000)
#monitor-hfreq = 31.5k-50k,70k
#
# vertical frequency range
#monitor-vfreq = 50-90
#
# dotclock (or pixelclock) range (m stands for 1000000)
#monitor-dotclock = 30M-300M

# Start in fullscreen mode by default.
#fs=yes

# Change to a different videomode when going fullscreen.
#vm=yes

# Override the autodetected color depth, may need 'vm=yes' as well.
#bpp=0

# Enable software scaling (powerful CPU needed) for video output
# drivers that do not support hardware scaling.
#zoom=yes

# standard monitor size, with square pixels
#monitoraspect=4:3

# Use this for a widescreen monitor, non-square pixels.
#monitoraspect=16:9

# Keep the player window on top of all other windows.
#ontop=yes


##################
# audio settings #
##################

# Specify default audio driver (see -ao help for a list).
#ao=oss

# Use SDL audio driver with the esd subdriver by default.
#ao = sdl:esd

# Specify the mixer device.
#mixer = /dev/mixer

# Resample the sound to 44100Hz with the lavcresample audio filter.
#af=lavcresample=44100

# Output audio to S/PDIF
#ao=alsa:device=spdif
#ac=hwac3,hwdts,hwmpa,


##################
# other settings #
##################

# Pretend to be Window Media Player.
# Fixes playback when playlist and media file use the same URL.
#user-agent=NSPlayer/4.1.0.3856

# Pretend to be Quicktime
# Fixes playback for apple.com/trailers redirects
#user-agent="QuickTime"

# Pretend to be Realplayer SP
# Fixes playback for some video streaming sites
#user-agent=RMA/1.0

# Pretend to be Winamp
# Fixes playback of some NSV streams
#user-agent="Winamp NSV Player/5.12 (ultravox/2.0)"

# Drop frames to preserve audio/video sync.
#framedrop = yes

# Specify your preferred skin here (skins are searched for in
# /usr/local/share/mplayer/skins/<name> and ~/.mplayer/skins/<name>).
#skin = Abyss

# Resample the font alphamap.
# 0     plain white fonts
# 0.75  very narrow black outline (default)
# 1     narrow black outline
# 10    bold black outline
#ffactor = 0.75

# cache settings
#
# Use 8MB input cache by default.
#cache = 8192
#
# Prefill 20% of the cache before starting playback.
#cache-min = 20.0
#
# Prefill 50% of the cache before restarting playback after the cache emptied.
#cache-seek-min = 50

# DVD: Display English subtitles if available.
#slang = en

# DVD: Play English audio tracks if available.
#alang = en


############
# Profiles #
############

# The options declared as part of profiles override global default settings,
# but only take effect when the profile is active.

[protocol.dvdnav]
#vc=ffmpeg12,
#mouse-movements=yes
#nocache=yes

[vo.vdpau]
vc=ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau,ffh264vdpau,ffodivxvdpau,
# Most video filters do not work with vdpau.
vf-clr=yes



# You can also include other configuration files.
#include = /path/to/the/file/you/want/to/include 

can also use smplayer

http://dl.dropbox.com/u/2143569/smplayer.png

and also the Totem player
http://aur.archlinux.org/packages.php?ID=43378
http://www.splitted-desktop.com/~gbeauc … mer-vaapi/

Last edited by CMatomic (2011-02-27 01:26:49)

Offline

#10 2011-03-05 20:55:13

canuckkat
Member
Registered: 2009-08-28
Posts: 44

Re: [SOLVED] VLC choppy video

What do you mean by

shall compile a new version of ffmpeg

?

Offline

#11 2011-03-05 20:58:33

Azriel
Member
Registered: 2008-01-23
Posts: 58

Re: [SOLVED] VLC choppy video

As far as i'm concerned, i don't know whether it was an update of ffmpeg, vlc, or just enabling graphics acceleration the way CMAtomic described, but after trying yesterday I found that most of my videos were playing flawlessly, only one had a few minor glitches but i can stand using another player once in a while.

I guess i'll mark this thread as solved then, unless someone else still reports this problem after enabling graphic acceleration.

Offline

#12 2011-03-06 22:30:48

canuckkat
Member
Registered: 2009-08-28
Posts: 44

Re: [SOLVED] VLC choppy video

Well, I still have this problem (it's actually ridiculous with VLC and only slightly choppy with smplayer) and if I use CMAtomic's modifications, I get either no audio (in VLC) or no video or nothing plays (in smplayer).

Offline

#13 2011-03-09 10:45:36

pfdm
Member
Registered: 2007-06-25
Posts: 19

Re: [SOLVED] VLC choppy video

I experienced the same trouble with VLC with accelerated video on ATI HD5870 ! I clearly didn't have this issue before. All my videos play well with mplayer-vaapi.
I don't know if it is a video output problem or the new catalyst problem ...so it's not solved !

Offline

#14 2011-03-11 10:58:45

CMatomic
Member
Registered: 2011-02-26
Posts: 3

Re: [SOLVED] VLC choppy video

canuckkat wrote:

What do you mean by

shall compile a new version of ffmpeg

?

vlc uses ffmpeg for video playback.
you need to install a new version of ffmpeg to be activated the following  codecs vaapi (ffwmv3vaapi, ffvc1vaapi, ffh264vaapi, ffodivxvaapi) and vdpau (ffwmv3vdpau, ffvc1vdpau, ffh264vdpau, ffodivxvdpau) in ffmpeg , vaapi is used by vlc for video acceleration
you need to install
for nvidia cards you need in the following order
1 - VDPAU libvdpau see in pacman  Our in aur
http://www.archlinux.org/packages/extra … pau-video/
http://www.archlinux.org/packages/extra … pau-video/
2 - VA-API libva see pacman in Our in aur
http://www.archlinux.org/packages/extra/x86_64/libva/
http://www.archlinux.org/packages/extra/i686/libva/
http://www.splitted-desktop.com/ gbeauchesne ~ / libva /
http://en.wikipedia.org/wiki/Video_Acceleration_API
  then compile the new version of ffmpeg git
3 - ffmpeg "suggestion http://aur.archlinux.org/packages.php?ID=45520"
then activate the acceleration in vlc

in mplayer users of nvidia graphics cards should not use vaapi, the VDPAU much better than vaapi

for ATI  see this
http://en.wikipedia.org/wiki/X-Video_Bi … celeration
https://wiki.archlinux.org/index.php/ATI_Catalyst

Last edited by CMatomic (2011-03-12 11:42:30)

Offline

#15 2011-03-14 15:30:35

canuckkat
Member
Registered: 2009-08-28
Posts: 44

Re: [SOLVED] VLC choppy video

Thanks for the detailed reply! I'm going to try it out when I have some time between final projects and exams.

Although, my video chip doesn't have vpdau (it's an NVIDIA® GeForce® 8600M GT 512MB DDR2) so that's probably an issue. The strange thing is that I didn't have all these problems before (although I don't remember how long ago that is *sigh*).

Last edited by canuckkat (2011-03-14 16:12:48)

Offline

#16 2011-03-14 18:33:53

Gusar
Member
Registered: 2009-08-25
Posts: 3,431

Re: [SOLVED] VLC choppy video

You *do* have vdpau actually.

Offline

#17 2011-03-14 18:59:32

canuckkat
Member
Registered: 2009-08-28
Posts: 44

Re: [SOLVED] VLC choppy video

Really? Interesting. Too many conflicting sources lol. Thanks for clearing that up. wink

Offline

Board footer

Powered by FluxBB