You are not logged in.

#1 2011-02-16 01:06:39

Registered: 2011-02-16
Posts: 1

[2.6.37] Problems with module compression


during the last days I had problems installing carl9170-driver package from the aur. It is a package based on compat-wireless.
Some other people had similar problems with other compat-wireless aur packages
All the packages that are based on compat-wireless provide new versions of already existing kernel modules. They put those modules under /lib/modules/kernel-version/updates.
After installing depmod -a should find the new modules in the /updates folder and after a reboot you can use the updated wireless drivers.

This does not work for kernel 2.6.37 because all the in-kernel modules are .gz compressed but the carl9170-driver package produces uncompressed modules.
I guess that depmod is not able to work correctly if you mix compressed modules with uncompressed ones.

I found this and it seems that there are configuration options wheter you get a compressed or uncompressed module when you run "make install_modules" in a PKGBUILD.
These configuration is made in "Makefile.modinst"

So the question is: Is this a problem with arch's kernel? I think when compressed in-kernel-modules are used, then external modules should compile in the same way.


#2 2011-02-20 10:18:03

Registered: 2009-10-20
Posts: 155

Re: [2.6.37] Problems with module compression

Thanks for your post. I've been reporting this problem for weeks:

I solved the problem by going to /lib/modules/kernel2.6.37ARCH/updates...iwlwifi and then ran:

cd /lib/modules/2.6.37ARCH/update
gzip -r *

Then I reloaded the modules and finally depmod would report that the compat-wireless one was loaded.

The above instructions only worked with compat-wireless-patched from AUR. I'm still unable to use compat-wireless-patched-daily even with the above trick (no module get loaded at all).

Last edited by alphazo (2011-02-20 19:54:59)


Board footer

Powered by FluxBB