You are not logged in.

#1 2011-02-18 10:23:29

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

2011.02-2 archboot "2k11-R1" ISO hybrid image released

Hi Arch community,

Arch Linux (archboot creation tool) 2011.02-1, "2k11-R1" has been released.
To avoid confusion, this is not an official arch linux iso release!

Homepage and for more information on archboot:
http://wiki.archlinux.org/index.php/Archboot

Summary:
- bump to latest kernels and introduce full UEFI bootloader support with new grub2 packages.

Hybrid image file and torrent is provided, which include
i686 and x86_64 core repository. Please check md5sum before using it.

Hybrid image file is a standard CD-burnable image and also a raw disk image.
    - Can be burned to CD(RW) media using most CD-burning utilities.
    - Can be raw-written to a drive using 'dd' or similar utilities.
      This method is intended for use with USB thumb drives.

Please get it from your favorite arch linux mirror:
https://downloads.archlinux.de/iso/archboot/2011.02/
<yourmirror>/iso/archboot/2010.12/

/boot for PXE/Rescue files are provided here:
https://downloads.archlinux.de/iso/arch … 11.02/boot
<yourmirror>/iso/archboot/2011.02/boot

Changelog:

General:
- kernel 2.6.37.1 / LTS kernel 2.6.32.29
- pacman 3.4.3 usage
- RAM recommendations: 320 MB

Kernel changes:
- bump to latest .37 series and bump lts to latest .32 series

Environment changes:
- updated to latest syslog-ng 3.2.x
- updated clamav
- updated pacman mirrorlist
- cleanup in hooks and remove redundant code
- replaced grub by grub2

setup changes:
- many internal changes, like use bash test and use brackets for all variables
- added UEFI bootloader
- move syslinux and extlinux in one bootloader menu
- some dmraid fixes
- add new grub2/grub2-efi package support
- allow nilfs2 for grub2
- allow dmraid for grub2
- install filesystem package, for detected filesystems
- install dmraid package, if dmraid device is detected
- fixed cryptsetup device reset
- some cryptsetup menu additions
- changed default encryption mode to
  aes-cbc-essiv:sha256 -s 128
- don't use rootflags, if not necessary

hwdetect changes:
- none

quickinst changes:
- none

KNOWN ISSUES:
- FTP installation mode:
  None
- CD installation mode:
  None
 
Further documentation can be found on-disk and on the wiki.
Have fun!

greetings
tpowa

Last edited by tpowa (2011-02-20 18:14:19)

Offline

#2 2011-02-19 14:24:40

thiagoc
Member
From: Brazil
Registered: 2009-02-14
Posts: 33
Website

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

Main Menu -> Select Packages -> Just hit OK

Some awk syntax errors appear quickly and I cannot install anything.

Last edited by thiagoc (2011-02-19 14:25:52)

Offline

#3 2011-02-19 14:58:53

thiagoc
Member
From: Brazil
Registered: 2009-02-14
Posts: 33
Website

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

Just found the issue. Variables in awk have "{}" in /arch/setup. Just remove that and it will work.

Offline

#4 2011-02-19 16:10:36

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

But setup should still work or not? I tried several installation here.

Offline

#5 2011-02-19 16:24:11

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

Ok ftp package selection is broken, sigh will release new fixed images tomorrow.
Thanks for reporting it.

Offline

#6 2011-02-19 16:29:31

jimbok
Member
Registered: 2009-09-17
Posts: 51

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

Same problem here too.

The awk mod work for me also.

Last edited by jimbok (2011-02-19 16:36:47)


Registered Linux User #402088

Offline

#7 2011-02-19 16:35:02

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

fixed setup script here:
http://dev.archlinux.org/~tpowa/setup

I'll recreate image till tomorrow with it and will include new kernels too.

Last edited by tpowa (2011-02-20 18:15:01)

Offline

#8 2011-02-19 16:37:46

kgas
Member
From: Qatar
Registered: 2008-11-08
Posts: 718

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

thanks. this time I installed in a netbook without an issue. The package selection is good without X and other stuff.

Last edited by kgas (2011-02-20 16:47:47)

Offline

#9 2011-02-20 13:47:06

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

New files sync up to the mirrors, please use the -2 images. Thanks for reporting the broken ftp install routine.
Bumped the kernels to 2.6.37.1 and 2.6.32.29.

Have fun,
greetings
tpowa

Offline

#10 2011-02-26 22:29:03

sluggo
Member
From: sweden
Registered: 2009-05-28
Posts: 16
Website

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

thank you for your awesome work and the new image tpowa!
Im trying out the new version (dled 2011-02-24) and its working nicely except for one thing, its missing makepkg and file.. i had to reinstall pacman and explicitly install file to get it. dunno if its intentional or not but its, imho, quite a useful package to have when installing, eg. if your in need of a special kernel.

edit: typo

Last edited by sluggo (2011-02-26 22:34:12)


// sluggo

Offline

#11 2011-03-13 13:28:13

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

sluggo, I'll add it to next iso build.
greetings
tpowa

Offline

#12 2011-03-13 14:08:42

skodabenz
Banned
From: Tamilnadu, India
Registered: 2010-04-11
Posts: 382

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

How about adding arch-wiki-docs and arch-wiki-lite ( http://aur.archlinux.org/packages.php?ID=47121 ) to archboot iso? Very useful now that the wiki pages are readable using less command in the console itself.


My new forum user/nick name is "the.ridikulus.rat" .

Offline

#13 2011-03-15 05:38:19

TheBeast
Member
Registered: 2005-11-29
Posts: 6

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

net-tools would be useful as well, netstat is missing.


Insert Witty Message Here

Offline

#14 2011-03-27 00:12:18

steve___
Member
Registered: 2008-02-24
Posts: 439

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

Hello,

Booting this image on a Macmini 2,1 causes grub to flash an error:

NO SUITABLE MODE FOUND
NO VIDEO MODE ACTIVATED

and then drops to a grub2 prompt.  On pressing <esc> I get a grub menu, something like:

ArchLinux
ArchLinux Fallback
ArchLinux LTS
ArchLinux LTS Fallback

Choosing any of these causing the computer to hang.  There may be a message about a "boot list" but unfortunately I did not jot this down; if necessary I can get it.

Last edited by steve___ (2011-03-27 00:13:16)

Offline

#15 2011-03-27 11:32:09

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

Skodabenz any idea, you are the UEFI expert.
The Beast: all net-tools are now included on next iso image.

Offline

#16 2011-03-27 12:42:43

skodabenz
Banned
From: Tamilnadu, India
Registered: 2010-04-11
Posts: 382

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

steve___ wrote:

Hello,

Booting this image on a Macmini 2,1 causes grub to flash an error:

NO SUITABLE MODE FOUND
NO VIDEO MODE ACTIVATED

and then drops to a grub2 prompt.  On pressing <esc> I get a grub menu, something like:

ArchLinux
ArchLinux Fallback
ArchLinux LTS
ArchLinux LTS Fallback

Choosing any of these causing the computer to hang.  There may be a message about a "boot list" but unfortunately I did not jot this down; if necessary I can get it.

Is this the message

error: no suitable mode found.
Booting however

When grub2 menu loads, highlight the option you want and edit the menu the menu adding these lines to the top of the command list

rmmod efi_gop
insmod efi_uga
set gfxmode=auto
set gfxpayload=keep

before "linux ..." line and tell me whether you are getting boot messages on screen. Also archboot grub2-efi menu should show no fallback entries (there aren't any. It should show

Arch Linux (i686) archboot
Arch Linux (x86_64) archboot
Arch Linux LTS (i686) archboot
Arch Linux LTS (x86_64) archboo

Also type in grub2 prompt

grub> set

and tell me what it it show for _EFI_ARCH= , i386 or x86_64 . Even after this if the system hangs, try instructions in http://grub.enbug.org/TestingOnMacbook . Otherwise ask in #grub in irc.freenode.net (as a last resort - I don't know about mac specific efi issues)


My new forum user/nick name is "the.ridikulus.rat" .

Offline

#17 2011-03-27 17:02:02

steve___
Member
Registered: 2008-02-24
Posts: 439

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

Is this the message

error: no suitable mode found.
Booting however

It says:

Welcome to GRUB! (screen refreshes and these two flash flash on the screen:)
NO SUITABLE MODE FOUND
NO VIDEO MODE ACTIVATED

I choose "Arch Linux (i686) archboot" and get:

Booting a command list

_

After approximately 30 second it times out and the computer reboots

When grub2 menu loads, highlight the option you want and edit the menu the menu adding these lines to the top of the command list

rmmod efi_gop
insmod efi_uga
set gfxmode=auto
set gfxpayload=keep

before "linux ..." line and tell me whether you are getting boot messages on screen. Also archboot grub2-efi menu should show no fallback entries (there aren't any. It should show

I did this and see no change.  I get the above message of "Booting a command list"

Arch Linux (i686) archboot
Arch Linux (x86_64) archboot
Arch Linux LTS (i686) archboot
Arch Linux LTS (x86_64) archboo

You are right; sorry for the assumption.

Also type in grub2 prompt

grub> set

and tell me what it it show for _EFI_ARCH= , i386 or x86_64 .

It says "i386".

Even after this if the system hangs, try instructions in http://grub.enbug.org/TestingOnMacbook . Otherwise ask in #grub in irc.freenode.net (as a last resort - I don't know about mac specific efi issues)

OK

Last night I booted an old CD, 2009.08.  I did the install and tried to use grub2 as the bootloader with no success.  I tried both the 'grub2-bios' and 'grub2-efi-i386' installing them to /dev/sda.  On reboot I don't get a grub prompt, just the message "No bootable device -- insert boot disk and press any key".

I may give up after this, use the 2009.08 boot CD and try to use the grub/MBR method as I was using.  The reason I decided to try grub2 was I just installed an SSD.  In the archwiki grub2 it suggests "By default, Apple's firmware switches SATA drives into IDE mode (not AHCI mode) when booting any OS besides Mac OS. It is easy to switch back to AHCI if you are using GRUB2 with an Intel SATA controller."  This can be done by setting:

setpci -d 8086:27c4 90.b=40

in /etc/grub/grub/cfg

I understand these questions are OT, but I thought I'd ask:
1) Does GPT have any other advantage than setting the starting sector to 2048?  I was thinking of using fdisk to do this along with grub (not grub2) -- Are there any flaws in my ignorance?
2) Do you know if it's possible to set AHCI mode with grub?

Lastly I should note, my goal is to install ArchLinux to a SSD in a Macmini 2,1 with one partition for / and nothing else.

Last edited by steve___ (2011-03-27 17:29:44)

Offline

#18 2011-03-27 17:16:47

steve___
Member
Registered: 2008-02-24
Posts: 439

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

Regarding my first question I see it's not that simple from reading the wiki: https://wiki.archlinux.org/index.php/SS … ecommended

Offline

#19 2011-03-27 17:28:49

skodabenz
Banned
From: Tamilnadu, India
Registered: 2010-04-11
Posts: 382

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

steve___ wrote:

It says:

Welcome to GRUB! (screen refreshes and these two flash flash on the screen:)
NO SUITABLE MODE FOUND
NO VIDEO MODE ACTIVATED

I choose "Arch Linux (i686) archboot" and get:

Booting a command list

_

After approximately 30 second it times out and the computer reboots

When grub2 menu loads, highlight the option you want and edit the menu the menu adding these lines to the top of the command list

rmmod efi_gop
insmod efi_uga
set gfxmode=auto
set gfxpayload=keep

before "linux ..." line and tell me whether you are getting boot messages on screen. Also archboot grub2-efi menu should show no fallback entries (there aren't any. It should show

I did this and see no change.  I get the above message of "Booting a command list"

Can you try removing nomodeset in the "linux ..." line in "Arch Linux (i686) archboot" (edit mode) along with adding the above lines, and reboot.

Also type in grub2 prompt

grub> set

and tell me what it it show for _EFI_ARCH= , i386 or x86_64 .

It says "i386".

You have 32-bit EFI, which is very old. You need to remove efi booting support from archboot. Extract archboot iso to any dir. Install extra/{libisoburn,libisofs,libburn} packages. Cd into the extracted dir and run

xorriso -as mkisofs -rock -joliet \
        -max-iso9660-filenames -omit-period \
        -omit-version-number -allow-leading-dots \
        -relaxed-filenames -allow-lowercase -allow-multidot \
        -volid "ARCHBOOT" \
        -eltorito-boot boot/syslinux/isolinux.bin \
        -eltorito-catalog boot/syslinux/boot.cat \
        -no-emul-boot -boot-load-size 4 -boot-info-table \
        -output ../archboot.iso ./

Last night I booted an old CD, 2009.08.  I did the install and tried to use grub2 as the bootloader with no success.  I tried both the 'grub2-bios' and 'grub2-efi-i386' installing them to /dev/sda.  On reboot I don't get a grub prompt, just the message "No bootable device -- insert boot disk and press any key".

What was the exact error? Did you read http://wiki.archlinux.org/index.php/GRUB2 instructions?

I may give up after this, use the 2009.08 boot CD and try to use the grub/MBR method as I was using.  The reason I decided to try grub2 was I just installed an SSD.  In the archwiki grub2 it suggests "By default, Apple's firmware switches SATA drives into IDE mode (not AHCI mode) when booting any OS besides Mac OS. It is easy to switch back to AHCI if you are using GRUB2 with an Intel SATA controller."  This can be done by setting:

setpci -d 8086:27c4 90.b=40

in /etc/grub/grub/cfg

I understand these questions are OT, but I thought I'd ask:
1) Does GPT have any other advantage than setting the starting sector to 2048?  I was thinking of using fdisk to do this along with grub (not grub2) -- Are there any flaws in my ignorance?
2) Do you know if it's possible to set AHCI mode with grub?


1) Using fdisk itself was a mistake. Macs use GPT and you should have used gdisk (available in archboot iso and latest releng test isos  http://releng.archlinux.org/isos/).
2) No idea about AHCI. Like I said I don't have a Mac to try these things.


My new forum user/nick name is "the.ridikulus.rat" .

Offline

#20 2011-03-27 17:58:37

steve___
Member
Registered: 2008-02-24
Posts: 439

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

Can you try removing nomodeset in the "linux ..." line in "Arch Linux (i686) archboot" (edit mode) along with:

rmmod efi_gop
insmod efi_uga
set gfxmode=auto
set gfxpayload=keep

The "linux line" looks like this:

linux (${archboot})/boot/vmlinuz ro ${_kernel_params}

At the grub prompt the output of 'set' is:

?=0
_EFI_ARCH=i386
_kernel_params=nomodeset add_efi_memmap none=EFI_ARCH_i386
archboot=cd0
color_highlight=light-cyan/blue
color_normal=light-blue/black
efi32=cd0
gfxmode=auto
gfxpayload=keep
pager=1
prefix=(cd0)/efi/grub2/i386-efi
root=memdisk

You have 32-bit EFI, which is very old. You need to remove efi booting support from archboot. Extract archboot iso to any dir. Install extra/{libisoburn,libisofs,libburn} packages. Cd into the extracted dir and run

xorriso -as mkisofs -rock -joliet \
        -max-iso9660-filenames -omit-period \
        -omit-version-number -allow-leading-dots \
        -relaxed-filenames -allow-lowercase -allow-multidot \
        -volid "ARCHBOOT" \
        -eltorito-boot boot/syslinux/isolinux.bin \
        -eltorito-catalog boot/syslinux/boot.cat \
        -no-emul-boot -boot-load-size 4 -boot-info-table \
        -output ../archboot.iso ./

Ok I this will take me sometime.

What was the exact error?

There were no errors while installing either package; 'grub2-bios' or 'grub2-efi-i386'.  The commands I used were:

# grub_bios-install --grub-setup=/bin/true --boot-directory=/boot --no-floppy --recheck /dev/sda    ## for grub2-bios
# grub_efi_i386-install --boot-directory=/boot/efi/efi --bootloader-id=grub --no-floppy --recheck    ## for grub2-efi-i386

Yes.  I'm ignorant to grub2, GPT and u{efi}.  Also the Mac hardware has had issues with grub2 in the past, which adds a level of uncertainty to what I read.

1) Using fdisk itself was a mistake. Macs use GPT and you should have used gdisk (available in archboot iso and latest releng test isos  http://releng.archlinux.org/isos/).

I used fdisk three years ago when I orginally installed ArchLinx on its SATA drive.  For this current install I did use gdisk.  I mentioned fdisk now as a plan B should I not be able to get grub2 to work.

Last edited by steve___ (2011-03-27 17:59:51)

Offline

#21 2011-03-27 18:34:20

skodabenz
Banned
From: Tamilnadu, India
Registered: 2010-04-11
Posts: 382

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

Ok. My mistake. Add

 set _kernel_params="add_efi_memmap none=EFI_ARCH_i386" 

after "insmod efi_uga" and try again. This overrides the previously defined _kernel_params var.

Last edited by skodabenz (2011-03-27 18:42:08)


My new forum user/nick name is "the.ridikulus.rat" .

Offline

#22 2011-03-27 18:49:29

steve___
Member
Registered: 2008-02-24
Posts: 439

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

No change.  It sits at "Booting a command list" for approximately 30 seconds.  During that time I can hear the cdrom spin up but then the computer reboots.

Last edited by steve___ (2011-03-27 19:12:17)

Offline

#23 2011-03-28 14:21:31

skodabenz
Banned
From: Tamilnadu, India
Registered: 2010-04-11
Posts: 382

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released


My new forum user/nick name is "the.ridikulus.rat" .

Offline

#24 2011-03-28 15:32:00

steve___
Member
Registered: 2008-02-24
Posts: 439

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

I was able to get the boot CD to boot.  I changed the default grub entry from this:

setparams 'Arch Linux (i686) archboot'

linux (${archlinux})/boot/vmlinuz ro ${_kernel_params}
initrd (${archboot})/boot/initrd.img

to this:

setparams 'Arch Linux (i686) archboot'
insmod efi_uga
terminal_output gfxterm
gfxpayload=keep
fakebios
linux (${archlinux})/boot/vmlinuz ro ${_kernel_params} noefi
initrd (${archboot})/boot/initrd.img

I see "Booting a command list" for a few seconds, then the screen refreshes showing an underscore.  I see the underscore for over a minute before the CD starts to boot.

Removing fakebios causes the exact same result as above accept my USB keyboard does not work after the CD is finished booting.

All the hints for this solution came from 'phcoder' on irc.freenode.net in the #grub channel.

Last edited by steve___ (2011-03-28 15:33:07)

Offline

#25 2011-03-29 19:17:20

steve___
Member
Registered: 2008-02-24
Posts: 439

Re: 2011.02-2 archboot "2k11-R1" ISO hybrid image released

I vote for the package 'extra/eject' to be included on the archboot CD.

Offline

Board footer

Powered by FluxBB