You are not logged in.

#1 2011-02-18 18:42:02

tjwoosta
Member
Registered: 2008-12-18
Posts: 453

makepkg gives invalid certificate error

Im trying to modify the uzbl pkgbuild to build the new 2011.02.15 uzbl (i know im impatient)  but I get this error

┌─[Arch]─[~/Build/uzbl]
└─╼ makepkg -s
==> Making package: uzbl 2011.02.15-1 (Fri Feb 18 14:00:15 EST 2011)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
  -> Downloading uzbl-2011.02.15.tar.gz...
--2011-02-18 14:00:15--  http://github.com/Dieterbe/uzbl/tarball/2011.02.15
Resolving github.com... 207.97.227.239
Connecting to github.com|207.97.227.239|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://github.com/Dieterbe/uzbl/tarball/2011.02.15 [following]
--2011-02-18 14:00:15--  https://github.com/Dieterbe/uzbl/tarball/2011.02.15
Connecting to github.com|207.97.227.239|:443... connected.
ERROR: certificate common name “*.github.com” doesn’t match requested host name “github.com”.
To connect to github.com insecurely, use ‘--no-check-certificate’.
==> ERROR: Failure while downloading uzbl-2011.02.15.tar.gz
    Aborting...
┌─[Arch]─[~/Build/uzbl]
└─╼

So I guess my question is where might I use the --no-check-certificate option? At first I thought it meant makepkg, but makepkg just complains its an unrecognized option.

Offline

#2 2011-02-18 20:08:43

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: makepkg gives invalid certificate error

You need to add it to DL_AGENTS in /etc/makepkg.conf. Like this:

'https::/usr/bin/wget -c -t 3 --waitretry=3 --no-check-certificate -O %o %u'

It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#3 2011-02-18 20:18:07

tjwoosta
Member
Registered: 2008-12-18
Posts: 453

Re: makepkg gives invalid certificate error

ahh , I see, thank you smile

EDIT:
Wait, wtf, I just went to modify it, and found I already have that line with the --no-check-certificate option already set for https

EDIT-AGAIN:
OK I got it, makepkg was using the regular http, and wget was redirected to https afterward but still using the regular http options from makepkg. Simply had to change http to https in pkgbuild smile

Last edited by tjwoosta (2011-02-18 20:26:37)

Offline

#4 2011-02-18 21:37:03

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,094
Website

Re: makepkg gives invalid certificate error

Alternatively, you can use curl which will follow redirects across protocols and won't throw cert errors:

'ftp::/usr/bin/curl -C - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
'http::/usr/bin/curl --compressed -LC - --retry 3 --retry-delay 3 -o %o %u'
'https::/usr/bin/curl --compressed -LC - --retry 3 --retry-delay 3 -o %o %u'

Last edited by falconindy (2011-02-18 21:37:21)

Offline

Board footer

Powered by FluxBB