You are not logged in.

#1 2011-03-05 05:44:32

Arsenal
Member
Registered: 2011-03-04
Posts: 9

Sound not working for USB Headset [Solved]

I've looked everywhere I can to find a solution for this as I'd hate to waste anyone's time.  I've done everythign the wiki has said and even tried some stuff on other webpages (like including a "!" in front of pcspkr in the Modules part of /etc/rc.conf).  This is currently a fresh install with only an updated pacman, password hashes, GNOME, and couple other minor changes.  As far this install goes I've added -- options snd-pcsp index=2 -- to /etc/modprobe.d/modprobe.conf and installed alsa-utils.  I didn't install alsa-oss this time becuase I thought I read somewhere that OSS and ALSA don't mix that well.  I did install it my first time, but it didn't make any difference.

The wiki said to post these:

# lsmod|grep '^snd' | column -t
snd_usb_audio          87191   0
snd_usbmidi_lib        18516   1   snd_usb_audio
snd_rawmidi            19525   1   snd_usbmidi_lib
snd_hda_codec_realtek  295589  1
snd_seq_dummy          1479    0
snd_seq_oss            29240   0
snd_seq_midi_event     5516    1   snd_seq_oss
snd_seq                50562   5   snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         5281    4   snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            39509   0
snd_mixer_oss          17730   1   snd_pcm_oss
snd_hda_intel          21837   0
snd_hda_codec          74609   2   snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              6222    2   snd_usb_audio,snd_hda_codec
snd_pcm                72321   4   snd_usb_audio,snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer              19537   2   snd_seq,snd_pcm
snd                    58906   14  snd_usb_audio,snd_usbmidi_lib,snd_rawmidi,snd_hda_codec_realtek,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
snd_page_alloc         7361    2   snd_hda_intel,snd_pcm

# ls -l /dev/snd
total 0
drwxr-xr-x 2 root root       80 Mar  4 17:12 by-id
drwxr-xr-x 2 root root      100 Mar  4 17:12 by-path
crw-rw---- 1 root audio 116, 10 Mar  4 17:12 controlC0
crw-rw---- 1 root audio 116, 12 Mar  4 17:12 controlC1
crw-rw---- 1 root audio 116, 15 Mar  4 17:12 controlC2
crw-rw---- 1 root audio 116,  9 Mar  4 17:12 hwC0D0
crw-rw---- 1 root audio 116,  8 Mar  4 17:12 pcmC0D0c
crw-rw---- 1 root audio 116,  7 Mar  4 17:31 pcmC0D0p
crw-rw---- 1 root audio 116,  6 Mar  4 17:12 pcmC0D1c
crw-rw---- 1 root audio 116,  5 Mar  4 17:12 pcmC0D1p
crw-rw---- 1 root audio 116,  4 Mar  4 17:12 pcmC0D2c
crw-rw---- 1 root audio 116, 11 Mar  4 17:12 pcmC1D0c
crw-rw---- 1 root audio 116, 14 Mar  4 17:12 pcmC2D0c
crw-rw---- 1 root audio 116, 13 Mar  4 17:12 pcmC2D0p
crw-rw---- 1 root audio 116,  3 Mar  4 17:12 seq
crw-rw---- 1 root audio 116,  2 Mar  4 17:12 timer

And here's this (The creative headset is what I'm trying to get to work)

# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC889A Analog [ALC889A Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC889A Digital [ALC889A Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Headset [Creative HS-1200 Headset], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


I'm not a terribly advanced user and am coming from about a month's worth of Linux experience from Ubuntu, but I'm here on Arch because I love the ideals of simplicity and efficiency and would love to learn about what goes on inside my computer behind the scenes.  (On that note, if you know of anything that would help me learn how to fix this type of stuff on my own or anythign that would increase my understanding of what computers do behind the scenes please let me know.)

Thanks

Last edited by Arsenal (2011-03-07 06:00:32)

Offline

#2 2011-03-05 06:09:22

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 6,775

Re: Sound not working for USB Headset [Solved]

A few comments:-

alsa-oss has nothing to do with 'alsa and oss not working well together', both can't be running at the same time. alsa-oss emulates oss for apps which rely on oss, so they can be used on an alsa system.

Besides, it looks like what you have should work. Do you know how to play to the non-default device in alsa? Its pretty app-specific but testing with aplay should be fine.

I'd recommend pulseaudio as simply being easier to USE (not necessarily to setup). If you cant set alsa up properly though, using pulseaudio won't really help.


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#3 2011-03-06 07:35:32

Arsenal
Member
Registered: 2011-03-04
Posts: 9

Re: Sound not working for USB Headset [Solved]

When you said that it should be working I decided to try and find a non-USB headset and it turns out that I do have sound working - at least on youtube videos.
I tried plugging the USB one in again and still no sound, the volume buttons on the USB headset did work correctly though and when I was in alsamixer it correctly displayed the USB headset under "Select sound card" while it was plugged in and removed it when it wasn't.  I've noticed though that in alsamixer I am unable to change the gain levels for the "Headphone" item (I am able to mute/unmute it though).  I think this might be the issue as my non-USB headset is affected by "Front" instead.  Is there a way to fix this or is this not likely the problem?

Offline

#4 2011-03-06 08:02:33

Maki
Member
From: Skopje, Macedonia
Registered: 2007-10-16
Posts: 345
Website

Re: Sound not working for USB Headset [Solved]

install pulseaudio,  maybe its just that its playing on the onboard card instead of the usb headphones, with pulseaudio you can select which output goes to which soundcard


If it ain't broke, broke it then fix it.

Offline

#5 2011-03-06 08:27:44

Arsenal
Member
Registered: 2011-03-04
Posts: 9

Re: Sound not working for USB Headset [Solved]

I installed pulseaudio and pulseaudio-alsa.  I'm not familiar with either alsa or pulseaudio and Ngoonee said that if I can't setup ALSA up properly pulseaudio isn't going to help.  I'll see if I can figure it out though with the manpages or wiki.  Pacman gave me this message:

>>> You might want to blacklist the "snd-pcm-oss" module in /etc/rc.conf to keep ALSA's OSS emulation from interfering with ALSA or PulseAudio.

Is that somethign I should do?

I also installed pulseaudio-gnome.  I received this:

:: gnome-media-pulse and gnome-media are in conflict. Remove gnome-media? [y/N] y
:: gnome-settings-daemon-pulse and gnome-settings-daemon are in conflict. Remove gnome-settings-daemon? [y/N] y

I'm assuming that this won't cause any problems.

Offline

#6 2011-03-06 09:03:12

Arsenal
Member
Registered: 2011-03-04
Posts: 9

Re: Sound not working for USB Headset [Solved]

It appears to be working fine now.  I did what I said above and relogged (including adding that command to MODULES).  I thought that I was gonna have to configure something, but as far as I know it did everything itself and now in alsamixer PulseAudio is selected for both the card and the chip.

I still have a few other things I'm trying to troubleshoot before I test my usb headset with other programs, but I'll mark this as [Solved] for now.

Thanks for the help.

Offline

#7 2011-03-06 11:01:41

Arsenal
Member
Registered: 2011-03-04
Posts: 9

Re: Sound not working for USB Headset [Solved]

I went to install java and now my sound in the headset has stopped working again.  The series of steps that happened was this

1.  Intalled jre (I did this from memory and couldn't remember if jre was the open source one or not.  I guessed wrong).
2.  Wanted to use open source so used pacman -Rs to remove jre.
3.  Installed openjdk6 and icedtea-web.
4.  I believe I rebooted or relogged at this point and when I was back on youtube the sound was no longer working.  I tried "pulseaudio --start", but still had no sound.
5.  Tried to do the fix that the wiki says because it states that Java and Pulseaudio don't work nice together, but I don't have a /opt folder and I don't know how to keep track of where pacman puts all the files from installs.
6.  Pacman -Rs openjdk6 icedtea-web

I've tried using alsamixer and alsaconf to get it to work.  I also followed every step I took that originally got it to work (reinstalled pulseaudio pulseaudio-alsa pulseaudio-gnome).  Alsamixer still displays the same information as when the headset was working.

I run this; I don't know if its helpful or not:

$ pulseaudio --start
$ pulseaudio
E: pid.c: Daemon already running.
E: main.c: pa_pid_file_create() failed.

Offline

#8 2011-03-06 14:02:18

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,709

Re: Sound not working for USB Headset [Solved]

Please read these two pages. You most likely have to change the default card (you can write a udev rule that changes the default card when you plug/unplug the headset if you want)
http://alsa.opensrc.org/Usb-audio
http://alsa.opensrc.org/MultipleCards


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#9 2011-03-07 05:31:30

Arsenal
Member
Registered: 2011-03-04
Posts: 9

Re: Sound not working for USB Headset [Solved]

I reformatted to get sound to work on the normal headset again.  I went to those two sites you suggested, but I'm having a couple issues. 

First I can't find any 'module' related item in /etc that has to do with alsa:

# find /etc -name '*module*'
/etc/syslog-ng/modules.conf
/etc/gtk-2.0/gtk.immodules
/etc/gtk-2.0/gtk.immodules-32
/etc/pango/pango.modules
/etc/pango/pango.modules-32
/etc/X11/xinit/xinitrc.d/40-libcanberra-gtk-module

This was also the only alsa.conf file I found and all it is is source code and didn't look like what the site was talking about so I didn't want to alter it.

# find / -name '*alsa.conf*'
/usr/share/alsa/alsa.conf

As far as my /etc/modprobe.d:

# ls -a /etc/modprobe.d
.   framebuffer_blacklist.conf    nouveau_blacklist.conf
..  modprobe.conf        usb-load-ehci-first.conf

and all /etc/modprobe.d/modprobe.conf is is this:

#
# /etc/modprobe.d/modprobe.conf (for v2.6 kernels)
#

and I don't have a /etc/init.d directory:

# /etc/init.d
bash: /etc/init.d: No such file or directory


I did manage to find a /proc/asound directory though that looks like it might be related to my problem.

# find / -name '*asound*'

/proc/asound
/var/lib/pacman/sync/extra/ecasound-2.7.2-1
/var/lib/alsa/asound.state
/usr/include/alsa/asoundef.h
/usr/include/alsa/asoundlib.h
/usr/include/alsa/sound/asound_fm.h
/usr/include/linux/ultrasound.h
/usr/include/sys/ultrasound.h
/usr/include/sys/asoundlib.h
/usr/include/sound/asound_fm.h
/usr/include/sound/asound.h
/usr/lib/libasound.so.2.0.0
/usr/lib/libasound.so.2
/usr/lib/libasound.so
/usr/lib32/libasound.so.2.0.0
/usr/lib32/libasound.so.2
/usr/lib32/libasound.so

# ls /proc/asound
card0  card2  CinemaTM    Headset  modules  pcm  seq     version
card1  cards  devices    hwdep     oss      SB   timers

# cat cards
0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe024000 irq 16
1 [CinemaTM       ]: USB-Audio - Microsoft® LifeCam Cinema(TM)
                      Microsoft Microsoft® LifeCam Cinema(TM) at usb-0000:00:12.2-4, high speed
2 [Headset        ]: USB-Audio - Creative HS-1200 Headset
                      Creative HS-1200 Headset Creative HS-1200 Headset at usb-0000:00:12.0-2, full s

I tried to change the order so that the creative headset was "0" and the hda "2" via nano, but after confirming the changes and viewing the file again it always reverted back to this.

I'd like to say that I'd like to write a udev rule to change the default card when I plug/unplug the headset, but I'm not sure how to do that and would like to fix it manually before I create an automatic method so that I know what I'm doing.
**PulseAudio isn't installed atm.  It seemed like even though it provided a temporary fix it didn't actually correct the problem.  I hope the problems I've stated here aren't related to not having it installed.

Offline

#10 2011-03-07 05:48:23

Arsenal
Member
Registered: 2011-03-04
Posts: 9

Re: Sound not working for USB Headset [Solved]

I went back to the Alsa page on the Arch wiki and it said I could use a ~/.asoundrc to override the /usr/share/alsa/alsa.conf.

I have this in it so far:

  GNU nano 2.2.6               File: /root/.asoundrc                            Modified 

#pcm.!default {
#type hw
#card 1
#device 0
#}
#ctl.!default {
#type hw
#card 1
#device 0
#}

I added the # because I'm hoping those are commenting it all out for the moment.  I'm not entirely sure what to change.  I assume I should put '2' in place of '1' based on the output below, but I don't know what to do about device.

# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC889A Analog [ALC889A Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC889A Digital [ALC889A Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Headset [Creative HS-1200 Headset], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Offline

#11 2011-03-07 06:00:01

Arsenal
Member
Registered: 2011-03-04
Posts: 9

Re: Sound not working for USB Headset [Solved]

I edited the asoundrc file to this and it seems to be working.

# cat ~/.asoundrc

pcm.!default {
type hw
card 2
device 0
}
ctl.!default {
type hw
card 2
device 0
}

Offline

Board footer

Powered by FluxBB