You are not logged in.

#1 2005-04-10 16:49:12

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,770

locale nightmare ...

Hi,

I keep getting these messages when running xterm (& other apps)

Warning: locale not supported by Xlib, locale set to C
Warning: X locale modifiers not supported, using default
Failed to open input method

I have locale set in /etc/profile

#
# /etc/profile
#

export PATH="/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/usr/X11R6/bin:/opt/bin"

export MANPATH="/usr/man:/usr/X11R6/man"
export LESSCHARSET="latin1"
export INPUTRC="/etc/inputrc"
export LESS="-R"

# Locale settings (find your locale with 'locale -a')
export LANG="en_GB"
export LC_COLLATE="en_GB"

export COLUMNS LINES

export PS1='[u@h W]$ '
export PS2='> '

umask 022

if [ "$TERM" = "xterm" -o "$TERM" = "xterm-color" -o "$TERM" = "rxvt" -o "$TERM" = "xterm-xfree86" ]; then
  PROMPT_COMMAND='echo -ne "33]0;${USER}@${HOSTNAME%%.*}:${PWD/$HOME/~}07"'
fi

# load profiles from /etc/profile.d
#  (to disable a profile, just remove execute permission on it)
for profile in /etc/profile.d/*.sh; do
  if [ -x $profile ]; then
    . $profile
  fi
done
unset profile

Wondered If I got something else wrong .....?


Mr Green

Offline

#2 2005-04-11 19:03:56

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,770

Re: locale nightmare ...

*bump*


Mr Green

Offline

#3 2005-04-11 19:11:46

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: locale nightmare ...

Hmmm, ok couple of things:
what's in /usr/X11R6/lib/X11/locale/en_GB.UTF-8 ?

can you try: en_GB.UTF-8 as the locale... *shrug*

are there locale settings anywhere else that would conflict?

try setting LANGUAGE="en_GB.UTF-8" also? (that's a GNU extension)

try replacing LC_COLLATE with LC_ALL...

I'm pulling at straws right now... never really bothered with locales (en_US)

Offline

#4 2005-04-11 19:41:44

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,770

Re: locale nightmare ...

Its just that since loading new KDE (& maybe even Gnome) things are taking longer to load ....

& I get odd error messages .... (I hate error messages means something needs fixing yet it works;-S)

Never had a problem like this before ... I'll keep searching ;-)

cd /usr/X11R6/lib/X11/locale/
[mrgreen@Arch locale]$ ls
compose.dir  locale.alias  locale.dir

Mr Green

Offline

#5 2005-04-11 19:46:04

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: locale nightmare ...

hmmm, I'm not at my box, but I think I have a huge mess of symlinks in that dir.... I'll check for sure later on tonight...

Offline

#6 2005-04-11 20:16:47

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: locale nightmare ...

I don't have en_GB.UTF-8. Here's what I get:

 14 eric@Erix//home/eric >cd /usr/X11R6/lib/X11/locale/
 15 eric@Erix/X11/locale >ls
C/                 iso8859-1/   iso8859-6/    ko_KR.UTF-8/       mulelao-1/     zh_CN.UTF-8/
armscii-8/         iso8859-10/  iso8859-7/    koi8-c/            nokhchi-1/     zh_CN.gbk/
compose.dir        iso8859-11/  iso8859-8/    koi8-r/            pt_BR.UTF-8/   zh_HK.big5/
el_GR.UTF-8/       iso8859-13/  iso8859-9/    koi8-u/            tatar-cyr/     zh_HK.big5hkscs/
en_US.UTF-8/       iso8859-14/  iso8859-9e/   lib/               th_TH/         zh_TW/
georgian-academy/  iso8859-15/  ja/           locale.alias       th_TH.UTF-8/   zh_TW.UTF-8/
georgian-ps/       iso8859-2/   ja.JIS/       locale.dir         tscii-0/       zh_TW.big5/
ibm-cp1133/        iso8859-3/   ja.SJIS/      microsoft-cp1251/  vi_VN.tcvn/
iscii-dev/         iso8859-4/   ja_JP.UTF-8/  microsoft-cp1255/  vi_VN.viscii/
isiri-3342/        iso8859-5/   ko/           microsoft-cp1256/  zh_CN/

Maybe try to reinstall xorg.

Offline

#7 2005-04-11 20:28:10

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: locale nightmare ...

FYI en_GB is just a symlink to en_US for most of it... you could probably link the dirs

Offline

#8 2005-04-12 06:41:21

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,770

Re: locale nightmare ...

Yay! Snowman reinstalling Xorg did the trick....

[scratches head] Why did that happen? [/scratches head]

& thanks to phracky too....;-)


Mr Green

Offline

Board footer

Powered by FluxBB