You are not logged in.

#1 2005-04-10 18:32:53

filoktetes
Member
From: Skien, Norway
Registered: 2003-12-29
Posts: 286

Openoffice2 stops downloading

I'm trying to install openoffice2 from unstable, but whatever I do, it stops downloading at 55% (57344K), at the exact same place every time.

If I try to resume, nothing happens, not one more byte is downloaded.

I also tried to download it with normal ftp from different mirrors, with no success.

Any ideas?

Offline

#2 2005-04-10 21:46:32

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Openoffice2 stops downloading

maybe uncomment

XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u

in /etc/pacman.conf....just a thought. Or maybe play around with the mirrors in /etc/pacman.d/

Offline

#3 2005-04-10 22:15:45

filoktetes
Member
From: Skien, Norway
Registered: 2003-12-29
Posts: 286

Re: Openoffice2 stops downloading

I tried to do that, but the result was the same:

[root@reblaptop etc]# pacman -S openoffice2

Targets: openoffice2-1.9.91-1

Total Package Size:   100.9 MB

Proceed with upgrade? [Y/n] y

:: Retrieving packages from unstable...
--23:57:13--  ftp://ftp.archlinux.org/unstable/os/i686/openoffice2-1.9.91-1.pkg.                                                            tar.gz
           => `openoffice2-1.9.91-1.pkg.tar.gz.part'
Resolving ftp.archlinux.org... 67.15.6.85
Connecting to ftp.archlinux.org[67.15.6.85]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /unstable/os/i686 ... done.
==> SIZE openoffice2-1.9.91-1.pkg.tar.gz ... done.
==> PASV ... done.    ==> REST 58720482 ... done.    
==> RETR openoffice2-1.9.91-1.pkg.tar.gz ... done.
Length: 105,846,042 [47,125,560 to go]

55% [++++++++++++++++++++                 ] 58,720,482    --.--K/s             -     

It hangs there, but when I press ctrl+c to stop it, it goes on to the next mirror. So, when it came to a http mirror it continued downloading.
So the ftp mirrors will not give me more than (exactly) 58720482 bytes of this file, but the http mirrors do. Although I'm getting my file, it would be nice to understand why this happens  :?

Offline

#4 2005-04-11 06:58:08

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Openoffice2 stops downloading

Try the following line

XferCommand = /usr/bin/wget --passive-ftp -c -t0 -T10 -O %o %u

.  It solved a similar problem I had.

Offline

#5 2005-04-11 06:59:49

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: Openoffice2 stops downloading

try changing the title of your original post to reflect the new issue - you might get more attention that way!

Offline

#6 2005-04-16 23:24:40

deft
Member
Registered: 2005-03-14
Posts: 79

Re: Openoffice2 stops downloading

BTW, does anyone know if the file formats have chaged in 2 - I installed it from unstable then tried to open a previous O.O .swx file with no luck.

Offline

Board footer

Powered by FluxBB