You are not logged in.

#1 2005-04-11 12:12:21

tarix
Member
From: Germany
Registered: 2003-10-16
Posts: 19

qjackctl won't launch jackd anymore

Greetings.

I have a problem with qjackctl. qjackctl itself starts up fine, but for some reason refuses to lauch jackd - reporting a problem of loading the ALSA driver. I can start jackd with its set of paramters manually, so I suppose this issue is not related to jackd.

I had qjackctl working quite well in the past, this is, before I upgraded my kernel to 2.6.11.3 (2.6.10 was working ok). And I even don't think it's a permission problem, as the same symptoms come up when using qjackctl as root.

I tried building qjackctl from ABS, but the apps' behaviour remains the same.

Any suggestions are welcome! Thanx.

-tARIX


If you can't scratch it - don't buy it!

Offline

#2 2005-04-11 21:12:49

Pajaro
Member
Registered: 2004-04-21
Posts: 876

Re: qjackctl won't launch jackd anymore

check your qjackctl configuration. If unsure paste it here (as a screenshoot if you prefer)

Offline

#3 2005-04-12 07:04:01

tarix
Member
From: Germany
Registered: 2003-10-16
Posts: 19

Re: qjackctl won't launch jackd anymore

Here is my qjackctl config.

Meanwhile I managed to l make qjackctl launch jackd by changing 'Interface' from default to hw:0 and either 'Input/Output Channels' from 4 to 0. (FYI: I use a MAudio Delta44 card which has 4 inputs and 4 outputs)

I just wonder why my old settings (Interface:default, In/Output Channels:4) used to work earlier...

And why do I have to set In/Output Channels to 0 when I have 4 each?

Thanx a lot for your reply.

qjackctl_config.png

-tARIX


If you can't scratch it - don't buy it!

Offline

#4 2005-04-12 09:04:51

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: qjackctl won't launch jackd anymore

HI

check the "verbose" field and paste what you get from the message pane

-neri

Offline

#5 2005-04-12 18:10:08

tarix
Member
From: Germany
Registered: 2003-10-16
Posts: 19

Re: qjackctl won't launch jackd anymore

This is the verbose message output when launching jackd with Input/Output Channels set to 4:

19:55:24.592 Patchbay deactivated.
19:55:24.667 Statistics reset.
19:55:24.752 MIDI connection graph change.
19:55:24.876 MIDI connection change.
19:55:41.441 Startup script...
19:55:41.442 artsshell -q terminate
19:55:41.731 Startup script terminated with exit status=256.
19:55:41.732 JACK is starting...
19:55:41.732 /usr/bin/jackd -v -R -dalsa -dhw:0 -r44100 -p1024 -n2 -i4 -o4
19:55:41.748 JACK was started with PID=5805 (0x16ad).
getting driver descriptor from /usr/lib/jack/jack_alsa.so
getting driver descriptor from /usr/lib/jack/jack_dummy.so
getting driver descriptor from /usr/lib/jack/jack_oss.so
jackd 0.99.0
Copyright 2001-2003 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
registered builtin port type 32 bit float mono audio
loading driver ..
new client: alsa_pcm, id = 1 type 1 @ 0x8056a48 fd = -1
apparent rate = 44100
creating alsa driver ... hw:0|hw:0|1024|2|44100|4|4|nomon|swmeter|-|32bit
control device hw:0
configuring for 44100Hz, period = 1024 frames, buffer = 2 periods
ALSA: cannot set channel count to 4 for capture
ALSA: cannot configure capture channel
cannot load driver module alsa
19:55:41.878 JACK was stopped successfully.
19:55:43.764 Could not connect to JACK server as client.

A dialog appears telling me "Could not connect to JACK server as client".

If I set "Input/Output Channels" to the value 0 again, qjackctl will launch jackd as expected:

20:06:20.167 Patchbay deactivated.
20:06:20.247 Statistics reset.
20:06:20.344 MIDI connection graph change.
20:06:20.457 MIDI connection change.
20:06:27.942 Startup script...
20:06:27.942 artsshell -q terminate
20:06:28.239 Startup script terminated with exit status=256.
20:06:28.240 JACK is starting...
20:06:28.240 /usr/bin/jackd -v -dalsa -dhw:0 -r44100 -p1024 -n2
20:06:28.253 JACK was started with PID=5906 (0x1712).
getting driver descriptor from /usr/lib/jack/jack_alsa.so
getting driver descriptor from /usr/lib/jack/jack_dummy.so
getting driver descriptor from /usr/lib/jack/jack_oss.so
jackd 0.99.0
Copyright 2001-2003 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
registered builtin port type 32 bit float mono audio
loading driver ..
new client: alsa_pcm, id = 1 type 1 @ 0x8056a48 fd = -1
apparent rate = 44100
creating alsa driver ... hw:0|hw:0|1024|2|44100|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 44100Hz, period = 1024 frames, buffer = 2 periods
new buffer size 1024
registered port alsa_pcm:capture_1, offset = 4096
registered port alsa_pcm:capture_2, offset = 8192
registered port alsa_pcm:capture_3, offset = 12288
registered port alsa_pcm:capture_4, offset = 16384
registered port alsa_pcm:capture_5, offset = 20480
registered port alsa_pcm:capture_6, offset = 24576
registered port alsa_pcm:capture_7, offset = 28672
registered port alsa_pcm:capture_8, offset = 32768
registered port alsa_pcm:capture_9, offset = 36864
registered port alsa_pcm:capture_10, offset = 40960
registered port alsa_pcm:capture_11, offset = 45056
registered port alsa_pcm:capture_12, offset = 49152
registered port alsa_pcm:playback_1, offset = 0
registered port alsa_pcm:playback_2, offset = 0
registered port alsa_pcm:playback_3, offset = 0
registered port alsa_pcm:playback_4, offset = 0
registered port alsa_pcm:playback_5, offset = 0
registered port alsa_pcm:playback_6, offset = 0
registered port alsa_pcm:playback_7, offset = 0
registered port alsa_pcm:playback_8, offset = 0
registered port alsa_pcm:playback_9, offset = 0
registered port alsa_pcm:playback_10, offset = 0
++ jack_rechain_graph():
client alsa_pcm: internal client, execution_order=0.
-- jack_rechain_graph()
5906 waiting for signals
load = 0.0646 max usecs: 30.000, spare = 23189.000
20:06:30.273 Server configuration saved to "/home/tarix/.jackdrc".
20:06:30.275 Statistics reset.
20:06:30.284 Client activated.
20:06:30.288 Audio connection change.
20:06:30.301 Audio connection graph change.
new client: qjackctl-5904, id = 2 type 2 @ 0xb6cee000 fd = 15
++ jack_rechain_graph():
client alsa_pcm: internal client, execution_order=0.
client qjackctl-5904: start_fd=5, execution_order=0.
client qjackctl-5904: wait_fd=14, execution_order=1 (last client).
-- jack_rechain_graph()
**** alsa_pcm: xrun of at least 41.321 msecs
load = 0.2799 max usecs: 115.000, spare = 23104.000
20:06:32.300 XRUN callback (1 skipped).
load = 9.6064 max usecs: 4396.000, spare = 18823.000
load = 4.9970 max usecs: 90.000, spare = 23129.000
load = 3.0648 max usecs: 263.000, spare = 22956.000
load = 2.4627 max usecs: 432.000, spare = 22787.000
20:06:35.715 Client deactivated.
20:06:35.718 JACK is stopping...
++ jack_rechain_graph():
client alsa_pcm: internal client, execution_order=0.
-- jack_rechain_graph()
removing failed client qjackctl-5904 state = Finished errors = 0
removing client "qjackctl-5904"
removing client "qjackctl-5904" from the processing chain
++ jack_rechain_graph():
client alsa_pcm: internal client, execution_order=0.
-- jack_rechain_graph()
jack main caught signal 15
stopping driver
detaching driver
unloading driver
freeing shared port segments
stopping server thread
freeing engine shared memory
max usecs: 4396.000, engine deleted
20:06:35.815 JACK was stopped successfully.

Is this normal behaviour?

-tARIX


If you can't scratch it - don't buy it!

Offline

#6 2005-04-12 19:23:46

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: qjackctl won't launch jackd anymore

Hi

your screenshot shows input=0 and output=0 but sent is either with value
set to 4, which your hw and thus your driver doesn't support.

try setting either value to 2 in the settings, save that value, and start over
again. Just a guess, that there is something strange in stored values and the
way they are showed in the gui. Setting them explicitely and save this state
might fix it.

-neri

Offline

#7 2005-04-12 19:35:57

tarix
Member
From: Germany
Registered: 2003-10-16
Posts: 19

Re: qjackctl won't launch jackd anymore

neri, thanx for your reply.

I did as you said, but then qjackctl refuses to start jackd as already mentioned :-(

-tARIX


If you can't scratch it - don't buy it!

Offline

#8 2005-04-12 19:47:14

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: qjackctl won't launch jackd anymore

tarix wrote:

neri, thanx for your reply.

I did as you said, but then qjackctl refuses to start jackd as already mentioned :-(

-tARIX

I just read from your log that jackd is started with 4 I/O. Just check if it
is still the case now when you set it to 2. It's sjust very strange since the
Gui shows 0.
I'm clueless ..

-neri

Offline

#9 2005-04-12 19:55:44

tarix
Member
From: Germany
Registered: 2003-10-16
Posts: 19

Re: qjackctl won't launch jackd anymore

I understand your cluelessness ;-)

The values are save in a correct manner in ~/.qt/qjackctlrc. If I enter the value 2, then qjackctl will refuse to start jackd:

[Settings]
Audio=0
Chan=0
Dither=0
Driver=alsa
Frames=1024
HWMeter=false
HWMon=false
IgnoreHW=false
InChannels=2
InDevice=
Interface=hw:0
Monitor=false
NoMemLock=false
OutChannels=2
OutDevice=
Periods=2
PortMax=128
Priority=0
Realtime=false
SampleRate=44100
Server=jackd
Shorts=false
SoftMode=false
StartDelay=2
Timeout=500
UnlockMem=false
Verbose=true
Wait=21333
WordLength=16

If I set the value to 0, jackd will start:

[Settings]
Audio=0
Chan=0
Dither=0
Driver=alsa
Frames=1024
HWMeter=false
HWMon=false
IgnoreHW=false
InChannels=0
InDevice=
Interface=hw:0
Monitor=false
NoMemLock=false
OutChannels=0
OutDevice=
Periods=2
PortMax=128
Priority=0
Realtime=false
SampleRate=44100
Server=jackd
Shorts=false
SoftMode=false
StartDelay=2
Timeout=500
UnlockMem=false
Verbose=true
Wait=21333
WordLength=16

-tARIX


If you can't scratch it - don't buy it!

Offline

#10 2005-04-13 12:52:58

tarix
Member
From: Germany
Registered: 2003-10-16
Posts: 19

Re: qjackctl won't launch jackd anymore

Meanwhile I made another observation concerning this matter:

When I tried starting jackd with the options -i4 -o4 manually from the console , then jackd refuses to start, dropping the same error message as qjackctl does. Without these options jackd will start and run fine.

Maybe the problem is more alsa/jack or hardware related.
I use a Maudio/Midiman Delta44 card, which btw runs fine (even without the input/output channel options).

I also tested the matter with my notebook and its crap onboard soundchip. There the input/output channel options are set to value 2 and jackd starts and runs flawlessy.

Any suggestions?

-tARIX


If you can't scratch it - don't buy it!

Offline

Board footer

Powered by FluxBB