You are not logged in.

#1 2011-04-12 09:03:14

hobarrera
Member
From: Amsterdam, NL
Registered: 2011-04-12
Posts: 355
Website

[SOLVED] Fonts too small on X

Hi,

My fonts are waaay too small for my linking.
I've recently migrated to Arch (I don't know what's been keeping me tongue ), and since the doc is *so* great, I've just had two tiny issues.

My fonts are really small.  About half the size I'm used to.  I formerly used Fedora, and GDM/LXDM magically made them bigger (I remember I once booted on runlevel 3 and ran startx, and the fonts weren't big).

  • I've checked .gtkrc-2.0

  • I've looked at the wiki (at Font Configuration and Fonts FAQ)

  • I've check all the X PPI (DPI) stuff.  On both OSs the DPI is set fine (and equally on both).  I calculated it manually, and I get 68.8dpi.  It's set to 69 now.

Update

Running "startx -- -dpi 96" makes the fonts look *just* like I want them to.  (I've already configured the rendering just like I like it, it's just the size that's annoying me).

However, running "xrdb -merge ~/.Xresources" from my .xinitrc does not fix the issue.

$ cat .Xresources 
xft.dpi:    96

Also, adding the following to ~/.fonts.config resulted in no changes either:

<match target="pattern">
   <edit name="dpi" mode="assign"><double>96</double></edit>
</match>

Any idea what the problem is?

Thanks, cheers!

Update 2

This fixed the issue:

Section "Monitor"
    Identifier "Monitor0"
    Option   "DPI" "96 x 96"
EndSection

Using Xresources didn't work for some reason, and xrdb gave no output, oddly.  Or any of the other methods.  Only passing the DPI explicitly to X worked.  So I guess that fixes the issue tongue (using startx -- -dpi 96 was way too dirty/hackish.

Last edited by hobarrera (2011-04-12 09:46:34)

Offline

Board footer

Powered by FluxBB