You are not logged in.

#1 2011-04-24 23:21:25

eistee85
Member
Registered: 2011-01-22
Posts: 2

Can't build splashy-full package an my machine

As th subject tells, i'm not able to build the splashy-full package on my arch-machine.

I alwys get the following error:

splashy 0.3.13

Print debugging messages...... :

configure complete, now type 'make'

make  all-recursive
make[1]: Entering directory `/tmp/yaourt-tmp-root/aur-splashy-full/src/splashy-0.3.13'
Making all in po
make[2]: Entering directory `/tmp/yaourt-tmp-root/aur-splashy-full/src/splashy-0.3.13/po'
make[2]: Für das Ziel »all« ist nichts zu tun.
make[2]: Leaving directory `/tmp/yaourt-tmp-root/aur-splashy-full/src/splashy-0.3.13/po'
Making all in doc
make[2]: Entering directory `/tmp/yaourt-tmp-root/aur-splashy-full/src/splashy-0.3.13/doc'
make[2]: Für das Ziel »all« ist nichts zu tun.
make[2]: Leaving directory `/tmp/yaourt-tmp-root/aur-splashy-full/src/splashy-0.3.13/doc'
Making all in src
make[2]: Entering directory `/tmp/yaourt-tmp-root/aur-splashy-full/src/splashy-0.3.13/src'
if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I..  -D_REENTRANT -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/directfb      -march=i686 -mtune=generic -O2 -pipe -Wall -Werror -DG_DISABLE_ASSERT -DG_DISABLE_CHECKS -MT xml_parser.lo -MD -MP -MF ".deps/xml_parser.Tpo" -c -o xml_parser.lo xml_parser.c; \
        then mv -f ".deps/xml_parser.Tpo" ".deps/xml_parser.Plo"; else rm -f ".deps/xml_parser.Tpo"; exit 1; fi
 gcc -DHAVE_CONFIG_H -I. -I. -I.. -D_REENTRANT -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/directfb -march=i686 -mtune=generic -O2 -pipe -Wall -Werror -DG_DISABLE_ASSERT -DG_DISABLE_CHECKS -MT xml_parser.lo -MD -MP -MF .deps/xml_parser.Tpo -c xml_parser.c  -fPIC -DPIC -o .libs/xml_parser.o
xml_parser.c: In Funktion »xml_parser_xpath_pop«:
xml_parser.c:94:25: Fehler: Variable »_last« gesetzt, aber nicht verwendet [-Werror=unused-but-set-variable]
xml_parser.c: In Funktion »xml_parser_stack_pop«:
xml_parser.c:109:21: Fehler: Variable »_last« gesetzt, aber nicht verwendet [-Werror=unused-but-set-variable]
cc1: Alle Warnungen werden als Fehler behandelt

make[2]: *** [xml_parser.lo] Fehler 1
make[2]: Leaving directory `/tmp/yaourt-tmp-root/aur-splashy-full/src/splashy-0.3.13/src'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/tmp/yaourt-tmp-root/aur-splashy-full/src/splashy-0.3.13'
make: *** [all] Fehler 2
==> FEHLER: Ein Unfall geschah in build().
    Breche ab ...
==> ERROR: Makepkg was unable to build splashy-full.
==> Restart building splashy-full ? [y/N]
==> -------------------------------------
==>
==> WARNING: Following packages have not been installed:
    splashy-full

What am i doing wrong? How can i solve this?

Thx for your help & ideas!

Offline

#2 2011-04-28 10:22:05

quarkup
Member
From: Portugal
Registered: 2008-09-07
Posts: 497

Re: Can't build splashy-full package an my machine

I am having the very same error: http://pastebin.com/XMDmERyC

link to the AUR entry :: http://aur.archlinux.org/packages.php?ID=27916


If people do not believe that mathematics is simple, it is only because they do not realize how complicated life is.
Simplicity is the ultimate sophistication.

Offline

#3 2011-04-28 10:49:49

quarkup
Member
From: Portugal
Registered: 2008-09-07
Posts: 497

Re: Can't build splashy-full package an my machine

easy to solve the problem, add the following to the PKGBUILD:
#------------------------------------------------------
    sed -e 's| -Werror||g' \
        -i "${srcdir}/splashy-${pkgver}/Makefile" \
        -i "${srcdir}/splashy-${pkgver}/configure" \
        -i "${srcdir}/splashy-${pkgver}/configure.ac"
#------------------------------------------------------
add it to the build() function,
just before 'make'


If people do not believe that mathematics is simple, it is only because they do not realize how complicated life is.
Simplicity is the ultimate sophistication.

Offline

Board footer

Powered by FluxBB