You are not logged in.

#1 2011-04-27 14:53:19

matse
Member
Registered: 2011-04-27
Posts: 276

KDE and fglrx module - power saving

Hello,
yesterday I switched from gnome to KDE 4.6 (stable) and have a problem regarding my graphics card driver:
I use the proprietary driver fglrx (11.3), which worked fine for me under gnome, but now with KDE the graphics card doesn't go into power-saving mode. So the fan is really loud all the time and with "aticonfig --odgc" I see that the core clock is at maximum. Under gnome the core frequency was not so high and the card managed to go into powersaving mode.
Has anybody the same problem and can help me?
Thanks,
Matse

Offline

#2 2011-04-29 12:55:43

byte
Member
From: Düsseldorf (DE)
Registered: 2006-05-01
Posts: 2,046

Re: KDE and fglrx module - power saving

Try switching off desktop effects: https://wiki.archlinux.org/index.php/KD … erformance


1000

Offline

#3 2011-04-29 16:31:01

matse
Member
Registered: 2011-04-27
Posts: 276

Re: KDE and fglrx module - power saving

Hi,
this did not solve my problem. What helps is to change the "Composit Type" from "opengl" to "XRender" in system-settings "desktop effects" (or similar, translated on the fly from german). But this is no solution for me because with XRender kde is really slow even with all effects disabled and by the way do I really like the desktop effects wink
And "aticonfig --odgc" shows a GPU-load of "0%" but does not lower core clock or core voltage, that's really strange.
Any suggestions besides buying a nvidia card? wink
bye
matse

Offline

#4 2011-05-12 15:59:11

matse
Member
Registered: 2011-04-27
Posts: 276

Re: KDE and fglrx module - power saving

So the problem still exists and I would like to know, whether there is somebody out there who does not have my problem?
So can anybody with an ATI card and the catalyst proprietary driver run KDE with Composit Type set to "opengl" and the card shows with "aticonfig --odgc" the "power saving" frequencies?
Thanks,
matse

Offline

#5 2011-05-16 22:25:53

matse
Member
Registered: 2011-04-27
Posts: 276

Re: KDE and fglrx module - power saving

I have to make another addition to my post, I just tried again "XRender" (now with catalyst 11.5, KDE 4.6.3 and XOrg 10 and now XRender works fine without "input lags" and even some nice animations like transparent windows wink
So the bug with opengl still exists but the "workaround" with XRender is OK.

Offline

Board footer

Powered by FluxBB