You are not logged in.

#1 2011-05-19 00:54:25

derblub
Member
From: /dev/null
Registered: 2011-04-25
Posts: 44
Website

GRUB Loading stage1.5 > Error 15 - no boot menu, no nothing

Today I restarted my laptop and got this message.
I'm quite new to Arch and Linux (switched from win7 about 2 months ago) in general and really don't know what to do now sad

The exact message I'm getting is:

GRUB Loading stage1.5

GRUB loading, please wait...
Error 15

currently I'm using an Ubuntu live-usb stick to get into my machine.

this is my output of fdisk -l

root@ubuntu:/# fdisk -l
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x997147f0

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2              14          46      265072+  82  Linux swap / Solaris
/dev/sda3              47        1003     7687102+  83  Linux
/dev/sda4            1004       60802   480329962+  83  Linux

Disk /dev/sdb: 8000 MB, 8000110592 bytes
160 heads, 19 sectors/track, 5139 cylinders
Units = cylinders of 3040 * 512 = 1556480 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1        5140     7812592    c  W95 FAT32 (LBA)

I've read several topics about this error message already and all where about "menu.lst" but I can't find this on my system o_O
this is the output of "find / -name "menu.lst"

root@ubuntu:/# find / -name "menu.lst"
/media/casper-rw/usr/share/doc/grub/examples/menu.lst
/usr/share/doc/grub/examples/menu.lst
root@ubuntu:/boot/grub# ls -la
total 12
drwxr-xr-x 2 root root 4096 2011-05-19 00:23 .
drwxr-xr-x 4 root root 4096 2011-04-25 23:10 ..
-rw-r--r-- 1 root root 1024 2011-05-19 00:13 grubenv
root@ubuntu:/boot/grub# 

don't know if this has something to do with this, but this is my /etc/fstab:

aufs / aufs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0
/dev/sda2 swap swap defaults 0 0

..looks quite empty

I really would appreciate any help from you guys - I've no idea what to do now :I
thanks in advance!

Offline

#2 2011-05-19 06:08:00

stqn
Member
Registered: 2010-03-19
Posts: 1,190
Website

Re: GRUB Loading stage1.5 > Error 15 - no boot menu, no nothing

I suppose your boot partition is sda1. You have to mount it in order to find your menu.lst. (sudo mkdir /mnt/boot && sudo mount /dev/sda1 /mnt/boot)

I think that the fstab you pasted is the one from your Ubuntu live USB stick, not the one from your hard drive. (Although it contains a reference to sda2, but I guess this has been automatically generated...?)

You must have done something to break Grub (changed the partition order or deleted a file or modified your menu.lst and set the wrong device for your boot partition.) There is plenty of documentation about the error 15 problem and how to fix it on the web.

Offline

#3 2011-05-19 13:01:36

derblub
Member
From: /dev/null
Registered: 2011-04-25
Posts: 44
Website

Re: GRUB Loading stage1.5 > Error 15 - no boot menu, no nothing

So the last thing I did was to to a "pacman -Syu" ..all went well there (can't remember tho what exactly was updated)

Never did any changes to my partition order or touched menu.lst (all should be on "default" settings I think, since I installed Arch with the "auto-installer" and all default settings for the partitions.

I just tried to mount my sda1 again (which is my boot partition), but it seems like it's empty hmm

root@ubuntu:/# fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x997147f0

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2              14          46      265072+  82  Linux swap / Solaris
/dev/sda3              47        1003     7687102+  83  Linux
/dev/sda4            1004       60802   480329962+  83  Linux

Disk /dev/sdb: 8000 MB, 8000110592 bytes
160 heads, 19 sectors/track, 5139 cylinders
Units = cylinders of 3040 * 512 = 1556480 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1        5140     7812592    c  W95 FAT32 (LBA)


root@ubuntu:/# mount /dev/sda1 /mnt/sda1_boot

root@ubuntu:/# ls -la /mnt/sda1_boot/
total 5
drwxr-xr-x 2 root root 1024 2011-05-16 22:54 .
drwxr-xr-x 4 root root 4096 2011-05-19 12:48 ..

root@ubuntu:/# ls -la /boot/grub/
total 12
drwxr-xr-x 2 root root 4096 2011-05-19 00:23 .
drwxr-xr-x 4 root root 4096 2011-04-25 23:10 ..
-rw-r--r-- 1 root root 1024 2011-05-19 10:19 grubenv

that grub environment file is full of ###'s does this mean anything?

Offline

#4 2011-05-19 22:41:27

derblub
Member
From: /dev/null
Registered: 2011-04-25
Posts: 44
Website

Re: GRUB Loading stage1.5 > Error 15 - no boot menu, no nothing

nobody? sad
my last hope is just to save all my configs and files and reinstall arch.. roll

Offline

#5 2011-05-20 06:48:15

stqn
Member
Registered: 2010-03-19
Posts: 1,190
Website

Re: GRUB Loading stage1.5 > Error 15 - no boot menu, no nothing

To know what was updated, look at /var/log/pacman.log.

If your boot partition (or directory) is empty, obviously grub won't work. You could mount your root partition and see if there's a boot directory in there. If there is none then grub files (and your kernel) have been deleted somehow. I don't remember reading about something like that.

When you run "ls -la /boot/grub/" you're listing the contents of your USB stick, which doesn't matter when you're trying to make your hard disk installation work...

Offline

#6 2011-05-20 07:36:32

JackH79
Member
From: Australia
Registered: 2009-06-18
Posts: 663
Website

Re: GRUB Loading stage1.5 > Error 15 - no boot menu, no nothing

It might be useful to re-install grub, if your boot partition is empty. This guide will help.

Offline

#7 2011-05-20 23:38:20

shulamy
Member
From: israel
Registered: 2010-09-11
Posts: 418

Re: GRUB Loading stage1.5 > Error 15 - no boot menu, no nothing

have you tried super grub disk ?

ezik

Online

Board footer

Powered by FluxBB