You are not logged in.

#1 2011-05-21 19:12:38

pnicolas
Member
Registered: 2011-05-21
Posts: 5

gnome-shell: black windows with nvidia

Hello,

gnome-shell with nvidia makes black windows when there are lots of windows (5-6 windows).

When the window is black, I can resize the window to a little size and window show fine, but if I resize big it show again black. At times, the window is completely corrupted, random information in black and white. If I close some windows, everything returns to normal.

With gnome2 (compiz or metacity) I had not this problem.

I have not found any similar issue in the bugs section. Any advice?

Two captures of this issue:

http://i52.tinypic.com/4jx4sg.jpg
http://i55.tinypic.com/1z356y9.jpg

My computer:

$ pacman -Qs nvidia
extra/libvdpau 0.4.1-1
    Nvidia VDPAU library
extra/nvidia 270.41.19-1
    NVIDIA drivers for kernel26.
extra/nvidia-utils 270.41.19-1
    NVIDIA drivers utilities and libraries.

$ lspci | grep VGA
00:05.0 VGA compatible controller: nVidia Corporation C51 [GeForce 6150 LE] (rev a2)

$ cat /etc/X11/xorg.conf.d/20-nvidia.conf 
Section "Device"
        Identifier "Default nvidia Device"
        Driver "nvidia"
        Option "NoLogo" "True"
EndSection

thanks!,
Pedro.

Last edited by pnicolas (2011-05-21 22:14:43)

Offline

#2 2011-05-21 21:42:01

MartijnL
Member
From: Leiden, The Netherlands
Registered: 2011-04-17
Posts: 23

Re: gnome-shell: black windows with nvidia

Hi pnicolas,

Could you post the output of the following command please?

cat Xorg.0.log | grep -i 'nvid'

Have you tried Gnome3 fallback mode?

Offline

#3 2011-05-21 22:13:22

pnicolas
Member
Registered: 2011-05-21
Posts: 5

Re: gnome-shell: black windows with nvidia

Hi MartijnL,

In fallback mode gnome-shell works fine.

[pedro@pimiento log]$ cat Xorg.0.log | grep -i 'nvid'
[  1733.913] (**) |   |-->Device "Default nvidia Device"
[  1733.931] (II) Module glx: vendor="NVIDIA Corporation"
[  1733.931] (II) NVIDIA GLX Module  270.41.19  Mon May 16 23:48:30 PDT 2011
[  1733.932] (II) LoadModule: "nvidia"
[  1733.932] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[  1733.933] (II) Module nvidia: vendor="NVIDIA Corporation"
[  1733.933] (II) NVIDIA dlloader X Driver  270.41.19  Mon May 16 23:33:35 PDT 2011
[  1733.933] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  1733.940] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[  1733.940] (II) NVIDIA(0): Creating default Display subsection in Screen section
[  1733.940] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[  1733.940] (==) NVIDIA(0): RGB weight 888
[  1733.940] (==) NVIDIA(0): Default visual is TrueColor
[  1733.940] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  1733.940] (**) NVIDIA(0): Option "NoLogo" "True"
[  1734.257] (II) NVIDIA(GPU-0): Display (Samsung SyncMaster (CRT-0)) does not support NVIDIA
[  1734.257] (II) NVIDIA(GPU-0):     3D Vision stereo.
[  1734.258] (II) NVIDIA(0): NVIDIA GPU GeForce 6150 LE (C51) at PCI:0:5:0 (GPU-0)
[  1734.258] (--) NVIDIA(0): Memory: 262144 kBytes
[  1734.258] (--) NVIDIA(0): VideoBIOS: 05.51.28.50.40
[  1734.258] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[  1734.258] (--) NVIDIA(0): Connected display device(s) on GeForce 6150 LE at PCI:0:5:0
[  1734.258] (--) NVIDIA(0):     Samsung SyncMaster (CRT-0)
[  1734.258] (--) NVIDIA(0): Samsung SyncMaster (CRT-0): 350.0 MHz maximum pixel clock
[  1734.258] (II) NVIDIA(0): Assigned Display Device: CRT-0
[  1734.258] (==) NVIDIA(0): 
[  1734.258] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[  1734.258] (==) NVIDIA(0):     will be used as the requested mode.
[  1734.258] (==) NVIDIA(0): 
[  1734.258] (II) NVIDIA(0): Validated modes:
[  1734.258] (II) NVIDIA(0):     "nvidia-auto-select"
[  1734.258] (II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
[  1734.260] (--) NVIDIA(0): DPI set to (92, 88); computed from "UseEdidDpi" X config
[  1734.260] (--) NVIDIA(0):     option
[  1734.264] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[  1734.365] (==) NVIDIA(0): Disabling shared memory pixmaps
[  1734.366] (==) NVIDIA(0): Backing store disabled
[  1734.366] (==) NVIDIA(0): Silken mouse enabled
[  1734.366] (==) NVIDIA(0): DPMS enabled
[  1734.367] (II) NVIDIA(0): [DRI2] Setup complete

Offline

#4 2011-05-21 22:36:24

MartijnL
Member
From: Leiden, The Netherlands
Registered: 2011-04-17
Posts: 23

Re: gnome-shell: black windows with nvidia

Hmm. I do know that Ubuntu had some trouble with Nvidia drivers. Have you tried using the nouveau packages(pacman) instead?

Also the following command might shed more light:

cat ~/.xsession-errors

Offline

#5 2011-05-21 23:04:07

pnicolas
Member
Registered: 2011-05-21
Posts: 5

Re: gnome-shell: black windows with nvidia

With nouveau driver everything appears corrupt.

In the past, when I used the nouveau driver in gnome2 with compiz, the desktop was only slightly slower but functional.

I have logged again and I have reproduced the error of black windows for a better log messages (sorry for the log messages in Spanish):

[pedro@pimiento ~]$ cat ~/.xsession-errors
/etc/gdm/Xsession: Beginning session setup...
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- gnome-session

(gnome-settings-daemon:5037): keybindings-plugin-WARNING **: La combinación de teclas (hamster-applet) está incompleta

(gnome-settings-daemon:5037): keybindings-plugin-WARNING **: La combinación de teclas (screenreader) está incompleta

(gnome-settings-daemon:5037): keybindings-plugin-WARNING **: La combinación de teclas (magnifier) está incompleta

(gnome-settings-daemon:5037): keybindings-plugin-WARNING **: La combinación de teclas (onscreenkeyboard) está incompleta
kupfer: Reading from stdin

** (kupfer.py:5082): WARNING **: Trying to register gtype 'WnckWindowState' as enum when in fact it is of type 'GFlags'

** (kupfer.py:5082): WARNING **: Trying to register gtype 'WnckWindowActions' as enum when in fact it is of type 'GFlags'

** (kupfer.py:5082): WARNING **: Trying to register gtype 'WnckWindowMoveResizeMask' as enum when in fact it is of type 'GFlags'
    JS ERROR: !!!   Exception was: Error: Requiring NetworkManager, version none: Typelib file for namespace 'NetworkManager' (any version) not found
    JS ERROR: !!!     lineNumber = '0'
    JS ERROR: !!!     fileName = 'gjs_throw'
    JS ERROR: !!!     stack = '("Requiring NetworkManager, version none: Typelib file for namespace 'NetworkManager' (any version) not found")@gjs_throw:0
@/usr/share/gnome-shell/js/ui/status/network.js:8
'
    JS ERROR: !!!     message = 'Requiring NetworkManager, version none: Typelib file for namespace 'NetworkManager' (any version) not found'
      JS LOG: NMApplet is not supported. It is possible that your NetworkManager version is too old
[INFO 00:44:01.260] Initializing Mono.Addins
[WARN 00:44:01.537] No GUI 'su' tool found
/usr/share/kupfer/kupfer/ui/browser.py:2087: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self.window.realize()
/usr/share/kupfer/kupfer/ui/browser.py:636: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  requisition.width, requisition.height = self.__child.size_request ()

** (kupfer.py:5082): CRITICAL **: cr_parser_new_from_buf: assertion `a_buf && a_len' failed

** (kupfer.py:5082): CRITICAL **: cr_parser_set_sac_handler: assertion `a_this' failed

(kupfer.py:5082): librsvg-WARNING **: Error setting CSS SAC handler


** (kupfer.py:5082): CRITICAL **: cr_parser_destroy: assertion `a_this && PRIVATE (a_this)' failed
warning: line 6432: incompatible stripping characters and condition
warning: line 6444: incompatible stripping characters and condition
      JS LOG: GNOME Shell started at Sun May 22 2011 00:44:01 GMT+0200 (CEST)

(Tomboy:5081): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
Advertencia del gestor de ventanas: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1800004 (Kupfer)
Advertencia del gestor de ventanas: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
Advertencia del gestor de ventanas: CurrentTime used to choose focus window; focus window may not be correct.
Advertencia del gestor de ventanas: Got a request to focus 0x1800004 (Kupfer) with a timestamp of 0.  This shouldn't happen!

(parcellite:5077): Gdk-CRITICAL **: IA__gdk_window_thaw_toplevel_updates_libgtk_only: assertion `private->update_and_descendants_freeze_count > 0' failed

(Tomboy:5081): Gdk-CRITICAL **: IA__gdk_window_thaw_toplevel_updates_libgtk_only: assertion `private->update_and_descendants_freeze_count > 0' failed
/usr/share/kupfer/kupfer/ui/browser.py:2313: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  gtk.main()
Error [kupfer.plugin.websearch] OpenSearchSource: [Errno 2] No existe el fichero o el directorio: '/home/pedro/.mozilla/firefox/3v6c3uek.default/searchplugins'
** Message: No loader found for extension 'session-manager' of type 'python'

warning: line 6432: incompatible stripping characters and condition
warning: line 6444: incompatible stripping characters and condition
Advertencia del gestor de ventanas: Received a _NET_WM_MOVERESIZE message for 0x1e00003 (Página en); these messages lack timestamps and therefore suck.
Advertencia del gestor de ventanas: Received a _NET_WM_MOVERESIZE message for 0x1e00003 (Página en); these messages lack timestamps and therefore suck.
Advertencia del gestor de ventanas: Received a _NET_WM_MOVERESIZE message for 0x1c00154 (pedro@pimi); these messages lack timestamps and therefore suck.

Offline

#6 2011-05-21 23:39:57

MartijnL
Member
From: Leiden, The Netherlands
Registered: 2011-04-17
Posts: 23

Re: gnome-shell: black windows with nvidia

Curious. Perhaps conflicting modules loaded? (lsmod)

I don't have any Nvidia hardware to test with, but perhaps the patch listed "black flashes with official nVidia drivers" will be of use:
https://live.gnome.org/GnomeShell/SwatList

Last edited by MartijnL (2011-05-22 00:00:43)

Offline

#7 2011-05-22 06:38:38

Entd
Member
Registered: 2011-03-10
Posts: 18

Re: gnome-shell: black windows with nvidia

I had same problem, but it appeared only when gnome was left to sleep for some time. Thought I have no gnome any more and can't help. Does the gnome do this also when you are leaving it to sleep for example one hour?

Offline

#8 2011-05-22 08:13:18

MartijnL
Member
From: Leiden, The Netherlands
Registered: 2011-04-17
Posts: 23

Re: gnome-shell: black windows with nvidia

Entd wrote:

I had same problem, but it appeared only when gnome was left to sleep for some time. Thought I have no gnome any more and can't help. Does the gnome do this also when you are leaving it to sleep for example one hour?

Try pressing alt+f2 and then type 'r' (sans-quotes) when that happens.

Also, have a look at
https://bbs.archlinux.org/viewtopic.php?id=118077
As your issues seem similar to me smile

Offline

#9 2011-05-22 17:50:00

jdn06
Member
Registered: 2010-02-01
Posts: 61

Re: gnome-shell: black windows with nvidia

I have the very same problem: after six or seven windows opened, new windows appear totally black, unless being downsized.
My card is a NVidia GeForce 6200 with 256 Mo and I use proprietary pilot. I don't use GNOME-shell anymore, No problem with openbox.
This problem remembered a similar problem I had a year ago with GNOME2 on a different desktop with a NVidia Card with too little memory (shared with CU). It was fixed by adding memory.

Offline

#10 2011-05-24 20:31:06

pnicolas
Member
Registered: 2011-05-21
Posts: 5

Re: gnome-shell: black windows with nvidia

Maybe my nvidia card is low on RAM, only 256MB!

In my system, I have 2GB of RAM and and I do not give much load. In this moment:

[pedro@pimiento ~]$ free -mt
             total       used       free     shared    buffers     cached
Mem:          1946       1270        675          0        114        365

For now, I will continue in Gnome fallsafe sad , and occasionally try to normal mode.

Thanks!

Offline

#11 2011-05-24 21:10:16

alphur
Member
Registered: 2011-04-23
Posts: 9

Re: gnome-shell: black windows with nvidia

this is a nvidia driver problem, not nvidia ram or gnome 3 problem. i have the same exact issue, even on KDE and regular gnome 2.32. this problem happened at the 270.xx series but doesn't happen on the 260.

Offline

#12 2011-05-25 15:20:21

jdn06
Member
Registered: 2010-02-01
Posts: 61

Re: gnome-shell: black windows with nvidia

@ alphur

I am not so sure as you are about the origin of the problem. If it is linked to nvidia proprietary pilot, why is there no issue with gnome-fallback, openbox or xfce (which I tried)?
As I did'nt give a try with nouveau and let gnome-shell down, I cannot go further.

Offline

#13 2011-05-25 18:54:49

alphur
Member
Registered: 2011-04-23
Posts: 9

Re: gnome-shell: black windows with nvidia

it's a driver bug in nvidia 270.xx. i'm just a victim and i have evacuated to pekWM for now

Offline

#14 2011-06-02 12:38:01

spark666
Member
Registered: 2011-05-23
Posts: 137

Re: gnome-shell: black windows with nvidia

i have nvidia and works very good whit gnome-shell

Offline

#15 2011-06-02 20:09:46

sliposk
Member
Registered: 2010-08-19
Posts: 45

Re: gnome-shell: black windows with nvidia

I have 3 Arch desktops that all have the Nvidia 6200 256 PCI cards (got all 3 cards for $10.00). On all 3 I use the latest proprietary Nvidia drivers . And on 2 of them I had to blacklist the i915 and intel_agp in the modules section of the /etc/rc.conf . I have to say for a cheap card they work pretty well , even with compiz or kwin . By the way all 3 comps came with intel 865 integrated graphics , and all three have 3.0 ghz Northwood P4 and 2 gig of ram . OLD Hardware that works great .

Offline

#16 2011-06-02 20:46:06

jdn06
Member
Registered: 2010-02-01
Posts: 61

Re: gnome-shell: black windows with nvidia

@sliposk:
Good to know that the same model can work great with gnome-shell. I have no intel GPU integrated to my motherboard; no blacklist then.
I was not blaming my nvidia card. I am very happy with it since five years. I just don't understand why gnome-shell doesn't work correctly for some of us...

Offline

#17 2011-11-22 22:21:31

pnicolas
Member
Registered: 2011-05-21
Posts: 5

Re: gnome-shell: black windows with nvidia

Hi!,

Thanks you all smile

My problem has been fixed in version 290 of nvidia. Today I updated my system, and has been fixed.

[pedro@pimiento ~]$ pacman -Qs nvidia
extra/libvdpau 0.4.1-1
    Nvidia VDPAU library
extra/nvidia 290.10-1
    NVIDIA drivers for linux.
extra/nvidia-utils 290.10-1
    NVIDIA drivers utilities and libraries.

Offline

Board footer

Powered by FluxBB