You are not logged in.

#1 2011-05-29 08:11:22

Registered: 2010-08-27
Posts: 266

[SOLVED]Java Plugin in Firefox 4 - no sound, pls hlp, tnx


Okay, I hope this question belong here. I have FireFox 4, and JRE 6_25, and G3 (dunnow if that's the problem). As described in the docs, I'm supposed to make a symlink to the plugin. The about : plugins keeps reporting File: as file, not the plugin I need.

I just reinstalled 6_21 (the one I know works) and have successfully made a symlink, but FireFox refuses to accept the link.

Applets do not have sound - tested with RuneScape and the Bells applet, no sound, but there is the music in RuneScape...

What manual do I read?

Thanks for some tips.

(by the way: in case you're wondering: yes, I did sniff tru the forum and did not find the answer...)

Edit - considering a cold-turkey re-install, there's too much breakage...Firefox that broke Eclipse (Xulrunner issues), Gnome3 that made the system less usuable (fall back only, here), VLC that takes the whole system down to the grave, and now JRE without sound.
What's left of the system? sad

After the update, things went into the fog...I read that the OSS emulations are not/no longer loaded by default. Does an Applet need these? If so, that could be the option: adding that into rc.conf...
Please consider a reply, thanks.

Last edited by Thor@Flanders (2011-05-30 18:45:15)


#2 2011-05-30 18:43:58

Registered: 2010-08-27
Posts: 266

Re: [SOLVED]Java Plugin in Firefox 4 - no sound, pls hlp, tnx


First of, to all that "came by" to read this post: thanks.

The solution is:

modprobe snd_pcm_oss

as Root, this line needs to be in /etc/rc.conf.

What lead me to this is the documentation and a line in pacman.log

OSS emulation modules are not loaded by default, add to rc.conf if needed.

I would very much like to mark this as solved...




Board footer

Powered by FluxBB