You are not logged in.

#1 2011-06-05 09:38:54

liticovjesac
Member
From: Stockholm-Belgrade-Köln
Registered: 2008-07-16
Posts: 91

multiple conky process with xfce session startup

Hi,
since recently I have this problem with conky and xfce startup. When I login into xfce it starts 5 - 10 + conky process.  That puts cpu to work up to 25% (pIII). When i kill conky and start it again from terminal it works normal. One process, cpu low.
Using xfce settings manager I disable and remove conky from Session and startup but conky still runs when I login next time. Is there any other place where I should check to disable conky session startup?
At the same time I have gnome3. There conky starts up and works without a problem with login. I was thinking that there maybe some conflict with gnome session startup and xfce so I tried to disable conky in gnome but can't find where is that settings now in gnome3. I tried with  gnome-session-properties and there is no conky marked for startup, but when I login to gnome conky starts again?!
In .config/autostart there is no conky mention neither in /etc/xdg/autostart
In lxde and fluxbox conky starts with login and works without problem.
Any sugestion?

Last edited by liticovjesac (2011-06-05 09:40:17)

Offline

#2 2011-09-17 13:30:35

grandmasterb
Member
From: Poland
Registered: 2008-03-12
Posts: 26

Re: multiple conky process with xfce session startup

Hi,
same problem here , after xfce start i have 4 conky processes. i don't have conky aded in startup programs.
on openbox conky starts 1 process. anyone?

Offline

#3 2011-09-17 14:39:23

moetunes
Member
From: A comfortable couch
Registered: 2010-10-09
Posts: 1,028

Re: multiple conky process with xfce session startup

Try logging in with a new session.

Cheers


You're just jealous because the voices only talk to me.

Offline

#4 2011-09-19 08:04:52

Padfoot
Member
Registered: 2010-09-03
Posts: 381

Re: multiple conky process with xfce session startup

This catches out many people on Xfce.

Your session appears to be auto saving along with conky being started via autostart. So each time you log out, the session is saved with another conky process running, thus when you log in again, all the saved processes are launched again, along with a new process from autostart.

The solution is simple, turn off session saving. The initial clean up (to prevent the multiple processes in future) is easy, but convoluted (without deleting your entire session cache - i don't like advising to do that as you can lose other config that is not messed up).

Here is what you need to do:

1. Open Sessions & Startup dialog and under the general tab, untick Automatically Save, and tick Prompt on Logout. Under the Application Auto Start tab, untick EVERYTHING.

2. Open Task Manager and terminate ALL the conky processes.

3. Close ALL running applications.

3. Log out - but BEFORE clicking the log out button, tick the Save Session box.

4. Log back in, and immediately log back out again, this time, unticking the Save Session box.

5. Log back in, open the Sessions & Startup dialog and re-set you Auto Start Applications (and just double check that Automatically Save is still unticked on the general tab).

6. Finally, log out, and back in again, and all should be back to normal.

Cheers.

Offline

#5 2011-09-19 16:47:59

grandmasterb
Member
From: Poland
Registered: 2008-03-12
Posts: 26

Re: multiple conky process with xfce session startup

thanks moetunes and Padfoot, that fixed my problem:)

Offline

#6 2011-12-05 14:38:17

oldpond
Member
Registered: 2010-01-26
Posts: 41

Re: multiple conky process with xfce session startup

This is still happening to me on a fresh install of arch and xfce4.  I am pretty sure I never told it to save my session, but it still seems to want to.  I followed your instructions and the problem went away for one boot, but came back later.  BTW, you can't kill ALL applications in Task Manager smile because it wiipes out your desktop. 

Right now I have 3 conky's running and I have xfce set to not save my session.  Would resetting all my defaults solve the problem?


oldpond = glide

Offline

#7 2011-12-05 14:58:04

oldpond
Member
Registered: 2010-01-26
Posts: 41

Re: multiple conky process with xfce session startup


oldpond = glide

Offline

#8 2011-12-06 07:24:28

Padfoot
Member
Registered: 2010-09-03
Posts: 381

Re: multiple conky process with xfce session startup

Xfce is set to save you session by default on an install. You need to un-check the option on both sessions & startup and the logout dialog.

Failing that, you can simply delete your session cache to clear out the multiple instances

$ rm -r ~/.cache/sessions/*

Bearing in mind, anything else you have in your saved session will also be wiped out (no need to worry if you don't want anything but default xfce stuff in the loaded session).

Cheers.

Offline

#9 2011-12-06 07:31:17

Padfoot
Member
Registered: 2010-09-03
Posts: 381

Re: multiple conky process with xfce session startup

oldpond wrote:

The bugs you refer to are for the session menu panel applet.

Avoid using that applet until fixed. Use the action buttons panel applet fot suspend/reboot/shutdown instead.

Cheers.

Offline

Board footer

Powered by FluxBB