You are not logged in.

#1 2011-06-06 21:58:26

From: Ohio, USA
Registered: 2011-05-12
Posts: 19

Epiphany and non-working back/foward mouse buttons

Hi guys. I checked out and used the following wiki page to get my back/foward mouse buttons to work. It didn't work. … ns_Working

I have a Logitech M510 mouse. The back/foward buttons work in Chrome, Firefox and Midori but not Epiphany. How can I get them to work? I tried the following:

Thumb Buttons - Forward and Back
Note: The following maybe redundant depending on whether xev detects all your mouse buttons correctly (functions can be mapped on a per-app basis) or you want to change the default behaviour.
To do this we need to map keystrokes to the desired mouse buttons and install xvkbd and xbindkeys.
# pacman -S xvkbd xbindkeys
In most modern applications which use back/forward features, XF86Back is mapped to back and XF86Forward is mapped to forward by default. On most MX mice the thumb buttons resolve to 8 & 9. If your mouse is different, check button numbers using xev and replace the numbers used in the example (b:8 & b:9).
So if you have an MX mouse you would create the file ~/.xbindkeysrc, containing:
# Mouse Buttons
"xvkbd -xsendevent -text "\[XF86Back]""
m:0x0 + b:8 
"xvkbd -xsendevent -text "\[XF86Forward]""
m:0x0 + b:9
Now to test... Run the following command and if it works as expected remember to add xbindkeys to .xinitrc or somewhere where it will be executed each time X starts. Also, this should work with Epiphany and Konqueror without any additional configuration or use of imwheel.

Then I tried the xmodmap tweaking and that still didn't work. I'm not sure what to do next. I am starting to use epiphany more and more because firefox formatting isn't accurate on some sites I go to. Epiphany renders it correctly.

When I add the device settings in xorg.conf, it wont allow me to start X. No screens found. My xorg.conf is blank other than what I was shown to put in there from the wiki page. So I'm completly lost.

Last edited by xdunlapx (2011-06-07 03:44:41)


#2 2013-03-16 21:45:39

Registered: 2013-03-16
Posts: 1

Re: Epiphany and non-working back/foward mouse buttons

Looks like this is a known BUG in Epiphany and apprently it's fixed for 3.8. Check for more information.


Board footer

Powered by FluxBB