You are not logged in.

#1 2011-06-12 15:28:11

zenlord
Member
From: Belgium
Registered: 2006-05-24
Posts: 1,207
Website

Bluetooth always on after (re)boot

Hi,

Cleaning up my list of stuff that needed to be done on my laptop and I've got one annoyance left: everytime I boot up my laptop (Arch64, gnome 3), the bluetooth-adapter is enabled, and in 90% of the times I have to disable it in order to save battery power.

There are so many files on my system with regards to BT, that I am confused. This is what I did/have:
In /etc/conf.d/bluetooth: DAEMON_ENABLE="false"
In /etc/bluetooth/main.conf: InitiallyPowered = false
In /etc/laptop-mode/conf.d/bluetooth: CONTROL_BLUETOOTH=0
In /etc/rc.conf: DAEMONS=(...@bluetooth...)
In /etc/conf.d/rfkill: RFKILL_BLOCK="bluetooth"

I think I have done everything I could to keep bluetooth from enabling itself with this configuration - did I miss something?

THX!

Offline

#2 2011-06-12 15:52:29

JokerBoy
Member
From: România
Registered: 2009-09-24
Posts: 641
Website

Re: Bluetooth always on after (re)boot

/etc/rc.conf: DAEMONS=(... !bluetooth ...)

!daemon to disable, @daemon is to run in background.

Last edited by JokerBoy (2011-06-12 15:52:53)

Offline

#3 2011-06-13 08:23:43

zenlord
Member
From: Belgium
Registered: 2006-05-24
Posts: 1,207
Website

Re: Bluetooth always on after (re)boot

I always thought that disabling the daemon would make bluetooth entirely unavailable, but as it turns out, it doesn't. In fact changing the @ for a ! didn't change anything: bluetooth is still powered and enabled in gnome 3.

Other ideas?

Offline

#4 2011-06-16 10:18:20

zenlord
Member
From: Belgium
Registered: 2006-05-24
Posts: 1,207
Website

Re: Bluetooth always on after (re)boot

Anyone? I don't know if it's related to gnome 3 or if I overlooked yet another configuration file...

Offline

Board footer

Powered by FluxBB