You are not logged in.

#1 2011-06-13 08:30:55

krivenok
Member
Registered: 2011-06-13
Posts: 3

Gtk-Message: Failed to load module "canberra-gtk-module"

I get the following error when I try to run gnome-terminal:

$ gnome-terminal

(gnome-terminal:4165): Gtk-WARNING **: GTK+ module /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so cannot be loaded.
GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported.
Gtk-Message: Failed to load module "canberra-gtk-module"
$

I found that libcanberra-gtk-module.so is owned by libcanberra 0.28-1:

$ pacman -Qo /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so
/usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so is owned by libcanberra 0.28-1
$

And even tried to remove it, but there are other packages which depend on it:

$ sudo pacman -R libcanberra
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: gdm: requires libcanberra
:: kdebase-runtime: requires libcanberra
:: libgnome: requires libcanberra>=0.28
$

If I understood properly it complains mixing gtk-2 and gtk-3 in gnome-terminal process.
I have both versions installed:

extra gtk3 3.0.11-1 [installed]
extra gtk2 2.24.4-2 [installed]

How can I solve this problem?

Thanks!

Offline

#2 2011-06-13 08:50:49

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: Gtk-Message: Failed to load module "canberra-gtk-module"

paste the output of the commands

$ pacman -Qm
$ env

Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#3 2011-06-13 09:24:01

krivenok
Member
Registered: 2011-06-13
Posts: 3

Re: Gtk-Message: Failed to load module "canberra-gtk-module"

$ pacman -Qm
bin32-skype 2.1.0.81-3
cdlabelgen 4.1.0-2
cloog-ppl 0.15.10-2
eggdbus 0.6-1
flashplugin 10.0.45.2-1
fontcacheproto 0.1.3-1
gcombust 0.1.55-4
kmldonkey 2.0.2-5
lib32-alsa-lib 1.0.23-2
lib32-dbus-core 1.2.24-1
lib32-e2fsprogs 1.41.12-1
lib32-expat 2.0.1-5
lib32-fontconfig 2.8.0-1
lib32-freetype2 2.4.1-1
lib32-gcc-libs 4.5.0-6
lib32-glib2 2.24.1-1
lib32-glibc 2.12-4
lib32-lcms 1.18-3
lib32-libdrm 2.4.21-1
lib32-libgl 7.8.2-1
lib32-libice 1.0.6-1
lib32-libjpeg 8.0.2-1
lib32-libldap 2.4.22-1
lib32-libpng 1.4.3-1
lib32-libsasl 2.1.23-4
lib32-libsm 1.1.1-1
lib32-libtiff 3.9.4-1
lib32-libx11 1.3.4-1
lib32-libxau 1.0.5-1
lib32-libxcb 1.6-1
lib32-libxcomposite 0.4.2-1
lib32-libxcursor 1.1.10-1
lib32-libxdamage 1.1.3-1
lib32-libxdmcp 1.0.3-1
lib32-libxext 1.1.2-1
lib32-libxfixes 4.0.5-1
lib32-libxft 2.1.14-1
lib32-libxi 1.3-2
lib32-libxinerama 1.1-1
lib32-libxmu 1.0.5-1
lib32-libxrandr 1.3.0-1
lib32-libxrender 0.9.6-1
lib32-libxslt 1.1.26-1
lib32-libxss 1.2.0-1
lib32-libxt 1.0.8-1
lib32-libxv 1.0.5-1
lib32-libxxf86dga 1.1.1-1
lib32-libxxf86vm 1.1.0-1
lib32-mesa 7.8.2-1
lib32-openssl 1.0.0.a-2
lib32-pcre 8.02-1
lib32-qt 4.6.3-1
lib32-sqlite3 3.6.23.1-1
lib32-util-linux-ng 2.17.2-2
lib32-zlib 1.2.5-2
libxfontcache 1.0.5-1
libxxf86misc 1.0.2-1
mysql-gui-tools 5.0r14-4
ndiswrapper-utils 1.56-2
squeeze 0.2.3-4
texlive-bibtexextra-doc 2008.12985-2
texlive-core-doc 2008.13013-1
texlive-fontsextra-doc 2008.13014-1
texlive-formatsextra-doc 2008.11913-1
texlive-games-doc 2008.12626-1
texlive-genericextra-doc 2008.12667-1
texlive-htmlxml-doc 2008.12803-1
texlive-humanities-doc 2008.11969-1
texlive-latex3-doc 2008.10126-2
texlive-latexextra-doc 2008.13033-1
texlive-music-doc 2008.7340-2
texlive-pictures-doc 2008.12087-1
texlive-plainextra-doc 2008.11913-1
texlive-pstricks-doc 2008.12873-2
texlive-publishers-doc 2008.11913-1
texlive-science-doc 2008.12088-1
thunar-vfs 1.2.0-2
thunderbird-spell-ru 3.1-1
ttf-ms-fonts 2.0-3
xf86miscproto 0.9.3-1
xfce4-icon-theme 4.4.3-2
xfce4-messenger-plugin 0.1.0-6
xfce4-playercontrol-plugin 0.3.0-1
xfce4-xfapplet-plugin 0.1.0-7
$

$ env
ORBIT_SOCKETDIR=/tmp/orbit-krivenok
SSH_AGENT_PID=3836
XDG_DATA_HOME=/home/krivenok/.local/share
GPG_AGENT_INFO=/tmp/keyring-GNxCNe/gpg:0:1
GLADE_PIXMAP_PATH=:
TERM=xterm
SHELL=/bin/bash
XDG_MENU_PREFIX=xfce-
HISTSIZE=1000
XDG_SESSION_COOKIE=b79c6be714d24a271b9b97254af70d85-1307951402.186020-1227276077
QT_XFT=true
WINDOWID=41958279
GNOME_KEYRING_CONTROL=/tmp/keyring-GNxCNe
QTDIR=/opt/qt
GTK_MODULES=canberra-gtk-module
HISTFILESIZE=1000
USER=krivenok
GLADE_MODULE_PATH=:
SSH_AUTH_SOCK=/tmp/keyring-GNxCNe/ssh
SESSION_MANAGER=local/olimpico-mobile:@/tmp/.ICE-unix/3858,unix/olimpico-mobile:/tmp/.ICE-unix/3858
USERNAME=krivenok
MOZ_PLUGIN_PATH=/usr/lib/mozilla/plugins
XDG_CONFIG_DIRS=/etc/xdg:/etc/xdg
PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/opt/kde/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/opt/qt/bin
DESKTOP_SESSION=xfce
PWD=/home/krivenok
JAVA_HOME=/usr/lib/jvm/java-6-openjdk
GNOME_KEYRING_PID=3799
LANG=
PS1=\[\033[01;34m\]\u@\h \t\[\033[01;34m\] \w \$\[\033[00m\] 
PS3=> 
GDMSESSION=xfce
HISTCONTROL=ignoredups
PS2=> 
PS4=+ 
HOME=/home/krivenok
SHLVL=2
XDG_CONFIG_HOME=/home/krivenok/.config
GTK_PATH=:/usr/lib/gtk-2.0
XDG_CACHE_HOME=/home/krivenok/.cache
LOGNAME=krivenok
XDG_DATA_DIRS=/usr/share/:/usr/local/share/:/opt/kde/share:/usr/share
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-dhoEuCXfIB,guid=6a08b000d2a68c3a6c6a704900000039
J2SDKDIR=/usr/lib/jvm/java-6-openjdk
PKG_CONFIG_PATH=:/opt/qt/lib/pkgconfig
PROMPT_COMMAND=history -a
WINDOWPATH=8
DISPLAY=:0.0
GLADE_CATALOG_PATH=:
LIBGLADE_MODULE_PATH=:
J2REDIR=/usr/lib/jvm/java-6-openjdk/jre
G_BROKEN_FILENAMES=1
COLORTERM=gnome-terminal
XAUTHORITY=/var/run/gdm/auth-for-krivenok-HKewEM/database
_=/usr/bin/env

Offline

#4 2011-06-13 09:30:06

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: Gtk-Message: Failed to load module "canberra-gtk-module"

GTK_PATH=:/usr/lib/gtk-2.0

this is the problem.
https://bugs.archlinux.org/task/23655

also, i see that you have some lib32 packages installed but you disabled multilib. i suggest to enable it again and fully update

Last edited by wonder (2011-06-13 09:33:02)


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#5 2011-06-15 08:40:01

krivenok
Member
Registered: 2011-06-13
Posts: 3

Re: Gtk-Message: Failed to load module "canberra-gtk-module"

Thanks a lot!

Offline

Board footer

Powered by FluxBB