You are not logged in.

#1 2011-06-13 16:10:20

Registered: 2010-01-24
Posts: 141

[Solved] GRUB, FakeRaid: Filesystem unknown, cannot mount partition

Hello folks I've been on an Arch Linux hiatus for a while because I've had a hard time setting up GRUB and a FakeRaid on a Vaio laptop with a quad raid0 SSD drive.

I followed the begginers, Fakeraid, and chroot wiki pages to the best of my knowleged but still can not get things setup properly. It's a bit too involved if you asked me and I only have Arch installed.

As far as I know GRUB stage 1.5 starts loading, in the boot menu I select Arch Linux, then I get the following error message:

Booting 'Arch Linux'

root (hd0,1)
  Filesystem type unknown, partition type 0x82
kernel /boot/vmlinux26 root=/dev/mapper/xxxxxxxxxxxxxxxx_Volume0p1 ro

Error 17: Cannot mount selected partition

I can't really figure out how to fix this, so any help is apreciated.


For reference this is how I have the drive partitioned

/dev/mapper/xxxxxxxxxxxxxxxx_Volume0p1 /
/dev/mapper/xxxxxxxxxxxxxxxx_Volume0p2 swap
/dev/mapper/xxxxxxxxxxxxxxxx_Volume0p3 extended
    /dev/mapper/xxxxxxxxxxxxxxxx_Volume0p5 ntfs

Last edited by snoxu (2011-06-13 17:52:21)


#2 2011-06-13 17:47:39

Registered: 2010-01-24
Posts: 141

Re: [Solved] GRUB, FakeRaid: Filesystem unknown, cannot mount partition

Nevermind I figured it out after a few long hours

I had to chroot into the system and edit the /boot/grub/menu.lst because my root partition is in (hd0,0) and (hd0,1) points to the swap partition

Too bad the grub setup and /arch/setup for fakeraids is a bit too involved and can be prone to error. Would be great if fakeraid setup was a bit more straight foward or somewhat automatic.

I never had this issue with my non raid systems.

Would of saved me a lot of precious hours.


Last edited by snoxu (2011-06-13 17:59:57)


Board footer

Powered by FluxBB