You are not logged in.

#1 2011-06-13 16:37:41

clincher
Member
Registered: 2011-06-13
Posts: 6

[Solved]unresolvable package conflicts detected

I installed Arch x86_64 yesterday and today I updated my mirrorlist and tried to do a -Syu and got this:

[clincher@lights ~]$ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace gir-repository with extra/gobject-introspection? [Y/n] y
:: Replace gnome2-user-docs with extra/gnome-user-docs? [Y/n] y
:: Replace gnome-themes with extra/gnome-themes-standard? [Y/n] y
:: Replace heimdal with core/krb5? [Y/n] y
:: Replace lib32-libjpeg with multilib/lib32-libjpeg-turbo? [Y/n] y
:: Replace lib32-util-linux-ng with multilib/lib32-util-linux? [Y/n] y
:: Replace libdjvu with extra/djvulibre? [Y/n] y
:: Replace libelf with extra/elfutils? [Y/n] y
:: Replace libjpeg with extra/libjpeg-turbo? [Y/n] y
:: Replace libv4l with extra/v4l-utils? [Y/n] y
:: Replace mailx with core/heirloom-mailx? [Y/n] y
:: Replace pycairo with extra/python2-cairo? [Y/n] y
:: Replace util-linux-ng with core/util-linux? [Y/n] y
resolving dependencies...
looking for inter-conflicts...
warning: removing 'libgl' from target list because it conflicts with 'nvidia-utils'
:: nvidia-utils and libgl are in conflict. Remove libgl? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: nvidia-utils and libgl are in conflict

Now, I don't even know why its giving that message cause I don't have an nvidia gpu. Can I remove the nvidia-utils package manually? I keep getting "target not found"

Any help will be appreciated

Last edited by clincher (2011-06-14 02:57:48)

Offline

#2 2011-06-13 17:25:24

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [Solved]unresolvable package conflicts detected

You don't have (yet) nvidia-utils installed. For some reason you want to install them - check what package pull it.

Offline

#3 2011-06-13 17:26:10

Leonid.I
Member
From: Aethyr
Registered: 2009-03-22
Posts: 994

Re: [Solved]unresolvable package conflicts detected

Which video driver do you use?

nvidia-utils is needed if you have an nvidia card and want to use the factory driver. It does provide libGL.so.xxx, so you can remove libgl.

On the other hand, if you use nouveau-dri (opengl extensionfor nouveau), you will need libgl:

~> pacman -Qi libgl
Required By    : libreoffice  mesa  mplayer  nouveau-dri

Arch Linux is more than just GNU/Linux -- it's an adventure
pkill -9 systemd

Offline

#4 2011-06-13 17:44:43

clincher
Member
Registered: 2011-06-13
Posts: 6

Re: [Solved]unresolvable package conflicts detected

karol wrote:

You don't have (yet) nvidia-utils installed. For some reason you want to install them - check what package pull it.

How do I check that? Remember, I'm just doing Syu, I don't know why it's giving me so much trouble

Leonid.I wrote:

Which video driver do you use?

I installed the xf86-video-ati driver after installing X

Offline

#5 2011-06-13 17:47:08

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [Solved]unresolvable package conflicts detected

paste pacman -Syu --debug


Give what you have. To someone, it may be better than you dare to think.

Offline

#6 2011-06-13 18:12:18

clincher
Member
Registered: 2011-06-13
Posts: 6

Re: [Solved]unresolvable package conflicts detected

Wonder wrote:

paste pacman -Syu --debug

debug: checkdeps: missing dependency 'popt' for package 'logrotate'
debug: checkdeps: missing dependency 'cron' for package 'logrotate'
debug: checkdeps: missing dependency 'gzip' for package 'logrotate'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package lzo2-2.05-1
debug: checkdeps: missing dependency 'glibc' for package 'lzo2'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package heirloom-mailx-12.5-1
debug: checkdeps: missing dependency 'openssl' for package 'heirloom-mailx'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package man-db-2.6.0.2-2
debug: checkdeps: missing dependency 'bash' for package 'man-db'
debug: checkdeps: missing dependency 'gdbm' for package 'man-db'
debug: checkdeps: missing dependency 'zlib' for package 'man-db'
debug: checkdeps: missing dependency 'groff' for package 'man-db'
debug: checkdeps: missing dependency 'libpipeline' for package 'man-db'
debug: pulling dependency libpipeline (needed by man-db)
debug: checkdeps: package libpipeline-1.2.0-1
debug: checkdeps: missing dependency 'glibc' for package 'libpipeline'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package man-pages-3.32-1
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package mdadm-3.2.1-3
debug: checkdeps: missing dependency 'glibc' for package 'mdadm'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package mono-2.10.2-1
debug: checkdeps: missing dependency 'zlib' for package 'mono'
debug: checkdeps: missing dependency 'libgdiplus>=2.10' for package 'mono'
debug: checkdeps: missing dependency 'sh' for package 'mono'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package mousetweaks-3.0.1-1
debug: checkdeps: missing dependency 'libxtst' for package 'mousetweaks'
debug: checkdeps: missing dependency 'gtk3' for package 'mousetweaks'
debug: checkdeps: missing dependency 'gsettings-desktop-schemas' for package 'mousetweaks'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package musicbrainz-2.1.5-4
debug: checkdeps: missing dependency 'expat>=2.0' for package 'musicbrainz'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package nano-2.2.6-1
debug: checkdeps: missing dependency 'ncurses' for package 'nano'
debug: checkdeps: missing dependency 'sh' for package 'nano'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package nautilus-sendto-3.0.0-1
debug: checkdeps: missing dependency 'evolution-data-server' for package 'nautilus-sendto'
debug: checkdeps: missing dependency 'nautilus' for package 'nautilus-sendto'
debug: checkdeps: missing dependency 'dconf' for package 'nautilus-sendto'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package netcfg-2.5.5-1
debug: checkdeps: missing dependency 'wireless_tools' for package 'netcfg'
debug: checkdeps: missing dependency 'coreutils' for package 'netcfg'
debug: checkdeps: missing dependency 'wpa_supplicant>=0.6.8' for package 'netcfg'
debug: checkdeps: missing dependency 'net-tools' for package 'netcfg'
debug: checkdeps: missing dependency 'dhcpcd>=4.0' for package 'netcfg'
debug: checkdeps: missing dependency 'iproute2' for package 'netcfg'
debug: pulling dependency wireless_tools (needed by netcfg)
debug: pulling dependency wpa_supplicant (needed by netcfg)
debug: pulling dependency net-tools (needed by netcfg)
debug: checkdeps: package wireless_tools-29-4
debug: checkdeps: missing dependency 'glibc' for package 'wireless_tools'
debug: checkdeps: package wpa_supplicant-0.7.3-3
debug: checkdeps: missing dependency 'openssl' for package 'wpa_supplicant'
debug: checkdeps: missing dependency 'dbus-core>=1.2.4' for package 'wpa_supplicant'
debug: checkdeps: missing dependency 'readline>=6.0' for package 'wpa_supplicant'
debug: checkdeps: package net-tools-1.60-18
debug: checkdeps: missing dependency 'glibc' for package 'net-tools'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package notification-daemon-0.7.1-1
debug: checkdeps: missing dependency 'gtk3' for package 'notification-daemon'
debug: checkdeps: missing dependency 'libcanberra' for package 'notification-daemon'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package orca-3.0.2-1
debug: checkdeps: missing dependency 'pygtk' for package 'orca'
debug: checkdeps: missing dependency 'python2-gconf' for package 'orca'
debug: checkdeps: missing dependency 'python2-libgnome' for package 'orca'
debug: checkdeps: missing dependency 'python-wnck' for package 'orca'
debug: checkdeps: missing dependency 'dbus-python' for package 'orca'
debug: checkdeps: missing dependency 'at-spi2-core' for package 'orca'
debug: checkdeps: missing dependency 'gnome-mag' for package 'orca'
debug: checkdeps: missing dependency 'brltty' for package 'orca'
debug: checkdeps: missing dependency 'pyxdg' for package 'orca'
debug: checkdeps: missing dependency 'pyatspi' for package 'orca'
debug: pulling dependency at-spi2-core (needed by orca)
debug: pulling dependency pyxdg (needed by orca)
debug: pulling dependency pyatspi (needed by orca)
debug: checkdeps: package at-spi2-core-2.0.2-1
debug: checkdeps: missing dependency 'dbus-core' for package 'at-spi2-core'
debug: checkdeps: missing dependency 'glib2' for package 'at-spi2-core'
debug: checkdeps: missing dependency 'libxtst' for package 'at-spi2-core'
debug: checkdeps: package pyxdg-0.19-2
debug: checkdeps: missing dependency 'python2' for package 'pyxdg'
debug: checkdeps: package pyatspi-2.0.2-1
debug: checkdeps: missing dependency 'pygobject' for package 'pyatspi'
debug: checkdeps: missing dependency 'at-spi2-core' for package 'pyatspi'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package pacman-mirrorlist-20110324-1
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package pcmciautils-017-2
debug: checkdeps: missing dependency 'glibc' for package 'pcmciautils'
debug: checkdeps: missing dependency 'sysfsutils' for package 'pcmciautils'
debug: checkdeps: missing dependency 'module-init-tools>=3.2pre9' for package 'pcmciautils'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package ppp-2.4.5-2
debug: checkdeps: missing dependency 'glibc' for package 'ppp'
debug: checkdeps: missing dependency 'libpcap>=1.0.0' for package 'ppp'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package pygtksourceview2-2.10.1-3
debug: checkdeps: missing dependency 'gtksourceview2>=2.10.0' for package 'pygtksourceview2'
debug: checkdeps: missing dependency 'pygtk>=2.17.0' for package 'pygtksourceview2'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package python-3.2-2
debug: checkdeps: missing dependency 'expat' for package 'python'
debug: checkdeps: missing dependency 'bzip2' for package 'python'
debug: checkdeps: missing dependency 'gdbm' for package 'python'
debug: checkdeps: missing dependency 'openssl' for package 'python'
debug: checkdeps: missing dependency 'zlib' for package 'python'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package python-pysqlite-2.6.0-2
debug: checkdeps: missing dependency 'python2' for package 'python-pysqlite'
debug: checkdeps: missing dependency 'sqlite3' for package 'python-pysqlite'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package reiserfsprogs-3.6.21-3
debug: checkdeps: missing dependency 'util-linux-ng>=2.16' for package 'reiserfsprogs'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package renderproto-0.11.1-1
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package rp-pppoe-3.10-6
debug: checkdeps: missing dependency 'ppp>=2.4.5' for package 'rp-pppoe'
debug: checkdeps: missing dependency 'sh' for package 'rp-pppoe'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package seahorse-3.0.2-1
debug: checkdeps: missing dependency 'gtk3' for package 'seahorse'
debug: checkdeps: missing dependency 'gconf' for package 'seahorse'
debug: checkdeps: missing dependency 'libgnome-keyring' for package 'seahorse'
debug: checkdeps: missing dependency 'gnome-keyring' for package 'seahorse'
debug: checkdeps: missing dependency 'libnotify' for package 'seahorse'
debug: checkdeps: missing dependency 'libsoup' for package 'seahorse'
debug: checkdeps: missing dependency 'desktop-file-utils' for package 'seahorse'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package sound-juicer-2.32.1-1
debug: checkdeps: missing dependency 'libmusicbrainz3' for package 'sound-juicer'
debug: checkdeps: missing dependency 'libgnome-media-profiles' for package 'sound-juicer'
debug: checkdeps: missing dependency 'gstreamer0.10-base-plugins' for package 'sound-juicer'
debug: checkdeps: missing dependency 'gstreamer0.10-good-plugins' for package 'sound-juicer'
debug: checkdeps: missing dependency 'brasero' for package 'sound-juicer'
debug: pulling dependency libmusicbrainz3 (needed by sound-juicer)
debug: checkdeps: package libmusicbrainz3-3.0.3-1
debug: checkdeps: missing dependency 'neon' for package 'libmusicbrainz3'
debug: checkdeps: missing dependency 'libdiscid' for package 'libmusicbrainz3'
debug: pulling dependency neon (needed by libmusicbrainz3)
debug: pulling dependency libdiscid (needed by libmusicbrainz3)
debug: checkdeps: package neon-0.29.6-1
debug: checkdeps: missing dependency 'krb5' for package 'neon'
debug: checkdeps: missing dependency 'expat' for package 'neon'
debug: checkdeps: missing dependency 'ca-certificates' for package 'neon'
debug: checkdeps: package libdiscid-0.2.2-1
debug: checkdeps: missing dependency 'glibc' for package 'libdiscid'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package sudo-1.8.1.p2-1
debug: checkdeps: missing dependency 'glibc' for package 'sudo'
debug: checkdeps: missing dependency 'pam' for package 'sudo'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package syslog-ng-3.2.4-1
debug: checkdeps: missing dependency 'glib2' for package 'syslog-ng'
debug: checkdeps: missing dependency 'eventlog' for package 'syslog-ng'
debug: checkdeps: missing dependency 'tcp_wrappers' for package 'syslog-ng'
debug: checkdeps: missing dependency 'openssl' for package 'syslog-ng'
debug: checkdeps: missing dependency 'libcap' for package 'syslog-ng'
debug: checkdeps: missing dependency 'awk' for package 'syslog-ng'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package tomboy-1.6.1-1
debug: checkdeps: missing dependency 'gtk2' for package 'tomboy'
debug: checkdeps: missing dependency 'gnome-sharp' for package 'tomboy'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package totem-3.0.1-2
debug: checkdeps: missing dependency 'gstreamer0.10-base-plugins' for package 'totem'
debug: checkdeps: missing dependency 'gstreamer0.10-good-plugins' for package 'totem'
debug: checkdeps: missing dependency 'totem-plparser' for package 'totem'
debug: checkdeps: missing dependency 'libxxf86vm' for package 'totem'
debug: checkdeps: missing dependency 'libxtst' for package 'totem'
debug: checkdeps: missing dependency 'desktop-file-utils' for package 'totem'
debug: checkdeps: missing dependency 'python2' for package 'totem'
debug: checkdeps: missing dependency 'libpeas' for package 'totem'
debug: checkdeps: missing dependency 'gnome-icon-theme-symbolic' for package 'totem'
debug: checkdeps: missing dependency 'gsettings-desktop-schemas' for package 'totem'
debug: checkdeps: missing dependency 'dconf' for package 'totem'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package ttf-dejavu-2.33-1
debug: checkdeps: missing dependency 'xorg-fonts-encodings' for package 'ttf-dejavu'
debug: checkdeps: missing dependency 'xorg-mkfontscale' for package 'ttf-dejavu'
debug: checkdeps: missing dependency 'xorg-mkfontdir' for package 'ttf-dejavu'
debug: pulling dependency xorg-fonts-encodings (needed by ttf-dejavu)
debug: pulling dependency xorg-mkfontscale (needed by ttf-dejavu)
debug: pulling dependency xorg-mkfontdir (needed by ttf-dejavu)
debug: checkdeps: package xorg-fonts-encodings-1.0.4-1
debug: checkdeps: package xorg-mkfontscale-1.0.8-1
debug: checkdeps: missing dependency 'freetype2' for package 'xorg-mkfontscale'
debug: checkdeps: missing dependency 'libfontenc' for package 'xorg-mkfontscale'
debug: checkdeps: package xorg-mkfontdir-1.0.6-2
debug: checkdeps: missing dependency 'sh' for package 'xorg-mkfontdir'
debug: checkdeps: missing dependency 'xorg-mkfontscale' for package 'xorg-mkfontdir'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package vi-1:050325-1
debug: checkdeps: missing dependency 'ncurses' for package 'vi'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package vinagre-3.0.1-1
debug: checkdeps: missing dependency 'libgnome-keyring' for package 'vinagre'
debug: checkdeps: missing dependency 'gtk-vnc' for package 'vinagre'
debug: checkdeps: missing dependency 'avahi' for package 'vinagre'
debug: checkdeps: missing dependency 'desktop-file-utils' for package 'vinagre'
debug: checkdeps: missing dependency 'telepathy-glib' for package 'vinagre'
debug: checkdeps: missing dependency 'dconf' for package 'vinagre'
debug: checkdeps: missing dependency 'libpeas' for package 'vinagre'
debug: checkdeps: missing dependency 'shared-mime-info' for package 'vinagre'
debug: checkdeps: missing dependency 'gnome-icon-theme' for package 'vinagre'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package vino-3.0.2-1
debug: checkdeps: missing dependency 'libnotify' for package 'vino'
debug: checkdeps: missing dependency 'libxtst' for package 'vino'
debug: checkdeps: missing dependency 'libsm' for package 'vino'
debug: checkdeps: missing dependency 'libsoup' for package 'vino'
debug: checkdeps: missing dependency 'telepathy-glib' for package 'vino'
debug: checkdeps: missing dependency 'gtk3' for package 'vino'
debug: checkdeps: missing dependency 'libgnome-keyring' for package 'vino'
debug: checkdeps: missing dependency 'avahi' for package 'vino'
debug: checkdeps: missing dependency 'desktop-file-utils' for package 'vino'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package wget-1.12-7
debug: checkdeps: missing dependency 'glibc' for package 'wget'
debug: checkdeps: missing dependency 'openssl' for package 'wget'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package xbitmaps-1.1.1-1
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package xf86-input-synaptics-1.4.0.901-1
debug: checkdeps: missing dependency 'libxtst' for package 'xf86-input-synaptics'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package xf86-video-ati-6.14.1-1
debug: checkdeps: missing dependency 'libpciaccess' for package 'xf86-video-ati'
debug: checkdeps: missing dependency 'libdrm' for package 'xf86-video-ati'
debug: checkdeps: missing dependency 'udev' for package 'xf86-video-ati'
debug: checkdeps: missing dependency 'pixman' for package 'xf86-video-ati'
debug: checkdeps: missing dependency 'ati-dri' for package 'xf86-video-ati'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package xfsprogs-3.1.5-1
debug: checkdeps: missing dependency 'util-linux-ng>=2.16' for package 'xfsprogs'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package xinetd-2.3.14-6
debug: checkdeps: missing dependency 'tcp_wrappers' for package 'xinetd'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package xorg-font-utils-7.6-2
debug: checkdeps: missing dependency 'xorg-bdftopcf' for package 'xorg-font-utils'
debug: checkdeps: missing dependency 'xorg-mkfontdir' for package 'xorg-font-utils'
debug: checkdeps: missing dependency 'xorg-mkfontscale' for package 'xorg-font-utils'
debug: checkdeps: missing dependency 'xorg-font-util' for package 'xorg-font-utils'
debug: pulling dependency xorg-bdftopcf (needed by xorg-font-utils)
debug: pulling dependency xorg-font-util (needed by xorg-font-utils)
debug: checkdeps: package xorg-bdftopcf-1.0.3-1
debug: checkdeps: missing dependency 'libxfont' for package 'xorg-bdftopcf'
debug: checkdeps: package xorg-font-util-1.2.0-1
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package xorg-server-utils-7.6-2
debug: checkdeps: missing dependency 'xorg-iceauth' for package 'xorg-server-utils'
debug: checkdeps: missing dependency 'xorg-sessreg' for package 'xorg-server-utils'
debug: checkdeps: missing dependency 'xorg-xcmsdb' for package 'xorg-server-utils'
debug: checkdeps: missing dependency 'xorg-xbacklight' for package 'xorg-server-utils'
debug: checkdeps: missing dependency 'xorg-xgamma' for package 'xorg-server-utils'
debug: checkdeps: missing dependency 'xorg-xhost' for package 'xorg-server-utils'
debug: checkdeps: missing dependency 'xorg-xinput' for package 'xorg-server-utils'
debug: checkdeps: missing dependency 'xorg-xmodmap' for package 'xorg-server-utils'
debug: checkdeps: missing dependency 'xorg-xrandr' for package 'xorg-server-utils'
debug: checkdeps: missing dependency 'xorg-xrdb' for package 'xorg-server-utils'
debug: checkdeps: missing dependency 'xorg-xrefresh' for package 'xorg-server-utils'
debug: checkdeps: missing dependency 'xorg-xset' for package 'xorg-server-utils'
debug: checkdeps: missing dependency 'xorg-xsetroot' for package 'xorg-server-utils'
debug: pulling dependency xorg-iceauth (needed by xorg-server-utils)
debug: pulling dependency xorg-sessreg (needed by xorg-server-utils)
debug: pulling dependency xorg-xcmsdb (needed by xorg-server-utils)
debug: pulling dependency xorg-xbacklight (needed by xorg-server-utils)
debug: pulling dependency xorg-xgamma (needed by xorg-server-utils)
debug: pulling dependency xorg-xhost (needed by xorg-server-utils)
debug: pulling dependency xorg-xinput (needed by xorg-server-utils)
debug: pulling dependency xorg-xmodmap (needed by xorg-server-utils)
debug: pulling dependency xorg-xrandr (needed by xorg-server-utils)
debug: pulling dependency xorg-xrefresh (needed by xorg-server-utils)
debug: pulling dependency xorg-xsetroot (needed by xorg-server-utils)
debug: checkdeps: package xorg-iceauth-1.0.5-1
debug: checkdeps: missing dependency 'libice' for package 'xorg-iceauth'
debug: checkdeps: package xorg-sessreg-1.0.6-2
debug: checkdeps: missing dependency 'glibc' for package 'xorg-sessreg'
debug: checkdeps: package xorg-xcmsdb-1.0.3-2
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xcmsdb'
debug: checkdeps: package xorg-xbacklight-1.1.2-2
debug: checkdeps: missing dependency 'libxrandr' for package 'xorg-xbacklight'
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xbacklight'
debug: checkdeps: package xorg-xgamma-1.0.4-2
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xgamma'
debug: checkdeps: missing dependency 'libxxf86vm' for package 'xorg-xgamma'
debug: checkdeps: package xorg-xhost-1.0.4-2
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xhost'
debug: checkdeps: missing dependency 'libxmu' for package 'xorg-xhost'
debug: checkdeps: package xorg-xinput-1.5.3-2
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xinput'
debug: checkdeps: missing dependency 'libxi' for package 'xorg-xinput'
debug: checkdeps: package xorg-xmodmap-1.0.5-2
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xmodmap'
debug: checkdeps: package xorg-xrandr-1.3.4-2
debug: checkdeps: missing dependency 'libxrandr' for package 'xorg-xrandr'
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xrandr'
debug: checkdeps: package xorg-xrefresh-1.0.4-2
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xrefresh'
debug: checkdeps: package xorg-xsetroot-1.1.0-2
debug: checkdeps: missing dependency 'libxmu' for package 'xorg-xsetroot'
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xsetroot'
debug: checkdeps: missing dependency 'libxcursor' for package 'xorg-xsetroot'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package xorg-utils-7.6-7
debug: checkdeps: missing dependency 'xorg-xdpyinfo' for package 'xorg-utils'
debug: checkdeps: missing dependency 'xorg-xdriinfo' for package 'xorg-utils'
debug: checkdeps: missing dependency 'xorg-xev' for package 'xorg-utils'
debug: checkdeps: missing dependency 'xorg-xlsatoms' for package 'xorg-utils'
debug: checkdeps: missing dependency 'xorg-xlsclients' for package 'xorg-utils'
debug: checkdeps: missing dependency 'xorg-xprop' for package 'xorg-utils'
debug: checkdeps: missing dependency 'xorg-xvinfo' for package 'xorg-utils'
debug: checkdeps: missing dependency 'xorg-xwininfo' for package 'xorg-utils'
debug: pulling dependency xorg-xdpyinfo (needed by xorg-utils)
debug: pulling dependency xorg-xdriinfo (needed by xorg-utils)
debug: pulling dependency xorg-xev (needed by xorg-utils)
debug: pulling dependency xorg-xlsatoms (needed by xorg-utils)
debug: pulling dependency xorg-xlsclients (needed by xorg-utils)
debug: pulling dependency xorg-xprop (needed by xorg-utils)
debug: pulling dependency xorg-xvinfo (needed by xorg-utils)
debug: pulling dependency xorg-xwininfo (needed by xorg-utils)
debug: checkdeps: package xorg-xdpyinfo-1.2.0-2
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xdpyinfo'
debug: checkdeps: missing dependency 'libxext' for package 'xorg-xdpyinfo'
debug: checkdeps: missing dependency 'libxtst' for package 'xorg-xdpyinfo'
debug: checkdeps: missing dependency 'libxxf86vm' for package 'xorg-xdpyinfo'
debug: checkdeps: missing dependency 'libxxf86dga' for package 'xorg-xdpyinfo'
debug: checkdeps: missing dependency 'libxcomposite' for package 'xorg-xdpyinfo'
debug: checkdeps: missing dependency 'libxinerama' for package 'xorg-xdpyinfo'
debug: checkdeps: missing dependency 'libdmx' for package 'xorg-xdpyinfo'
debug: checkdeps: package xorg-xdriinfo-1.0.4-2
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xdriinfo'
debug: checkdeps: missing dependency 'libgl' for package 'xorg-xdriinfo'
debug: checkdeps: package xorg-xev-1.1.0-2
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xev'
debug: checkdeps: package xorg-xlsatoms-1.1.0-2
debug: checkdeps: missing dependency 'libxcb' for package 'xorg-xlsatoms'
debug: checkdeps: package xorg-xlsclients-1.1.2-1
debug: checkdeps: missing dependency 'libxcb' for package 'xorg-xlsclients'
debug: checkdeps: package xorg-xprop-1.2.0-2
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xprop'
debug: checkdeps: package xorg-xvinfo-1.1.1-2
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xvinfo'
debug: checkdeps: missing dependency 'libxv' for package 'xorg-xvinfo'
debug: checkdeps: package xorg-xwininfo-1.1.1-2
debug: checkdeps: missing dependency 'libxcb' for package 'xorg-xwininfo'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package xorg-xauth-1.0.6-1
debug: checkdeps: missing dependency 'libxmu' for package 'xorg-xauth'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package xorg-xinit-1.3.0-3
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xinit'
debug: checkdeps: missing dependency 'xorg-xauth' for package 'xorg-xinit'
debug: finished resolving dependencies
debug: started resolving dependencies
debug: checkdeps: package xorg-xkb-utils-7.6-1
debug: checkdeps: missing dependency 'xorg-xkbutils' for package 'xorg-xkb-utils'
debug: checkdeps: missing dependency 'xorg-xkbcomp' for package 'xorg-xkb-utils'
debug: checkdeps: missing dependency 'xorg-xkbevd' for package 'xorg-xkb-utils'
debug: checkdeps: missing dependency 'xorg-setxkbmap' for package 'xorg-xkb-utils'
debug: pulling dependency xorg-xkbutils (needed by xorg-xkb-utils)
debug: pulling dependency xorg-xkbevd (needed by xorg-xkb-utils)
debug: checkdeps: package xorg-xkbutils-1.0.3-2
debug: checkdeps: missing dependency 'libxaw' for package 'xorg-xkbutils'
debug: checkdeps: missing dependency 'libxt' for package 'xorg-xkbutils'
debug: checkdeps: missing dependency 'libx11' for package 'xorg-xkbutils'
debug: checkdeps: package xorg-xkbevd-1.1.2-2
debug: checkdeps: missing dependency 'libxkbfile' for package 'xorg-xkbevd'
debug: finished resolving dependencies
debug: started sorting dependencies
debug: sorting dependencies finished
looking for inter-conflicts...
debug: looking for conflicts
debug: check targets vs targets
debug: check targets vs targets
debug: package nvidia-utils conflicts with libgl (by libgl)
debug: conflicting packages in the sync list: 'nvidia-utils' <-> 'libgl'
warning: removing 'libgl' from target list because it conflicts with 'nvidia-utils'
debug: check targets vs db and db vs targets
debug: check targets vs db
debug: package util-linux conflicts with util-linux-ng (by linux32)
debug: package util-linux conflicts with util-linux-ng (by util-linux-ng)
debug: package krb5 conflicts with heimdal (by heimdal)
debug: package libjpeg-turbo conflicts with libjpeg (by libjpeg)
debug: package elfutils conflicts with libelf (by libelf)
debug: package v4l-utils conflicts with libv4l (by libv4l)
debug: package nvidia-utils conflicts with libgl (by libgl)
debug: package gobject-introspection conflicts with gir-repository (by gir-repository)
debug: package python2-cairo conflicts with pycairo (by pycairo)
debug: package djvulibre conflicts with libdjvu (by libdjvu)
debug: package gnome-user-docs conflicts with gnome2-user-docs (by gnome2-user-docs)
debug: package gnome-themes-standard conflicts with gnome-themes (by gnome-themes)
debug: package lib32-util-linux conflicts with lib32-util-linux-ng (by lib32-util-linux-ng)
debug: package lib32-libjpeg-turbo conflicts with lib32-libjpeg (by lib32-libjpeg)
debug: package heirloom-mailx conflicts with mailx (by mailx)
debug: check db vs targets
debug: package util-linux conflicts with util-linux-ng (by linux32)
debug: package util-linux conflicts with util-linux-ng (by util-linux)
debug: package 'nvidia-utils' conflicts with 'libgl'
:: nvidia-utils and libgl are in conflict. Remove libgl? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: nvidia-utils and libgl are in conflict
debug: unregistering database 'local'
debug: freeing package cache for repository 'local'
debug: unregistering database 'core'
debug: freeing package cache for repository 'core'
debug: unregistering database 'extra'
debug: freeing package cache for repository 'extra'
debug: unregistering database 'community'
debug: freeing package cache for repository 'community'
debug: unregistering database 'multilib'
debug: freeing package cache for repository 'multilib'

It's too big for me to be able to copy the whole thing, hopefully all you need is the last bit

Offline

#7 2011-06-13 18:21:21

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [Solved]unresolvable package conflicts detected

just do pacman -S fb-client and then pacman -Su --debug | fb and paste the link


Give what you have. To someone, it may be better than you dare to think.

Offline

#8 2011-06-13 18:34:12

clincher
Member
Registered: 2011-06-13
Posts: 6

Re: [Solved]unresolvable package conflicts detected

wonder wrote:

just do pacman -S fb-client and then pacman -Su --debug | fb and paste the link

Thanks, I tried community/nopaste with no luck.
Anyway, here it is: http://paste.xinu.at/1WAB/

Offline

#9 2011-06-13 18:44:31

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [Solved]unresolvable package conflicts detected

heh, no wonder is trying to pull nvidia-utils.

debug: new version of 'lib32-nvidia-utils' found (256.35-5 => 270.41.19-1)
....
debug: checkdeps: missing dependency 'nvidia-utils' for package 'lib32-nvidia-utils'

pacman -Rdd lib32-nvidia-utils
pacman -Su lib32-libgl

Last edited by wonder (2011-06-13 18:46:24)


Give what you have. To someone, it may be better than you dare to think.

Offline

#10 2011-06-13 18:49:24

clincher
Member
Registered: 2011-06-13
Posts: 6

Re: [Solved]unresolvable package conflicts detected

Wow, this is a big update. Thanks a lot, wonder!
What's the difference between -Syu and -Su?

Last edited by clincher (2011-06-13 18:51:10)

Offline

#11 2011-06-13 20:48:26

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: [Solved]unresolvable package conflicts detected

man pacman:

-y, --refresh
Download a fresh copy of the master package list from the server(s) defined in pacman.conf(5). This should typically be used each time you use --sysupgrade or -u. Passing two --refresh or -y flags will force a refresh of all package lists even if they appear to be up to date.

Read the man page and pacman Wiki article. It can help you keep off from headaches. ;o)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

Board footer

Powered by FluxBB