You are not logged in.

#1 2011-06-14 19:42:19

Snuken
Member
Registered: 2011-06-14
Posts: 24

urxvt - color scheme won't change

Hi,
I've been googling for about an hour to try and fix my problem. I want to use urxvt as my terminal, because I've seen really good looking pictures of those terminals so I decided I wanted that myself. And I've been experamenting for more then an hour trying to get it right. But when I change .Xdefaults with a config I find on these forums, all that change is perhaps the window shape, and the font. But the colors stays the same.
What am I doing wrong?

edit: this is my .bashrc

#
# ~/.bashrc
#

# If not running interactively, don't do anything
[[ $- != *i* ]] && return

alias ls='ls --color=auto'
PS1='\[\e[1;32m\][\u@\h \W]\$\[\e[0m\] '

 if [[ $TERM =~ "xterm|*rxvt*" ]]; then
    # set -o functrace
    trap 'set_title' DEBUG
    fi

And this is my current .Xdefaults (i've tried many before that)

urxvt*font:             xft:Bitstream Vera Sans Mono:pixelsize=12
urxvt*termName:         rxvt
urxvt*background:       #000000
urxvt*foreground:       #cccccc
urxvt*scrollBar:        false
urxvt*perl-lib:         /usr/lib/urxvt/perl/
urxvt*perl-ext-common:  default,matcher
urxvt*urlLauncher:      /opt/mozilla/bin/firefox
urxvt*matcher.button:   1
#urxvt*fading:           50
#urxvt*fadeColor:        #000000

URxvt*dynamicColors:    on

Xft*dpi:                96
Xft*antialias:          true
Xft*hinting:            full

urxvt*depth:        32
urxvt*background:       rgba:0000/0000/0000/cccc

URxvt.transparent:   true
URxvt.tintColor:     black
URxvt.shading:       18 
 
URxvt*color0:      #000000
URxvt*color1:      #9e1828
URxvt*color2:      #aece92
URxvt*color3:      #968a38
URxvt*color4:      #414171
URxvt*color5:      #963c59
URxvt*color6:      #418179
URxvt*color7:      #bebebe
URxvt*color8:      #666666
URxvt*color9:      #cf6171
URxvt*color10:     #c5f779
URxvt*color11:     #fff796
URxvt*color12:     #4186be
URxvt*color13:     #cf9ebe
URxvt*color14:     #71bebe
URxvt*color15:     #ffffff

Last edited by Snuken (2011-06-14 19:48:11)

Offline

#2 2011-06-14 19:52:47

kofrad
Member
From: South Florida, USA
Registered: 2011-05-15
Posts: 45

Re: urxvt - color scheme won't change

Try using "URxvt.colorX:" instead, it's what works in my .Xresources file. Also ensure you run the following command after modifying the file, and then start a new urxvt to test the settings.

xrdb -merge ~/.Xresources

You also may want to check out this article for more information on .Xresources/.Xdefaults and how to ensure it properly loads when you login.
http://stray-notes.blogspot.com/2010/08 … aults.html


Desktop: Arch Linux | AMD Athlon 64 X2 Dual Core 5000+ | 3GB RAM | GeForce 6800 XT 512MB | 1TB+
Audio Studio: XP SP3 | Intel Pentium 4 3GHz Prescott | 1GB DDR | GeForce 6800 128MB | 120GB

Offline

#3 2011-06-14 20:00:37

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 25,245
Website

Re: urxvt - color scheme won't change

Read the wiki page: https://wiki.archlinux.org/index.php/Xdefaults

Also, comments in .Xdefaults are ! not #

Snuken wrote:

#urxvt*fading:           50
#urxvt*fadeColor:        #000000

There are some other things in there that may be problematic. Start simple and use what you understand, then add other options incrementally to work out what is breaking...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#4 2011-06-14 20:08:58

Snuken
Member
Registered: 2011-06-14
Posts: 24

Re: urxvt - color scheme won't change

Thanks for the responses. I've read both of those that you linked before posting here, but I still can't seem to get it right. I havn't written anything in those myself, I've only copied from people that has posted theirs on this forum. But I removed those 2 lines that you commented on, but still no change.
But the thing that is confusing me the most, is that sometimes when I copy somebodys .Xdefaults, everything changes.. except the color.

Offline

#5 2011-06-14 20:20:21

kofrad
Member
From: South Florida, USA
Registered: 2011-05-15
Posts: 45

Re: urxvt - color scheme won't change

What are your TERM and COLORTERM environment variables set to? They should be set in .bashrc. You should be using:

TERM='rxvt-unicode'
COLORTERM='rxvt-unicode-256color'

Desktop: Arch Linux | AMD Athlon 64 X2 Dual Core 5000+ | 3GB RAM | GeForce 6800 XT 512MB | 1TB+
Audio Studio: XP SP3 | Intel Pentium 4 3GHz Prescott | 1GB DDR | GeForce 6800 128MB | 120GB

Offline

#6 2011-06-14 20:28:25

Snuken
Member
Registered: 2011-06-14
Posts: 24

Re: urxvt - color scheme won't change

kofrad wrote:

What are your TERM and COLORTERM environment variables set to? They should be set in .bashrc. You should be using:

TERM='rxvt-unicode'
COLORTERM='rxvt-unicode-256color'

I didn't have those lines in there before, but I do now. So now it looks like this:

#
# ~/.bashrc
#

# If not running interactively, don't do anything
[[ $- != *i* ]] && return

alias ls='ls --color=auto'
TERM='rxvt-unicode'
COLORTERM='rxvt-unicode-256color'

It didn't help though sad

Last edited by Snuken (2011-06-14 20:28:45)

Offline

#7 2011-06-14 20:47:20

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 25,245
Website

Re: urxvt - color scheme won't change

Snuken wrote:

But the thing that is confusing me the most, is that sometimes when I copy somebodys .Xdefaults, everything changes.. except the color.

Don't. Until you know what you are doing. Follow the wiki, add items incrementally. You will learn a lot more than just cutting and pasting from other people's files...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#8 2011-06-14 20:54:27

Snuken
Member
Registered: 2011-06-14
Posts: 24

Re: urxvt - color scheme won't change

jasonwryan wrote:
Snuken wrote:

But the thing that is confusing me the most, is that sometimes when I copy somebodys .Xdefaults, everything changes.. except the color.

Don't. Until you know what you are doing. Follow the wiki, add items incrementally. You will learn a lot more than just cutting and pasting from other people's files...

Alright. I'll try to do my best to understand what everything does that's mentioned in the wiki. But do I need to edit both .Xdefault and resources? or how does that work?

And another thing. The wiki said to look for the default values in: /usr/share/X11/app-defaults/. but I don't got the urxvt there. Only UXTerm, XTerm and stuff like that.

Last edited by Snuken (2011-06-14 20:58:15)

Offline

#9 2011-06-14 21:04:37

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 25,245
Website

Re: urxvt - color scheme won't change

Use either .Xresources or the deprecated .Xdefaults - not both.

Use the urxvt man page for configuration details if that is your term.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB