You are not logged in.

#1 2011-06-17 13:55:48

dawidmt
Member
Registered: 2011-01-16
Posts: 12

E-MU 0202 (USB) on Linux

Do anyone have some experience with this card on linux. Is it working good? I have read that it works only with 44100/16bit - is this true?


Sorry for language mistakes.

Offline

#2 2011-06-19 18:10:15

Henry Flower
Member
Registered: 2010-04-12
Posts: 46

Re: E-MU 0202 (USB) on Linux

I use this with Arch (and have done with various other distros) with no problems.  44100/16 bit is all I have or use, so I don't know about the second part.

Offline

#3 2011-06-22 11:39:48

qdiesel
Member
Registered: 2008-05-19
Posts: 61

Re: E-MU 0202 (USB) on Linux

I have one. About two years ago it required a patch for alsa to add manual samplerate selection but now it can guess the right one by itself right out of the box.

Offline

#4 2011-10-25 18:34:12

junkie
Member
From: Hungary
Registered: 2011-10-12
Posts: 20

Re: E-MU 0202 (USB) on Linux

Uh oh.. What am I doing wrong then? I have a 0202, ALSA seems to pick it up, because aplay -l lists it, I can unmute it and set volume in alsamixer, but still I cannot get any sound out of it.
I made a script that makes it the default device (I have a similar script for the onboard and the HDMI device too, can switch between them like this with no problem).

Script ("emu-on"):

echo "
pcm.!default {
 type hw
 card 2
 device 0
}
" > ~/.asoundrc
sudo /etc/rc.d/alsa force-restart

After running the script, VLC plays the file, but no sound.
speaker-test -c 2 fails with an error:

speaker-test 1.0.24.2

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Sample format not available for playback: Invalid argument
Setting of hwparams failed: Invalid argument

Any ideas?

Offline

#5 2011-10-26 12:01:17

Henry Flower
Member
Registered: 2010-04-12
Posts: 46

Re: E-MU 0202 (USB) on Linux

For what it's worth, my asound.conf is:

defaults.pcm.dmix.rate 44100 #to avoid wrong rate

#True setup (like it must be in the alsa)
pcm.test {
    type asym
    playback.pcm {
        type plug
        slave.pcm "dmix:USB"
    }
    capture.pcm {
        type plug
        slave.pcm "dsnoop:USB"
    }
}


#Clean setup

pcm.emu {
    type plug
    slave {
        pcm "hw:0"
        rate 44100
    }
}

pcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}

You could give that a try (without the pulse parts if you're not using it) and see what happens.

Offline

Board footer

Powered by FluxBB