You are not logged in.

#1 2005-05-04 15:04:42

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

dvd playback in arch

i use either xine/mplayer to play dvd's...a recent problem of late is an odd microsecond skip/jerk every 30 seconds or so while playing a dvd..the screen freezes and resumes playback normally.....this does NOT happen when playing the extracted vob's or any other file on the hard disk..all dvd's play fine in windows...this problem happens in both my drives

for my dvd reader, hdparm -i gives:

/dev/hdc:

Model=DVD-ROM DDU1621, FwRev=VER S4.1, SerialNo=
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=0kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=yes, tPIO={min:227,w/IORDY:120}, tDMA={min:120,rec:150}
PIO modes:  pio0 pio1 pio2 pio3 pio4
DMA modes:  sdma0 sdma1 sdma2 mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 *udma2
AdvancedPM=no

* signifies the current active mode

thanks in advance!

Offline

#2 2005-05-18 10:19:19

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: dvd playback in arch

follow up :

this problem occurs with ANY large  avi file..even extracted vobs..so contrary to what i thought earlier it has nothing to do with my dvd drives...there are frames being dropped every 10 seconds or so..please help..

Offline

#3 2005-05-18 10:24:45

cmp
Member
Registered: 2005-01-03
Posts: 350

Re: dvd playback in arch

have you allready tried to enable frame dropping?
for me it worked.
part of my .mplayer/config

#video options
vo=xv,x11,
framedrop=yes
zoom=yes

Offline

#4 2005-05-18 10:46:10

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: dvd playback in arch

didnt help in mplayer.. : (

Offline

#5 2005-05-18 11:01:29

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: dvd playback in arch

i dont think the problem will solve itself with framedropping either...this happens only in arch..never in slack/mepis..i have an AMD athlon xp 2400 and 1GB of ram, so its definetely not my system specs..something in the kernel perhaps?

Offline

#6 2005-05-19 05:48:30

soniX
Member
From: Oslo, Norway
Registered: 2004-01-23
Posts: 161

Re: dvd playback in arch

I have the same problem....

Offline

#7 2005-05-19 07:57:18

Kern
Member
From: UK
Registered: 2005-02-09
Posts: 460

Re: dvd playback in arch

maybe try starting xine from a terminal and watching the text output as the dvd plays. may give some hint.

or running top as well. see if any processes are running at same time.

could also try changing the "niceness" of the process from a root terminal while it plays. renice  -18 <xine pid number>

Offline

#8 2005-05-19 12:46:01

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: dvd playback in arch

i get a lot of these:


fixing sound card drift by -3425 pts
fixing sound card drift by -2568 pts
fixing sound card drift by -1926 pts
fixing sound card drift by -1443 pts
video_out: throwing away image with pts 1793423 because it's too old (diff : 26691).
video_out: throwing away image with pts 1796426 because it's too old (diff : 23688).
video_out: throwing away image with pts 1799429 because it's too old (diff : 20685).
video_out: throwing away image with pts 1802432 because it's too old (diff : 17682).
video_out: throwing away image with pts 1805435 because it's too old (diff : 14679).
video_out: throwing away image with pts 1808438 because it's too old (diff : 11676).
video_out: throwing away image with pts 1811441 because it's too old (diff : 8673).
video_out: throwing away image with pts 1814444 because it's too old (diff : 5670).


any ideas? i thought it was maybe cause i was on reiser4 as root, but reiserfs has the same problem too..

Offline

#9 2005-05-19 12:47:02

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: dvd playback in arch

soniX : are u running a vanilla kernel? or a patched one? FYI im running 2.6.11-cko

Offline

#10 2005-05-19 18:32:27

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: dvd playback in arch

i recompiled a vanilla kernel..things seem to be *slightly* better with this kernel...but i shouldnt be getting dropped frames at all right?

Offline

#11 2005-05-19 18:35:53

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: dvd playback in arch

ok correction: the difference is about 50% with the vanilla kernel...so i guess im on the right track..still not perfect though...

Offline

#12 2005-05-20 11:48:36

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: dvd playback in arch

this problem does not happen if hal/dbus/ivman are disabled from starting up..and this does not happen in gnome irrespective of whether they start up or not...i use kde and need ivman..any workarounds?

Offline

#13 2005-05-20 12:24:12

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: dvd playback in arch

see which it is, is it hal or ivman? turn off ivman and see if you still have the problem, leave hal on.

Offline

#14 2005-05-20 13:20:04

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: dvd playback in arch

the problem is hal...some other people have a similar problem...but it happens only in kde..

Offline

#15 2005-05-20 14:33:23

soniX
Member
From: Oslo, Norway
Registered: 2004-01-23
Posts: 161

Re: dvd playback in arch

strange.. I just found what caused the problem with my kde, which was taskbar_v2.. bloody eyecandy (says the kde user... he he )
havent tested it for more than a couple of minutes, but without taskbar_v2, I have not had a single skip in the film... with it, I had small skips about every 20-30 second

Offline

#16 2005-05-30 05:26:42

ganja_guru
Member
Registered: 2005-02-14
Posts: 464

Re: dvd playback in arch

hey ure right..disabling  hal reduces the problem, but disabling taskbar v2 solves it completely...thanx man!

Offline

Board footer

Powered by FluxBB