You are not logged in.

#1 2011-07-11 09:48:52

Registered: 2011-07-03
Posts: 71

pwmconfig: pwm1_enable stuck to 2

I ran pwmconfig once before and it created /etc/fancontrol file, but now I can't run it again. This is the output:

Found the following devices:
   hwmon0 is acpitz
   hwmon1/device is thinkpad
   hwmon2/device is coretemp
   hwmon3/device is coretemp

Found the following PWM controls:
hwmon1/device/pwm1 is currently setup for automatic speed control.
In general, automatic mode is preferred over manual mode, as
it is more efficient and it reacts faster. Are you sure that
you want to setup this output for manual control? (n) y
hwmon1/device/pwm1_enable stuck to 2
Manual control mode not supported, skipping hwmon1/device/pwm1.
There are no usable PWM outputs.

This is in my daemons array:

hwclock syslog-ng sensors !network netfs dbus @networkmanager gdm @alsa @laptop-mode @crond @httpd @mysqld

All of the above daemons are running (except network of course), including sensors.

And this is in my modules array:


What is surprising is that I don't think I changed anything since the last time I ran pwmconfig and I think my pwm1_enable is always set to 2 (the file is refreshed in short intervals). The file is located in /sys/class/hwmon/hwmon1/device.


#2 2011-08-25 13:54:25

Registered: 2011-07-03
Posts: 71

Re: pwmconfig: pwm1_enable stuck to 2

Recently my laptop's fan runs on full speed. pwm1 value is constantly "255", even if I try to change it manually.

I still have no idea why my pwm1_enable is now set to "2" when it was obviously set to something else once.

Are there any modules I should load or unload? I'd really appreciate some help with this.


#3 2012-10-02 01:10:34

Registered: 2011-05-06
Posts: 3

Re: pwmconfig: pwm1_enable stuck to 2

sudo rmmmod thinkpad_acpi
sudo modprobe thinkpad_acpi fan_control=1
sudo sh -c 'echo 1 > /sys/class/hwmon/hwmon2/device/pwm1_enable'

First line removes thinkpad_acpi module. Second line starts the module and enables fan_control. Third line sets the value for pwm1_enable as 1.

This was tested on a  Thinkpad X61t; please match the hwmon identifiers with that of your laptop, in this case hwmon1.


Board footer

Powered by FluxBB