You are not logged in.

#1 2003-09-11 01:50:59

contrasutra
Member
From: New Jersey
Registered: 2003-07-26
Posts: 507

GNOME 2.4 is out!

Supa_User: Are you building packages?  wink

Im dying to try it, and I dont want to kill my poor processor compiling.


"Contrary to popular belief, penguins are not the salvation of modern technology.  Neither do they throw parties for the urban proletariat."

Offline

#2 2003-09-11 06:17:50

Blaasvis
Member
Registered: 2003-01-17
Posts: 467

Re: GNOME 2.4 is out!

look in incoming i helping supa user out to build some packages
tonight i will continue


Freedom is what i love

Offline

#3 2003-09-11 11:09:23

contrasutra
Member
From: New Jersey
Registered: 2003-07-26
Posts: 507

Re: GNOME 2.4 is out!

There are a few new packages in Gnome 2.4,from 2.2. Are you building those too?

If you tell me what to packages you want me to build, I can help.


"Contrary to popular belief, penguins are not the salvation of modern technology.  Neither do they throw parties for the urban proletariat."

Offline

#4 2003-09-11 19:56:40

Blaasvis
Member
Registered: 2003-01-17
Posts: 467

Re: GNOME 2.4 is out!

well i am done building.
you can find the packages in ftp://ftp.archlinux.org/incoming/gnome2.4/
please install all libs from the directory lib and system first else you might get in trouble sad
also before you start install do "pacman -Rd gnome-themes fontilus bonobo-activation"

If you get an error reinstall the according package...

gcalctool gnome-mag gnome-speech gnomemeeting gnopericus gok gucharmap still need to be build. i hope i'll have time tommorow.....
else any one is free to build them wink

happy testing...

also these are an first set i will add a few more packages soon.

http://www.kwando-tech.nl/blaasvis/Screenshot2.4.png
Screenshot2.4-small.png

click for an larger one wink


Freedom is what i love

Offline

#5 2003-09-11 20:49:54

Toth
Member
Registered: 2002-12-04
Posts: 82

Re: GNOME 2.4 is out!

Great job! It works beautifully. Much more responsive than 2.2.2. Thanks!

Offline

#6 2003-09-11 22:43:13

kritoke
Member
From: Texas, USA
Registered: 2003-08-01
Posts: 211
Website

Re: GNOME 2.4 is out!

Works wonderfully for me as well.  It is just so fast now.

Kritoke


http://counter.li.org/ Registered Linux User #318963 kritoke@jabber.org

Offline

#7 2003-09-12 02:25:47

contrasutra
Member
From: New Jersey
Registered: 2003-07-26
Posts: 507

Re: GNOME 2.4 is out!

OK, I installed gnome 2.4, and I like it. Its very nice. Im gonna stay with it for a while.

A couple things:

1. Gnome-terminal was not updated in your packages. I made a new package for myself, its the same as 2.2.2, but you need a newer vte (virtual terminal emulator), so I made that too.

I can upload that if you dont want to build it.

2. The "Stickies-Applet" doesnt seem to be working. Actually, its a big problem. I right clicked and added it to the panel, but it didnt appear anywhere, and its taking up like 50% CPU. Its obviously a bug, but I dont know how to remove the applet, since I cant right click on it.


"Contrary to popular belief, penguins are not the salvation of modern technology.  Neither do they throw parties for the urban proletariat."

Offline

#8 2003-09-12 06:31:05

Blaasvis
Member
Registered: 2003-01-17
Posts: 467

Re: GNOME 2.4 is out!

please do uploade vte ... i gotten some weird errors on compilen and even the devers of vte did not know a solution sad

hmmm about the sticky notes.... here it works fine smile

but you can try and "killall -HUP  /opt/gnome/libexec/stickynotes_applet"

also let see some screenies around here tongue


Freedom is what i love

Offline

#9 2003-09-12 09:02:26

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Re: GNOME 2.4 is out!

Hi,

Im not at my Linux box, so i cant try out this, can i run

pacman -Sfy gnome

like with KDE.


how long will be in incoming the package??

thanks.


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#10 2003-09-12 10:33:14

Toth
Member
Registered: 2002-12-04
Posts: 82

Re: GNOME 2.4 is out!

contrasutra wrote:

2. The "Stickies-Applet" doesnt seem to be working. Actually, its a big problem. I right clicked and added it to the panel, but it didnt appear anywhere, and its taking up like 50% CPU. Its obviously a bug, but I dont know how to remove the applet, since I cant right click on it.

Same thing happened here. Recompile gnome-applets...that worked for me.

I am having one other problem...if I set a panel to autohide, it never unhides. I tried rebuilding the panel but that didn't work. Anybody else getting this?

Offline

#11 2003-09-12 11:13:50

contrasutra
Member
From: New Jersey
Registered: 2003-07-26
Posts: 507

Re: GNOME 2.4 is out!

OK, ill try recompiling.

Also, I posted this in another thread, but what packages do I have to recompile to enable Xinerama, Metacity doesnt seem to be enough.

//
I am having one other problem...if I set a panel to autohide, it never unhides. I tried rebuilding the panel but that didn't work. Anybody else getting this?
//

I have the EXACT same problem.

Either someone didnt make the packages right, or GNOME 2.4 is buggy too. sad


"Contrary to popular belief, penguins are not the salvation of modern technology.  Neither do they throw parties for the urban proletariat."

Offline

#12 2003-09-12 12:08:12

Toth
Member
Registered: 2002-12-04
Posts: 82

Re: GNOME 2.4 is out!

I would try just the gnome-panel and see if that works. If not, it may be libgnome, libgnomeui, and maybe gnome-session.

BTW, Metacity's window placement is much, much better than what it was. Still not as good as Xfwm4 was, but it's good now. It won't just throw every window in the upper left corner anymore ;p

Offline

#13 2003-09-12 19:08:14

contrasutra
Member
From: New Jersey
Registered: 2003-07-26
Posts: 507

Re: GNOME 2.4 is out!

OK, I recompiled gnome-applets and stickies works now.

Honestly, if you only have to recompile Metacity to get Xinerama support, GNOMEs Xinerama support is super crappy. I mean, XFCEs is exceptional, but gnome is almost unbearable.


"Contrary to popular belief, penguins are not the salvation of modern technology.  Neither do they throw parties for the urban proletariat."

Offline

#14 2003-09-12 19:19:31

Toth
Member
Registered: 2002-12-04
Posts: 82

Re: GNOME 2.4 is out!

What about Xinerama doesn't work?

Here's what I found from a quick Google: http://gnomesupport.org/wiki/index.php/ … dQuestions

It looks like the following probably need to be built with Xinerama support (I'd check the ./configure --help in each individually):

libgnomeui
libbonobui
metacity
gnome-panel
eel
nautilus
gnome-applets

I would suggest recompiling them in that order. Of course, that WIKI was dealing with GNOME pre-2.2. This may have changed since then, but it's a start.

A quick look at the Arch PKGBUILDs for Gnome 2.2.2 didn't reveal any specific mention of Xinerama. Did Xinerama work fine for you with those packages?

If Xinerama needs to be specifically enabled, then it probably should be in the released packages.

Offline

#15 2003-09-12 19:43:22

contrasutra
Member
From: New Jersey
Registered: 2003-07-26
Posts: 507

Re: GNOME 2.4 is out!

Xinerama is detected during compile, so if the package maker doesnt have it on, it wont be enabled.

Damn, thats a lot to compile. I guess ill do it this weekend.

Right now, im about to compile some of the packages that blaasvis forgot, like gnome-audio.

Ill upload VTE too. Its version 11.0. anything newer wouldnt compile, and thats the minimum required for gnome terminal.

Where should I upload it? Into the gnome.2.4 dir, or just /incoming root?


"Contrary to popular belief, penguins are not the salvation of modern technology.  Neither do they throw parties for the urban proletariat."

Offline

#16 2003-09-12 20:44:24

contrasutra
Member
From: New Jersey
Registered: 2003-07-26
Posts: 507

Re: GNOME 2.4 is out!

OK, I have this problem when compiling gnome-panel:

checking X11/extensions/Xinerama.h usability... no
checking X11/extensions/Xinerama.h presence... yes
configure: WARNING: X11/extensions/Xinerama.h: present but cannot be compiled
configure: WARNING: X11/extensions/Xinerama.h: check for missing prerequisite headers?
configure: WARNING: X11/extensions/Xinerama.h: proceeding with the preprocessor's result
configure: WARNING:     ## ------------------------------------ ##
configure: WARNING:     ## Report this to bug-autoconf@gnu.org. ##
configure: WARNING:     ## ------------------------------------ ##


and the thing doesnt compile.

I dont get it, Xinerama works fine. Is there some missing library?

Damn.  :x


"Contrary to popular belief, penguins are not the salvation of modern technology.  Neither do they throw parties for the urban proletariat."

Offline

#17 2003-09-13 09:05:50

Blaasvis
Member
Registered: 2003-01-17
Posts: 467

Re: GNOME 2.4 is out!

contrasutra wrote:

Xinerama is detected during compile, so if the package maker doesnt have it on, it wont be enabled.

Damn, thats a lot to compile. I guess ill do it this weekend.

Right now, im about to compile some of the packages that blaasvis forgot, like gnome-audio.

Ill upload VTE too. Its version 11.0. anything newer wouldnt compile, and thats the minimum required for gnome terminal.

Where should I upload it? Into the gnome.2.4 dir, or just /incoming root?

just mail me it....
i will have a look at it ...


Freedom is what i love

Offline

#18 2003-09-13 20:49:48

contrasutra
Member
From: New Jersey
Registered: 2003-07-26
Posts: 507

Re: GNOME 2.4 is out!

OK, I sent you the stuff.


No one can help me with my Xinerama problem? sad

Can someone else try building gnome-panel w/ Xinerama enabled.


Its so annoying having "invisible panels" on my second monitor.


And also, all my apps open in the middle of the two screens, this gets very annoying obviously, as Id like to have them open up on my current monitor, does anyone know a setting for this?

There use to be one in 2.2, but that seems to have been taken out. sad


"Contrary to popular belief, penguins are not the salvation of modern technology.  Neither do they throw parties for the urban proletariat."

Offline

#19 2003-09-17 02:09:58

tyme
Member
From: PA
Registered: 2003-06-12
Posts: 139
Website

Re: GNOME 2.4 is out!

ok, i have a feeling this is a rather stupid question, but i can't seem to find an answer to it:

when i tried to install the acme package, i get this error:

[root@prajna acme]# pacman --upgrade acme*
loading package data... load_pkg: missing package info file in acme.install

any clues?

Offline

#20 2003-09-17 04:24:59

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: GNOME 2.4 is out!

You're trying to install acme.install, not acme-pkgver-release.pkg.tar.gz.

Try typing 'pacman --upgrade acme*.pkg.tar.gz' it might work better.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#21 2003-09-17 07:37:31

tyme
Member
From: PA
Registered: 2003-06-12
Posts: 139
Website

Re: GNOME 2.4 is out!

riiight...ok, i feel like a moron.  i'll crawl back into my hole now :-D

Offline

#22 2003-09-18 19:57:28

contrasutra
Member
From: New Jersey
Registered: 2003-07-26
Posts: 507

Re: GNOME 2.4 is out!

pacman -A foo.pkg.tar.gz foo1.pkg.tar.gz foo2.pkg.tar.gz 

"Contrary to popular belief, penguins are not the salvation of modern technology.  Neither do they throw parties for the urban proletariat."

Offline

#23 2003-09-19 07:17:30

Blaasvis
Member
Registered: 2003-01-17
Posts: 467

Re: GNOME 2.4 is out!

contrasutra wrote:
pacman -U foo.pkg.tar.gz foo1.pkg.tar.gz foo2.pkg.tar.gz 

not -A it should be -U


Freedom is what i love

Offline

#24 2003-09-19 21:26:28

contrasutra
Member
From: New Jersey
Registered: 2003-07-26
Posts: 507

Re: GNOME 2.4 is out!

I ALWAYS forget that. I usually end up finding out when actually trying -A. tongue


"Contrary to popular belief, penguins are not the salvation of modern technology.  Neither do they throw parties for the urban proletariat."

Offline

#25 2003-10-01 03:02:24

kritoke
Member
From: Texas, USA
Registered: 2003-08-01
Posts: 211
Website

Re: GNOME 2.4 is out!

How is all the beta testing and such going with Gnome 2.4?  I have been running it since it appeared in /Incoming and it has worked flawlessly.  Is there any real hold ups in updating Gnome in Pacman?  I am just curious, seeing as how all real discussion pertaining to this died down over a week ago.

Kritoke


http://counter.li.org/ Registered Linux User #318963 kritoke@jabber.org

Offline

Board footer

Powered by FluxBB