You are not logged in.

#1 2011-08-01 21:29:25

-Snowrider-
Member
Registered: 2011-05-03
Posts: 8

[SOLVED] Unexpected inconsistency run fsck manually

When I boot up my arch box (vertex 3 120 gb max imops ssd ) sda3 is my root partion formated ext2 and sda7 is my home partion formated ext4.

I get the following error.

now= Fri Jan 8 22:53:17 2010 is in the future (keep in mind this is incorrect)

/dev/sda3: unexpected inconsistency run fsck manually
(i.e. , without -a or -p options)

/dev/sda7 Superblock last write time (mon Aug 1 16:36:22 2011, now= Fri Jan 8 22:53:17 2010) is in the future

/dev/sda7: unexpected inconsistency run fsck manually
(i.e. , without -a or -p options)

*************File system check failed****************
Please repair manually and reboot. Note that the root filesytem is currently mounted read-only. To remount it read-write type: mount -n -o remount ,rw /
When you exit the maintinence shell the system will reboot autimatically.

I  proceeded to login to the maintinence shell and run fsck. I rebooted and I booted right in. No issues. If I reboot the system I have to run fsck again. This leads me to beleive it might be erroring on the shutdown/reboot. Any help would be appreciated. I'm trying to avoid a reinstall because i have to install my own ethernet module for internet not to fail so it makes the install a pain. If you need anymore information let me know.

Thanks, Mitch

Last edited by -Snowrider- (2011-08-06 21:34:13)

Offline

#2 2011-08-01 22:08:21

alphaniner
Member
From: Ancapistan
Registered: 2010-07-12
Posts: 2,810

Re: [SOLVED] Unexpected inconsistency run fsck manually

now= Fri Jan 8 22:53:17 2010

O RLY?

I think your system clock got messed up.

Last edited by alphaniner (2011-08-01 22:08:43)


But whether the Constitution really be one thing, or another, this much is certain - that it has either authorized such a government as we have had, or has been powerless to prevent it. In either case, it is unfit to exist.
-Lysander Spooner

Offline

#3 2011-08-01 23:02:01

-Snowrider-
Member
Registered: 2011-05-03
Posts: 8

Re: [SOLVED] Unexpected inconsistency run fsck manually

My hardware clock was messed up so I synced it with my system clock using this command:

hwclock --systohc --utc

I never thought that was what was causing the error even though it was telling me it was messed up. DUH!

After I synced it I rebooted 3 times with no issues. Before I mark it as solved I will wait a day to make sure there isn't any other issues. It seems so obvious now. I knew it was wrong but it took someone to say it to me to put two and two together.


Thanks

Offline

#4 2011-08-01 23:30:22

alphaniner
Member
From: Ancapistan
Registered: 2010-07-12
Posts: 2,810

Re: [SOLVED] Unexpected inconsistency run fsck manually

I only knew it off the bat because I've seen it numerous times.  I have a re-purposed RAID chassis with different drives containing different OSs.  I often need to change the system time (for purely honourable purposes, of course roll) and sometimes I forget to set it back before booting to Linux.


But whether the Constitution really be one thing, or another, this much is certain - that it has either authorized such a government as we have had, or has been powerless to prevent it. In either case, it is unfit to exist.
-Lysander Spooner

Offline

#5 2011-08-02 01:26:36

stqn
Member
Registered: 2010-03-19
Posts: 1,191
Website

Re: [SOLVED] Unexpected inconsistency run fsck manually

If your root is on an SSD you probably should be using ext4 with the discard option, and not ext2... Unless you prefer to run wiper.sh, I guess.

Offline

#6 2013-06-01 05:21:59

harshadura
Member
Registered: 2013-05-08
Posts: 5

Re: [SOLVED] Unexpected inconsistency run fsck manually

-Snowrider- wrote:

My hardware clock was messed up so I synced it with my system clock using this command:

hwclock --systohc --utc

I never thought that was what was causing the error even though it was telling me it was messed up. DUH!

After I synced it I rebooted 3 times with no issues. Before I mark it as solved I will wait a day to make sure there isn't any other issues. It seems so obvious now. I knew it was wrong but it took someone to say it to me to put two and two together.


Thanks

I am using Arch and i got the same issue in my machine, but my problem doesn't solved by this solution, While Googling i found another workaround in Fedora forums, I am sharing it here hope it will be helpful to someone cause its applicable for ArchLinux users as well.

Thanks: Ref: http://forums.fedoraforum.org/archive/i … 77866.html

Your system clock is wrong (are you booting into Windows by chance? it can mess up the system clock if you have Fedora set to use UTC, and Windows using local time). Yo may need to run fsck on more than just the filesystem that your Fedora system is on as well.

From the Fedora common bugs:


If you set back your system time for more than one day into the past, Fedora will not boot on next system restart. It will complain about your disk mount time being too far in the future. Typically the error message looks like this (dracut shell):

/dev/mapper/VolGroup-lv_root: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
(i.e., without -a or -p options)
dracut Warning: e2fsck returned with 4
dracut Warning: /dev/mapper/VolGroup-lv_root: Superblock last mount time (Tue
Oct 25 14:40:08 2011,
dracut Warning: now = Sun Sep 25 14:41:50 2011) is in the future.
dracut Warning: *** An error occurred during the file system check.
dracut Warning: *** Dropping you to a shell; the system will try
dracut Warning: *** to mount the filesystem(s), when you leave the shell.

Or it can look like this (emergency mode shell):

systemd-fsck[605]: /dev/sda2: Superblock last mount time (Tue Oct 25 10:40:12
2011,
systemd-fsck[605]: now = Sun Sep 25 10:41:59 2011) is in the future.
systemd-fsck[605]: /dev/sda2: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
systemd-fsck[605]: (i.e., without -a or -p options)
[ 13.652068] systemd-fsck[605]: fsck failed with error code 4.
Welcome to emergency mode. Use "systemctl default" or ^D to activate default
mode.
Give root password for maintenance
(or type Control-D to continue):

You have to use the shell to correct the filesystem that is claimed to be "inconsistent". If you have multiple partitions you may need to do the following procedure for all of them. The easiest approach is:

Note that partition name in the error message (/dev/mapper/VolGroup-lv_root and /dev/sda2 in our examples).
Run this command

fsck <partition name>

For example:

fsck /dev/sda2

and confirm you want to fix it.
Run

reboot

It may happen that you are presented with the error message, but you are not given any emergency shell. In that case please boot from the Fedora installation media and select Troubleshooting -> Rescue a Fedora system. After the rescue tool mounts your system disks you can just reboot, everything should be corrected.

Offline

#7 2013-06-01 05:25:36

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,194
Website

Re: [SOLVED] Unexpected inconsistency run fsck manually


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB