You are not logged in.

#1 2011-08-05 11:59:38

TwiNight
Member
Registered: 2011-06-04
Posts: 46

[SOLVED]How disable the autostart of application launchers in KDE 4.7?

I just upgraded to KDE 4.7 and noticed that during each time, the application launchers for Dolphin and Konquerer are there on the taskbar. I don't want them on the taskbar. What should I do disable thier autostart permanently? Also when I choose "Task manager settings" by right clicking on the taskbar and then close it, every time those launchers reappear. That's annoying.

Last edited by TwiNight (2011-08-07 04:55:46)

Offline

#2 2011-08-05 13:17:37

Dastingo
Member
Registered: 2011-01-15
Posts: 41

Re: [SOLVED]How disable the autostart of application launchers in KDE 4.7?

I have the same problem, though instead of Konqueror I get an icon-less launcher of Firefox, I have to manually delete them at every login and they always come back.
I deleted ~/.kde4 and it didn't help.

Offline

#3 2011-08-06 02:17:35

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED]How disable the autostart of application launchers in KDE 4.7?

http://aseigo.blogspot.com/2011/08/more … erlin.html says

One other small thing we did in 4.7 on the panel is make the default launchers in the taskbar for file manager and web browser follow your prefered applications as set in the system settings. Which means we have one configuration that we ship, but it matches what you want. Including if you change your mind later. Since they share space intelligently with the tasks, it means less space used: when the app is running, the launcher goes away. (Btw, a bug in 4.7.0 around that feature has been fixed for 4.7.1, so if that isn't working for you properly, the fix is just a patch level update away.)

Can you pick e.g. 'None' as you preferred app or disable that feature entirely? (I don't use KDE so I don't know if it's possible)

I think Dastingo set Firefox to be his preferred app and that's why he's getting it instead of Konquerer.

Offline

#4 2011-08-06 11:23:06

Dastingo
Member
Registered: 2011-01-15
Posts: 41

Re: [SOLVED]How disable the autostart of application launchers in KDE 4.7?

Looking at System Settings, I couldn't find a way to change the preferred applications to none, and yes I did make Firefox the default when I installed it.

Since the KDE devs are aware of this issue and it will be solved in 4.7.1 then I can wait (It's a minor issue after all).

Offline

#5 2011-08-06 11:29:31

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED]How disable the autostart of application launchers in KDE 4.7?

Dastingo wrote:

Since the KDE devs are aware of this issue and it will be solved in 4.7.1 then I can wait (It's a minor issue after all).

Not sure if this is the bug the author was talking about.


What happens if you click the launcher and start e.g. firefox? Does the launcher disappear? Does it reappear if you close the app?

Last edited by karol (2011-08-06 11:34:47)

Offline

#6 2011-08-06 11:48:12

Dastingo
Member
Registered: 2011-01-15
Posts: 41

Re: [SOLVED]How disable the autostart of application launchers in KDE 4.7?

If I click on dolphin once it launches the icon disappears but when I close it the icon doesn't come back.
As for Firefox the icon doesn't disappear no matter how many times I click it (It does launch firefox every time).

Also If I click on "Task Manager Settings" in the panel and click Ok the Firefox launcher return (after I remove it) but the Dolphin launcher does not.
I changed the default application from Firefox to Konqueror and it's launcher has the same issue.

Personally, I want these launchers removed completely because I use the Lancelot menu and all my most used apps are there.

Update: Ok I was able to fix the Web Browser launcher and make it disappear when it launches by changing the file associations for html files in System Settings (It had two firefox choices in the list one of them was custom launcher so I deleted it)

Now both Firefox and dolphin disappear when I click on their launchers.

Now the remaining question: Is it possible to disable these launchers from appearing at all?

Last edited by Dastingo (2011-08-06 12:02:39)

Offline

#7 2011-08-06 12:07:59

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED]How disable the autostart of application launchers in KDE 4.7?

Dastingo wrote:

If I click on dolphin once it launches the icon disappears but when I close it the icon doesn't come back.

I believe that's the bug they've fixed in 4.7.1.

Dastingo wrote:

Now the remaining question: Is it possible to disable these launchers from appearing at all?

I think you should ask this on the KDE forum.

Offline

#8 2011-08-06 13:08:21

gedgon
Member
From: Poland
Registered: 2011-01-27
Posts: 91

Re: [SOLVED]How disable the autostart of application launchers in KDE 4.7?

Dastingo wrote:

Now the remaining question: Is it possible to disable these launchers from appearing at all?

In ~/.kde4/share/config/plasma-desktop-appletsrc find and delete

browser=preferred://browser, , ,\s
filemanager=preferred://filemanager, , ,\s

Offline

#9 2011-08-06 13:41:33

Dastingo
Member
Registered: 2011-01-15
Posts: 41

Re: [SOLVED]How disable the autostart of application launchers in KDE 4.7?

Thanks gedgon, That did solve my issue and the launchers do not appear anymore.

I'm not the OP though so can't mark this as [SOLVED].

Offline

#10 2011-08-06 15:20:44

Hyugga
Member
From: Santiago, Chile
Registered: 2010-03-26
Posts: 331

Re: [SOLVED]How disable the autostart of application launchers in KDE 4.7?

I solve the problem deleting the panel and making a new one.

Offline

#11 2011-08-07 04:55:16

TwiNight
Member
Registered: 2011-06-04
Posts: 46

Re: [SOLVED]How disable the autostart of application launchers in KDE 4.7?

gedgon wrote:
Dastingo wrote:

Now the remaining question: Is it possible to disable these launchers from appearing at all?

In ~/.kde4/share/config/plasma-desktop-appletsrc find and delete

browser=preferred://browser, , ,\s
filemanager=preferred://filemanager, , ,\s

Thanks a lot. That worked like a charm. :-)

Offline

#12 2013-07-13 16:47:46

Jaloo
Member
Registered: 2013-07-13
Posts: 1

Re: [SOLVED]How disable the autostart of application launchers in KDE 4.7?

gedgon wrote:
Dastingo wrote:

Now the remaining question: Is it possible to disable these launchers from appearing at all?

In ~/.kde4/share/config/plasma-desktop-appletsrc find and delete

browser=preferred://browser, , ,\s
filemanager=preferred://filemanager, , ,\s

It works at slackware 14.0.

Offline

#13 2013-07-13 17:08:23

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,793

Re: [SOLVED]How disable the autostart of application launchers in KDE 4.7?

Hi Jaloo, and welcome to Arch Linux.  Note that you are responding to a three year old thread.   Much has changed in this time; it is unlikely this thread is still relevant to modern systems.  I am going to go ahead and close this thread.
https://wiki.archlinux.org/index.php/Fo … Bumping.22


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB