You are not logged in.

#1 2011-08-09 07:08:41

akb825
Member
Registered: 2011-03-27
Posts: 77

Radeon HDMI audio now disabled by default in Linux 3.0

Due to some people having blank screens linked to the HDMI audio support in the open source Radeon driver, HDMI audio is now disabled by default. However, if you used the HDMI audio before upgrading to Linux 3.0, you'll notice your sound doesn't work anymore.

To re-enable HDMI audio, in /boot/grub/menu.lst, add this to the end of your "kernel" line:
radeon.audio=1

For example, this is my first "kernel" line in my menu.lst (I left the fallback alone):
kernel /boot/vmlinuz-linux root=/dev/sda1 ro radeon.audio=1

After a reboot, your sound should be restored.

Offline

#2 2011-08-15 03:49:42

gentoofu
Member
Registered: 2006-10-05
Posts: 33

Re: Radeon HDMI audio now disabled by default in Linux 3.0

Like.

Offline

#3 2011-08-16 00:08:21

QuimaxW
Member
From: Waukesha, WI
Registered: 2006-12-03
Posts: 218

Re: Radeon HDMI audio now disabled by default in Linux 3.0

Ah ha!

Two days trying to figure this out!

Oh yea...and I added this to the wiki. smile

Last edited by QuimaxW (2011-08-17 01:35:23)

Offline

#4 2011-09-04 04:17:41

grandtheft
Member
Registered: 2010-10-05
Posts: 26

Re: Radeon HDMI audio now disabled by default in Linux 3.0

I am going to link to this thread from the alsa wiki.

Because with sound not working, what ppl do is aplay -D [their hdmi device] and no error message is displayed but no sound.
Then they go to the wiki https://wiki.archlinux.org/index.php/Ad … s_Not_Work and dont find help.

Thx akb825 !

gt

Offline

#5 2011-09-12 09:27:24

dubbe
Member
Registered: 2011-09-12
Posts: 1

Re: Radeon HDMI audio now disabled by default in Linux 3.0

I've installed Grub2, where do I add the line to then?

Offline

#6 2011-09-12 10:51:22

grandtheft
Member
Registered: 2010-10-05
Posts: 26

Re: Radeon HDMI audio now disabled by default in Linux 3.0

There are several places where you can do that, e.g. in /etc/grub...
If everything else fails, you can put it in the grub.cfg, which is quite alike the menu.lst, but ofc, the usage concept is different.

https://wiki.archlinux.org/index.php/GRUB2

Best,gt

Offline

#7 2011-09-14 00:00:31

jlindgren
Member
Registered: 2011-02-27
Posts: 196

Re: Radeon HDMI audio now disabled by default in Linux 3.0

I ran into this the other day also, and (not knowing the solution) had to boot into Windows while everyone waited.  I still dream about the day I can plug my laptop into a TV and know that it will just work.

Offline

#8 2011-10-08 10:37:36

benny_kenobi
Member
From: poland
Registered: 2011-04-15
Posts: 17

Re: Radeon HDMI audio now disabled by default in Linux 3.0

Big thanks for the tip akb825! It kinda astounded why hdmi sound wouldn't work when I switched from the proprietary driver.

Offline

#9 2011-11-12 07:12:03

qubodup
Member
From: Berlin, Germany
Registered: 2008-01-19
Posts: 61
Website

Re: Radeon HDMI audio now disabled by default in Linux 3.0

I did what is said here but audio will not work.

kernel /boot/vmlinuz26 root=/dev/disk/by-uuid/f16ef16a-2e5c-4725-97e0-9ae1f947c86f ro nomodeset radeon.audio=1

My alsa-info is http://www.alsa-project.org/db/?f=0eb0e … 26897b908c

Notable is the fact that when running

$ aplay -D plughw:0,3 /usr/share/sounds/alsa/Front_Center.wav

there is no error but the program finishes instantly, rather than being busy for 1.43 seconds which it usually takes to play back that sound.

speaker-test -D plughw:0,3

also rapidly progresses to the next tests.

alsamixer only has one option: "S/PDIF:ON"

One more info: I also have an on-board sound card, which uses the same module, so I disabled it in BIOS.

I'd be glad to have my audio back.

PS: oh. vYjhzcw - http://www.x.org/wiki/RadeonFeature

Last edited by qubodup (2011-11-12 17:18:00)

Offline

#10 2012-01-13 20:12:46

Sean-Der
Member
Registered: 2007-09-30
Posts: 88

Re: Radeon HDMI audio now disabled by default in Linux 3.0

qubodup I have a very simmilar setup to yours.

http://www.alsa-project.org/db/?f=351b1 … 17a9ecb5c2

Were you able to ever get your sound working or did you rollback your kernel to one that works for you?

Offline

#11 2012-01-14 01:45:40

qubodup
Member
From: Berlin, Germany
Registered: 2008-01-19
Posts: 61
Website

Re: Radeon HDMI audio now disabled by default in Linux 3.0

Not a chance I'm afraid. I now use the on-board sound card with analog output.

Offline

#12 2012-01-21 19:17:11

lamnk
Member
Registered: 2008-01-30
Posts: 65
Website

Re: Radeon HDMI audio now disabled by default in Linux 3.0

Evergreen cards support HDMI audio now, but only until kernel 3.3 :-(

Offline

Board footer

Powered by FluxBB