You are not logged in.

#1 2005-05-16 21:41:05

Euphoric Nightmare
Member
From: Kentucky
Registered: 2005-05-02
Posts: 283

error: mozilla-firefox conflicts with nss-nspr

I get this message when I try:

#>pacman -S gnome

i get:

error:  mozilla-firefox conflicts with nss-nspr

i tried upgraded all installed packages, and still got this error.  I'm still not used to pacman, so I could have missed a step or something.  The only other packages I had installed besides the base system at this point was hwd and xorg.

I removed hwd and still got the same message.

Offline

#2 2005-05-16 22:51:46

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: error: mozilla-firefox conflicts with nss-nspr

pacman does a check on all dependencies and conflicts. For gnome, one of the dependencies was firefox but firefox conflicts with nss-nspr. You need to unistall nss-nspr. To unistall do:

pacman -Rn nss-nspr

-R will remove and n will remove the config files.

Offline

#3 2005-05-16 23:31:24

Euphoric Nightmare
Member
From: Kentucky
Registered: 2005-05-02
Posts: 283

Re: error: mozilla-firefox conflicts with nss-nspr

do you know what that particular package is?

Offline

#4 2005-05-17 00:05:11

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: error: mozilla-firefox conflicts with nss-nspr

[root@somehost# pacman -Ss nss-nspr
current/mozilla-firefox 1.0.4-1
    Standalone web browser from mozilla.org
current/nss-nspr 3.9.2-1
    NSS and NSPR from mozilla.org

its some kind of browser. I thought it was the old mozilla but I'm not sure.

Offline

#5 2005-05-17 00:38:33

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: error: mozilla-firefox conflicts with nss-nspr

No, it's extra libraries of some sort. Firefox used to contribute only Gecko (the actual rendering engine), whereas Mozilla gave both Gecko and NSS-NSPR. Now Firefox gives both, and Mozilla no longer provides the latter... Thus, Firefox and the separate NSS-NSPR package conflict.

Offline

#6 2005-05-17 00:54:42

Euphoric Nightmare
Member
From: Kentucky
Registered: 2005-05-02
Posts: 283

Re: error: mozilla-firefox conflicts with nss-nspr

Okay, so it is safe to get rid of this then.

Offline

#7 2005-05-17 06:51:34

Sader
Member
Registered: 2005-03-31
Posts: 42

Re: error: mozilla-firefox conflicts with nss-nspr

I've got the same problem with one exception - I've got no "nss-nspr" installed on my system :shock:

[root@localhost evgeny]# pacman -S gnome
:: group gnome:
    control-center gnome-applets gnome-backgrounds gnome-common gnome-desktop 
    gnome-icon-theme gnome-media gnome-mime-data gnome-panel gnome-session 
    gnome-themes gnome2-user-docs metacity nautilus vte yelp 
    Install whole content? [Y/n] y
:: gnome-common-2.8.0-9: is up to date.  Upgrade anyway? [Y/n] n
:: gnome-icon-theme-2.10.1-1: is up to date.  Upgrade anyway? [Y/n] n
:: gnome-mime-data-2.4.2-1: is up to date.  Upgrade anyway? [Y/n] n
:: vte-0.11.13-1: is up to date.  Upgrade anyway? [Y/n] n

error: mozilla-firefox conflicts with nss-nspr
[root@localhost evgeny]# pacman -R nss-nspr
error: could not find nss-nspr in database

Did I missed something ?

Thnks.

Offline

#8 2005-05-17 09:23:10

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: error: mozilla-firefox conflicts with nss-nspr

Install Firefox, then GNOME.

Offline

#9 2005-05-17 22:05:17

Euphoric Nightmare
Member
From: Kentucky
Registered: 2005-05-02
Posts: 283

Re: error: mozilla-firefox conflicts with nss-nspr

Here's what i did, and now I have gnome.

>pacman -S nss-nspr
>pacman -S gnome

Didn't make much sense to me, but it worked. Let me know if that works for you as well.

EDIT:  Sorry the -y option shouldn't be there.  I have removed it from the original message.

Offline

#10 2005-05-17 23:53:23

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: error: mozilla-firefox conflicts with nss-nspr

Wait... You want to use Mozilla Suite? Because that's the only graphical browser for GNOME if you're not using Firefox...

Offline

#11 2005-05-18 01:23:37

Euphoric Nightmare
Member
From: Kentucky
Registered: 2005-05-02
Posts: 283

Re: error: mozilla-firefox conflicts with nss-nspr

it seems that you have to have this package before installing firefox.  I didn't run into this problem with previous builds...but this was my first successful install of gnome with arch

edit:  actually i didn't have to install that package the other day, when I installed the arch base system along with xorg, and xscreensaver.  However, when I installed only the base system, and then later installed xorg with pacman, i was required to install this package before i could get gnome to install

Offline

#12 2005-05-18 10:34:28

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: error: mozilla-firefox conflicts with nss-nspr

NSS-NSPR is uninstalled when you install Firefox.

Offline

Board footer

Powered by FluxBB