You are not logged in.

#1 2011-08-13 19:57:42

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,613
Website

gnome3 - have to enter to unlock keyring

All of a sudden, when I ssh into a box with public key auth, gnome-terminal is forcing me to enter the password in the terminal.  In the past, the passwords were unlocked when I logged into gnome.  I haven't changed any of my config files.  What would cause this?

$ ssh mars
Enter passphrase for key '/home/facade/.ssh/id_rsa':

The daemon is running...

$ ps aux | grep key
facade   4667  0.0  0.0 146748  3492 ?        Sl   15:53   0:00 /usr/bin/gnome-keyring-daemon --daemonize --login

EDIT: if I log into xfce4 on the same box, I am not prompted for my password at all.  WTF?

EDIT years later:  It seems as though checking 'start gnome services' checked in the startup session options followed by a logout/restat of lxdm fixes this.

Last edited by graysky (2014-11-17 14:26:51)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

Board footer

Powered by FluxBB