You are not logged in.

#2476 2014-03-12 09:50:02

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

cguenther wrote:

i did a full system upgrade today an i can't Boot anymore to the unity desktop. my dmesg shows "compiz[6556]: segfault at 0 ip 00007f7b9b0711ad sp 00007fff95614740 error 4 in libunityshell.so[7f7b9aeac000+483000]". Also a second line with segfaul of compiz inside libunityshell follows. I tried the compiz.reset, but the step 3 gives an error for creating the commandline.  What can I do to geht a real clean unity compiz? I also tried uninstalling all unity arch packages and reinstalled them. But it does not fixed it.

I confirm this also happened on my machine. I suspect some packages are  binary incompatible. So I've tried recompiling compiz-ubuntu which doesn't help. The compiling of unity failed.

Downgrading nux to 4.0.3 enables me to log into unity desktop. But it's highly unstable. Compiz automatically restart from time to time.

Offline

#2477 2014-03-12 12:54:08

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

I found that downgrading the following packages would make unity work. Some packages may not be necessarily downgraded.
But at least it works.

[2014-03-12 10:36] [PACMAN] downgraded libunity (7.1.4.14.04.20140210-100 -> 7.1.3.14.04.20131106-100)
[2014-03-12 10:38] [PACMAN] downgraded nux (4.0.5.14.04.20140226-100 -> 4.0.3.13.10.20131011-100)
[2014-03-12 10:57] [PACMAN] downgraded unity-gtk-module (1:0.0.0daily14.02.13.2-1 -> 0.0.0daily13.11.25-1)
[2014-03-12 11:27] [PACMAN] downgraded zeitgeist-ubuntu (0.9.14-2 -> 0.9.14-1)
[2014-03-12 11:28] [PACMAN] downgraded ido (13.10.0daily14.02.13-101 -> 13.10.0daily13.11.27-100)
[2014-03-12 11:29] [PACMAN] downgraded metacity-ubuntu (2.34.13.0ubuntu4-106 -> 2.34.13.0ubuntu2-105)
[2014-03-12 11:29] [PACMAN] downgraded nautilus-ubuntu (3.10.1-102 -> 3.10.1-101)
[2014-03-12 11:30] [PACMAN] downgraded libnautilus-extension-ubuntu (3.10.1-102 -> 3.10.1-101)

Offline

#2478 2014-03-13 09:26:04

cguenther
Member
Registered: 2013-06-18
Posts: 8

Re: Progress on Unity under Arch Linux!

Thank you for fixing the problem!

Offline

#2479 2014-03-14 01:49:13

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

cguenther wrote:

Thank you for fixing the problem!

Thanks to qiuwei for finding the packages to revert! smile

I was working on GNOME 3.12 support early so we don't run into a mess of issues like we did with GNOME 3.10, but I accidentally pushed all the changes to the wrong branch. My server built all of those packages and uploaded them to the repo which broke everything.


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#2480 2014-03-15 18:10:02

gianluca.pettinello
Member
Registered: 2013-04-16
Posts: 56

Re: Progress on Unity under Arch Linux!

Is there a chance to see compiz 0.9.11 soon ?
Thank Chen to work for gnome 3.12 before it gets out so to make a smooth transition. Very wise
Gianluca

Offline

#2481 2014-03-15 18:31:38

sb56637
Member
Registered: 2009-02-18
Posts: 62

Re: Progress on Unity under Arch Linux!

Hi,

Impressive progress! I installed Unity from the Dropbox repo, and it basically all works, both on Virtualbox and on an old laptop bare metal.

However, for some reason on both installations, the entire Unity interface from time to time acts like it crashes and restarts. When it does this the wallpaper remains, but everything else, including  application windows, disappears. Sometime it all re-appears after a few seconds, but other times it doesn't, and the desktop becomes unusable with just a wallpaper. Any ideas what is going on? Sorry I don't know which log files are relevant. I looked at xsession-errors but there doesnt seem to be anything related.

Thanks!

EDIT: By the way, both of the installations were 32-bit, not sure if that might have something to do with it.
EDIT2: I just tried it in a 64-bit VirtualBox install, behaves the same.

Last edited by sb56637 (2014-03-17 00:38:55)

Offline

#2482 2014-03-17 20:21:06

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

sb56637 wrote:

Hi,

Impressive progress! I installed Unity from the Dropbox repo, and it basically all works, both on Virtualbox and on an old laptop bare metal.

However, for some reason on both installations, the entire Unity interface from time to time acts like it crashes and restarts. When it does this the wallpaper remains, but everything else, including  application windows, disappears. Sometime it all re-appears after a few seconds, but other times it doesn't, and the desktop becomes unusable with just a wallpaper. Any ideas what is going on? Sorry I don't know which log files are relevant. I looked at xsession-errors but there doesnt seem to be anything related.

Thanks!

EDIT: By the way, both of the installations were 32-bit, not sure if that might have something to do with it.
EDIT2: I just tried it in a 64-bit VirtualBox install, behaves the same.


Hi, you may try downgrading all of the packages I mentioned above.
Chen has reverted some of them in his repo, but not all.

Offline

#2483 2014-03-18 04:35:51

sb56637
Member
Registered: 2009-02-18
Posts: 62

Re: Progress on Unity under Arch Linux!

qiuwei wrote:
sb56637 wrote:

Hi,

Impressive progress! I installed Unity from the Dropbox repo, and it basically all works, both on Virtualbox and on an old laptop bare metal.

However, for some reason on both installations, the entire Unity interface from time to time acts like it crashes and restarts. When it does this the wallpaper remains, but everything else, including  application windows, disappears. Sometime it all re-appears after a few seconds, but other times it doesn't, and the desktop becomes unusable with just a wallpaper. Any ideas what is going on? Sorry I don't know which log files are relevant. I looked at xsession-errors but there doesnt seem to be anything related.

Thanks!

EDIT: By the way, both of the installations were 32-bit, not sure if that might have something to do with it.
EDIT2: I just tried it in a 64-bit VirtualBox install, behaves the same.


Hi, you may try downgrading all of the packages I mentioned above.
Chen has reverted some of them in his repo, but not all.

Hi, thanks very much for the reply. So this seems to be related to the mistaken commit mentioned earlier in this thread? Unfortunately this is my first Unity on Arch installation in about a year, so I don't have any old versions in the cache to downgrade to.

By the way, thanks to everyone who is working hard on this project, I'm really hoping it continues to succeed.

Last edited by sb56637 (2014-03-18 04:36:45)

Offline

#2484 2014-03-19 05:47:02

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 134

Re: Progress on Unity under Arch Linux!

Is there a way that I can download the older files into my cache so I can downgrade? I just installed Unity on my laptop tonight, and everything works- for a little bit... My problem is the same as described in previous posts, but I have no older packages. If there's a way to download or make them with a PKGBUILD, please let me know. If not, I'll just have to wait until Chen gets the old packages back into the repositories.

Offline

#2485 2014-03-19 10:07:39

freieschaf
Member
Registered: 2010-11-30
Posts: 18

Re: Progress on Unity under Arch Linux!

Hi,

I recently installed Unity from repository but I'm having some trouble getting it to work. At first it crashed after login with a black background; I looked for error logs on journalctl and got something along the lines of 'gnome-shell component cannot be found', so I installed gnome-shell.

After that, it does launch after login, but the desktop I get is in fact Gnome Shell, not Unity. I'm a little confused at this point not knowing whether I missed something or something is wrong.

I'm running SLiM as a multisession manager. If someone has any notion of what is happening, please let me know which log/output you'd like to see; there are a bunch of warnings in journalctl just after logging in, but honestly wouldn't know if they are related to this. Thanks!

EDIT: source of installation.
EDIT2: This was solved replacing SLiM with GDM.

Last edited by freieschaf (2014-03-24 13:39:54)

Offline

#2486 2014-03-19 20:16:25

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

horsemanoffaith wrote:

Is there a way that I can download the older files into my cache so I can downgrade? I just installed Unity on my laptop tonight, and everything works- for a little bit... My problem is the same as described in previous posts, but I have no older packages. If there's a way to download or make them with a PKGBUILD, please let me know. If not, I'll just have to wait until Chen gets the old packages back into the repositories.

Hi, I've shared other packages which may require to be reverted.
Maybe not all of them are necessary, you can try them out.

https://www.dropbox.com/sh/xtq6f7ff4sa1sog/JKsh8QyDQE

Offline

#2487 2014-03-20 01:36:26

sb56637
Member
Registered: 2009-02-18
Posts: 62

Re: Progress on Unity under Arch Linux!

qiuwei wrote:
horsemanoffaith wrote:

Is there a way that I can download the older files into my cache so I can downgrade? I just installed Unity on my laptop tonight, and everything works- for a little bit... My problem is the same as described in previous posts, but I have no older packages. If there's a way to download or make them with a PKGBUILD, please let me know. If not, I'll just have to wait until Chen gets the old packages back into the repositories.

Hi, I've shared other packages which may require to be reverted.
Maybe not all of them are necessary, you can try them out.

https://www.dropbox.com/sh/xtq6f7ff4sa1sog/JKsh8QyDQE

Thanks VERY MUCH for taking the time to upload these. I'll try them ASAP, doing a fresh install right now.

By any chance does anybody else have these same files for i686 too?

Offline

#2488 2014-03-20 02:10:58

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

sb56637 wrote:
qiuwei wrote:
horsemanoffaith wrote:

Is there a way that I can download the older files into my cache so I can downgrade? I just installed Unity on my laptop tonight, and everything works- for a little bit... My problem is the same as described in previous posts, but I have no older packages. If there's a way to download or make them with a PKGBUILD, please let me know. If not, I'll just have to wait until Chen gets the old packages back into the repositories.

Hi, I've shared other packages which may require to be reverted.
Maybe not all of them are necessary, you can try them out.

https://www.dropbox.com/sh/xtq6f7ff4sa1sog/JKsh8QyDQE

Thanks VERY MUCH for taking the time to upload these. I'll try them ASAP, doing a fresh install right now.

By any chance does anybody else have these same files for i686 too?

Sorry I haven't had a chance to fix these yet. The i686 (and x86_64) packages can still be found on my build server: http://jenkins.cxl.epac.to/ Just click on the package name, choose the older build from the left sidebar, and click the download. I'll link the packages here just in case smile

ido (i686): http://jenkins.cxl.epac.to/job/UFA-2.0- … pkg.tar.xz
ido (x86_64): http://jenkins.cxl.epac.to/job/UFA-2.0- … pkg.tar.xz

metacity (i686): http://jenkins.cxl.epac.to/job/UFA-2.0- … pkg.tar.xz
metacity (x86_64): http://jenkins.cxl.epac.to/job/UFA-2.0- … pkg.tar.xz

nautilus (i686):
http://jenkins.cxl.epac.to/job/UFA-2.0- … pkg.tar.xz

http://jenkins.cxl.epac.to/job/UFA-2.0- … pkg.tar.xz
nautilus (x86_64):
http://jenkins.cxl.epac.to/job/UFA-2.0- … pkg.tar.xz

http://jenkins.cxl.epac.to/job/UFA-2.0- … pkg.tar.xz

zeitgeist (i686): http://jenkins.cxl.epac.to/job/UFA-2.0- … pkg.tar.xz
zeitgeist (x86_64): http://jenkins.cxl.epac.to/job/UFA-2.0- … pkg.tar.xz

EDIT: Everything reverted in repo

Last edited by chenxiaolong (2014-03-23 00:57:22)


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#2489 2014-03-20 05:21:59

sb56637
Member
Registered: 2009-02-18
Posts: 62

Re: Progress on Unity under Arch Linux!

Thanks very much chenxiaolong! Those packages fixed Unity, and it's stable as a rock now. Very impressive work! It's amazing to see Unity running like this on an Arch system. big_smile

My only complaint has to do with Zeitgeist. I'm not sure if it's specific to this Arch port of Unity or not, since I haven't used Ubuntu for a while. But when I used to use Ubuntu, the search seemed to produce more intelligent results. This time with Unity+Arch, frequently used applications are not given priority in the search results unless I log out and log back in again. Likewise, a search for random text "dsfdsafsdfsdf" brings up a bunch of bogus file results.

Additionally, is there any way to make it mix applications and files in the search results depending on what I use more frequently? For example, if I start typing "calc", it will show me the calculator first in the applications. But what if I have a file named "calc-monthly-2014.ods" that I use more frequently? I would prefer that to appear first.

Finally, is there any way to navigate and select search results with TAB to move forward? It feels a lot more natural.

Thanks again for your hard work on this, we're thrilled to have this available.

Last edited by sb56637 (2014-03-20 05:23:15)

Offline

#2490 2014-03-23 01:11:27

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

In case anyone is wondering why packages are being removed from Jenkins, I've hit the maximum number of forms that Firefox and Chromium are willing to send to a website.

Case in point, my beautiful Jenkins config: http://dl.dropboxusercontent.com/u/486665/jenkins.pdf smile

I'll need to rework how it tracks and builds packages.


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#2491 2014-03-23 20:01:17

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 134

Re: Progress on Unity under Arch Linux!

I just did a re-install of Unity on my laptop a few days ago. It is working, but there are a couple of issues that I am having.

#1- gnome-tweak-tool isn't working. Here's the error message via CLI:

** (gnome-tweak-tool:1851): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-B3ATv7GT1c: Connection refused
WARNING : Shell not installed or running
INFO    : GSetting missing org.gnome.mutter
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/gtweak/app.py", line 39, in do_activate
    self.win = Window(self, model)
  File "/usr/lib/python2.7/site-packages/gtweak/tweakview.py", line 53, in __init__
    self._model.load_tweaks(self)
  File "/usr/lib/python2.7/site-packages/gtweak/tweakmodel.py", line 125, in load_tweaks
    mods = __import__("gtweak.tweaks", globals(), locals(), tweak_files, 0)
  File "/usr/lib/python2.7/site-packages/gtweak/tweaks/tweak_group_shell.py", line 65, in <module>
    sw = StaticWorkspaceTweak(size_group=sg, loaded=_shell_loaded)
  File "/usr/lib/python2.7/site-packages/gtweak/tweaks/tweak_group_shell.py", line 49, in __init__
    default = self.STATUS.keys()[self.STATUS.values().index(self.settings[self.key_name])]
ValueError: None is not in list

#2- When I log in to Unity, all of my settings set to my preferences. After some time, my panel reverts to GNOME default settings, which are UGLY. Also, when I open Nautilus, I find that the icons are also the GNOME default icons. What causes this and how do I fix it?

Offline

#2492 2014-03-25 05:26:34

ThElitEyeS
Member
Registered: 2014-03-25
Posts: 122

Re: Progress on Unity under Arch Linux!

Hey guys i am just wondering how i can make the terminal background transparent and how i can change the cursor theme ?
In Ubuntu i was using that command: sudo update-alternatives --config x-cursor-theme

Last edited by ThElitEyeS (2014-03-25 05:33:54)

Offline

#2493 2014-04-02 20:18:34

oi_wtf
Member
From: /home/wtf
Registered: 2012-03-11
Posts: 190

Re: Progress on Unity under Arch Linux!

@Cursor read: https://wiki.archlinux.org/index.php/Cu … cification

@Terminal:
If you're using gnome-terminal, transparent background is not possible anymore, gnome removed that feature.


Laptop:   Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-3630QM @ 2.40GHz, 8 GiB RAM, NViDiA GeForce GT 650M 2 GiB
Desktop: Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-4771  @ 3.50GHz, 8 GiB RAM, NViDiA GeForce GTX 660 Ti 2GiB

Offline

#2494 2014-04-04 15:24:41

py_crash
Member
From: Resistencia
Registered: 2013-05-28
Posts: 10

Re: Progress on Unity under Arch Linux!

I'm having problems here. Added the repositories shown in https://wiki.archlinux.org/index.php/Un … mmended.29. But when I try to run

 $ sudo pacman -S $(pacman -Slq Unity-for-Arch)

I get the following error:

verificando conflictos...
:: gsettings-desktop-schemas-ubuntu y gsettings-desktop-schemas están en conflicto. ¿Quitar gsettings-desktop-schemas? [s/N] s
:: gnome-settings-daemon-ubuntu y gnome-settings-daemon están en conflicto. ¿Quitar gnome-settings-daemon? [s/N] s
:: network-manager-applet-ubuntu y network-manager-applet están en conflicto. ¿Quitar network-manager-applet? [s/N] s
:: gnome-control-center-ubuntu y gnome-control-center están en conflicto. ¿Quitar gnome-control-center? [s/N] s
:: qt4-ubuntu y qt4 están en conflicto. ¿Quitar qt4? [s/N] s
:: libindicator3 y libindicator-gtk3 están en conflicto. ¿Quitar libindicator-gtk3? [s/N] s
error: error al preparar la transacción (no se pudieron satisfacer las dependencias)
:: indicator-datetime: necesita libindicator-gtk3
:: indicator-power: necesita libindicator-gtk3
:: indicator-session: necesita libindicator-gtk3
:: indicator-sound: necesita libindicator-gtk3
:: libdbusmenu-gtk2: necesita libdbusmenu-glib=12.10.3daily14.02.17.1
:: libindicate: necesita libdbusmenu

Offline

#2495 2014-04-04 19:05:22

freieschaf
Member
Registered: 2010-11-30
Posts: 18

Re: Progress on Unity under Arch Linux!

py_crash wrote:

I'm having problems here. Added the repositories shown in https://wiki.archlinux.org/index.php/Un … mmended.29. But when I try to run

 $ sudo pacman -S $(pacman -Slq Unity-for-Arch)

I get the following error:

verificando conflictos...
:: gsettings-desktop-schemas-ubuntu y gsettings-desktop-schemas están en conflicto. ¿Quitar gsettings-desktop-schemas? [s/N] s
:: gnome-settings-daemon-ubuntu y gnome-settings-daemon están en conflicto. ¿Quitar gnome-settings-daemon? [s/N] s
:: network-manager-applet-ubuntu y network-manager-applet están en conflicto. ¿Quitar network-manager-applet? [s/N] s
:: gnome-control-center-ubuntu y gnome-control-center están en conflicto. ¿Quitar gnome-control-center? [s/N] s
:: qt4-ubuntu y qt4 están en conflicto. ¿Quitar qt4? [s/N] s
:: libindicator3 y libindicator-gtk3 están en conflicto. ¿Quitar libindicator-gtk3? [s/N] s
error: error al preparar la transacción (no se pudieron satisfacer las dependencias)
:: indicator-datetime: necesita libindicator-gtk3
:: indicator-power: necesita libindicator-gtk3
:: indicator-session: necesita libindicator-gtk3
:: indicator-sound: necesita libindicator-gtk3
:: libdbusmenu-gtk2: necesita libdbusmenu-glib=12.10.3daily14.02.17.1
:: libindicate: necesita libdbusmenu

Try the solution proposed by horsemanoffaith (and the preceding discussion) in this same thread: https://bbs.archlinux.org/viewtopic.php … 1#p1346731 If your pacman.conf lists the Community repo before the Unity-for-Arch/Unity-for-Arch-Extra ones, Community's libdbusmenu conflicts with the version that resides in Unity-for-Arch. There is no need to comment/uncomment Community, it is enough placing Unity-for-Arch, Unity-for-Arch-Extra before Community in pacman.conf.

Offline

#2496 2014-04-04 19:31:51

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

I'm almost finished with GNOME 3.12 compatibility (well, maybe not all features, but at least no crashes) smile This may very well be the first time we have working Unity at the same time a new version of GNOME lands in [extra].


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#2497 2014-04-05 01:25:15

py_crash
Member
From: Resistencia
Registered: 2013-05-28
Posts: 10

Re: Progress on Unity under Arch Linux!

freieschaf wrote:

Try the solution proposed by horsemanoffaith (and the preceding discussion) in this same thread: https://bbs.archlinux.org/viewtopic.php … 1#p1346731 If your pacman.conf lists the Community repo before the Unity-for-Arch/Unity-for-Arch-Extra ones, Community's libdbusmenu conflicts with the version that resides in Unity-for-Arch. There is no need to comment/uncomment Community, it is enough placing Unity-for-Arch, Unity-for-Arch-Extra before Community in pacman.conf.

Thanks! And sorry i didn't find it on the search

Offline

#2498 2014-04-05 03:38:01

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 134

Re: Progress on Unity under Arch Linux!

Try the solution proposed by horsemanoffaith (and the preceding discussion) in this same thread: https://bbs.archlinux.org/viewtopic.php … 1#p1346731 If your pacman.conf lists the Community repo before the Unity-for-Arch/Unity-for-Arch-Extra ones, Community's libdbusmenu conflicts with the version that resides in Unity-for-Arch. There is no need to comment/uncomment Community, it is enough placing Unity-for-Arch, Unity-for-Arch-Extra before Community in pacman.conf.

I posted that before I knew about moving the Unity repositories above the community repos. The information is still good, but it's a much harder way to fix the problem! After I found out about moving the repositories in pacman.conf, I did a fresh install, and everything worked like a charm!!

By the way, anyone know how to fix gnome-tweak-tool??? I posted the errors in a previous post here on the thread, but I've heard no information. I've tried using gnome-tweak-tool-git, and that doesn't work either. It appears due to the errors it's something to do with Python 2. Any help would be appreciated!!!

Offline

#2499 2014-04-05 05:08:01

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 134

Re: Progress on Unity under Arch Linux!

By the way, anyone know how to fix gnome-tweak-tool??? I posted the errors in a previous post here on the thread, but I've heard no information. I've tried using gnome-tweak-tool-git, and that doesn't work either. It appears due to the errors it's something to do with Python 2. Any help would be appreciated!!!

Fixed it. Installed the mutter package, and it's working.

Offline

#2500 2014-04-05 17:01:19

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:

I'm almost finished with GNOME 3.12 compatibility (well, maybe not all features, but at least no crashes) smile This may very well be the first time we have working Unity at the same time a new version of GNOME lands in [extra].

Cool! Thanks for your hard work! And will we have the new integrated menu?

Offline

Board footer

Powered by FluxBB