You are not logged in.

#1276 2012-10-31 23:25:11

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

pekmop1024 wrote:

chenxiaolong
so, I can start to rebuild repo? smile

Sure smile If there are any dependency problems, please let me know.


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#1277 2012-10-31 23:30:41

oi_wtf
Member
From: /home/wtf
Registered: 2012-03-11
Posts: 190

Re: Progress on Unity under Arch Linux!

I had some depency issues on a fresh arch install,
I installed unity directly and when I wanted to log in gnome-settings-daemon failed to start.
It couldn't find libgnome-desktop-3.so.2 (or something like that)
that lib is part of the gnome-desktop package, so settings daemon probably should depend on it.

Last edited by oi_wtf (2012-10-31 23:39:22)


Laptop:   Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-3630QM @ 2.40GHz, 8 GiB RAM, NViDiA GeForce GT 650M 2 GiB
Desktop: Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-4771  @ 3.50GHz, 8 GiB RAM, NViDiA GeForce GTX 660 Ti 2GiB

Offline

#1278 2012-11-01 00:21:13

pekmop1024
Member
From: Kiev/Feodosia
Registered: 2010-04-21
Posts: 125
Website

Re: Progress on Unity under Arch Linux!

oi_wtf, has you installed unity from my repo? It's not rebuilt for G 3.6, wait some time please smile


ArchLinux x86_64 (desktop): i7 970@4.3GHz - 24GB - GTX680 DirectCU II TOP - Crucial M4 128GB - 3x2TB Seagate - Creative X-Fi Platinum - Zalman ZM1000HP
ArchLinux i686 PAE (passive cooled): i3 540 - 4GB - GT610 Silent - Crucial M4 64GB - Creative X-Fi XtremeMusic
ArchLinux i686 (HTPC): Core 2 Duo E6400 - 2GB - GT520 Silent - 80GB Seagate

Offline

#1279 2012-11-01 00:24:06

oi_wtf
Member
From: /home/wtf
Registered: 2012-03-11
Posts: 190

Re: Progress on Unity under Arch Linux!

No, it was some days ago, with gnome3.4...


Laptop:   Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-3630QM @ 2.40GHz, 8 GiB RAM, NViDiA GeForce GT 650M 2 GiB
Desktop: Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-4771  @ 3.50GHz, 8 GiB RAM, NViDiA GeForce GTX 660 Ti 2GiB

Offline

#1280 2012-11-01 00:25:35

pekmop1024
Member
From: Kiev/Feodosia
Registered: 2010-04-21
Posts: 125
Website

Re: Progress on Unity under Arch Linux!

And since unity installation you have updated Arch? Seems that some parts of 3.6 arrived earlier than other.


ArchLinux x86_64 (desktop): i7 970@4.3GHz - 24GB - GTX680 DirectCU II TOP - Crucial M4 128GB - 3x2TB Seagate - Creative X-Fi Platinum - Zalman ZM1000HP
ArchLinux i686 PAE (passive cooled): i3 540 - 4GB - GT610 Silent - Crucial M4 64GB - Creative X-Fi XtremeMusic
ArchLinux i686 (HTPC): Core 2 Duo E6400 - 2GB - GT520 Silent - 80GB Seagate

Offline

#1281 2012-11-01 00:27:03

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

oi_wtf wrote:

I had some depency issues on a fresh arch install,
I installed unity directly and when I wanted to log in gnome-settings-daemon failed to start.
It couldn't find libgnome-desktop-3.so.2 (or something like that)
that lib is part of the gnome-desktop package, so settings daemon probably should depend on it.

Added to deps smile


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#1282 2012-11-01 08:10:13

RockrKnight
Member
Registered: 2011-06-03
Posts: 10

Re: Progress on Unity under Arch Linux!

When building gnome-bluetooth-ubuntu, it gives this error:

make[2]: Leaving directory `/home/rockrknight/Unity-for-Arch/gnome-bluetooth-ubuntu/src/gnome-bluetooth-3.6.0/po'
Making all in help
make[2]: Entering directory `/home/rockrknight/Unity-for-Arch/gnome-bluetooth-ubuntu/src/gnome-bluetooth-3.6.0/help'
Makefile:463: *** missing separator.  Stop.
make[2]: Leaving directory `/home/rockrknight/Unity-for-Arch/gnome-bluetooth-ubuntu/src/gnome-bluetooth-3.6.0/help'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/rockrknight/Unity-for-Arch/gnome-bluetooth-ubuntu/src/gnome-bluetooth-3.6.0'
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

Here is the entire output: http://pastebin.com/jQMZqMA7

Edit: I compiled it.

In the src/gnome-bluetooth-3.6.0/help/Makefile the line 463 just have this:

@YELP_HELP_RULES@

Apparently is missing TAB, that I added after the ./configure step in PKGBUILD.

sed -i 's/@YELP_HELP_RULES@/	@YELP_HELP_RULES@/' "${srcdir}/${pkgname%-*}-${_actual_ver}/help/Makefile"

Last edited by RockrKnight (2012-11-01 18:12:31)

Offline

#1283 2012-11-01 12:25:35

pekmop1024
Member
From: Kiev/Feodosia
Registered: 2010-04-21
Posts: 125
Website

Re: Progress on Unity under Arch Linux!

some unity lens misses zeitgeist-extensions (and PKGBUILD in git for it disappeared).


ArchLinux x86_64 (desktop): i7 970@4.3GHz - 24GB - GTX680 DirectCU II TOP - Crucial M4 128GB - 3x2TB Seagate - Creative X-Fi Platinum - Zalman ZM1000HP
ArchLinux i686 PAE (passive cooled): i3 540 - 4GB - GT610 Silent - Crucial M4 64GB - Creative X-Fi XtremeMusic
ArchLinux i686 (HTPC): Core 2 Duo E6400 - 2GB - GT520 Silent - 80GB Seagate

Offline

#1284 2012-11-01 17:25:21

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

Related wiki page updated, now I feel that I'm contributing something:)

Offline

#1285 2012-11-01 18:31:44

kladd
Member
Registered: 2012-09-18
Posts: 7

Re: Progress on Unity under Arch Linux!

Building from the git repo on gnome 3.6 I'm not able to see applicaitons in the dash or by searching within the dash. Is this a known issue or does anyone have any ideas to fix this?

I tried clearing the zeitgeist cache and the unity caches mentioned on some ubuntu forums.

pekmop1024 wrote:

some unity lens misses zeitgeist-extensions (and PKGBUILD in git for it disappeared).

I also built and installed this package after I saw that post ^

Edit: Nevermind, none of the unity lens packages came up when i ran the update script. Went back and built them, all is well.

Last edited by kladd (2012-11-01 21:59:12)

Offline

#1286 2012-11-01 23:31:15

pekmop1024
Member
From: Kiev/Feodosia
Registered: 2010-04-21
Posts: 125
Website

Re: Progress on Unity under Arch Linux!

kladd
you just have installed zeitgeist-extensions already, but I always building packages at a clean environment for best binary compatibility results.

chenxiaolong
so, what's wrong with your zeitgeist-extensions PKGBUILD, why it's removed from git?


ArchLinux x86_64 (desktop): i7 970@4.3GHz - 24GB - GTX680 DirectCU II TOP - Crucial M4 128GB - 3x2TB Seagate - Creative X-Fi Platinum - Zalman ZM1000HP
ArchLinux i686 PAE (passive cooled): i3 540 - 4GB - GT610 Silent - Crucial M4 64GB - Creative X-Fi XtremeMusic
ArchLinux i686 (HTPC): Core 2 Duo E6400 - 2GB - GT520 Silent - 80GB Seagate

Offline

#1287 2012-11-02 00:33:12

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

pekmop1024 wrote:

kladd
you just have installed zeitgeist-extensions already, but I always building packages at a clean environment for best binary compatibility results.

chenxiaolong
so, what's wrong with your zeitgeist-extensions PKGBUILD, why it's removed from git?

I guess it's because zeitgeist-extensions is not required any more. At least unity-lens-files doesn't need it anymore, it's powered by zeitgeist-core which is provided in libzeitgeist.
Just remove it from depends, I think it will work:)

Offline

#1288 2012-11-02 00:34:35

pekmop1024
Member
From: Kiev/Feodosia
Registered: 2010-04-21
Posts: 125
Website

Re: Progress on Unity under Arch Linux!

I'll try to do this, thanks for tip... smile


ArchLinux x86_64 (desktop): i7 970@4.3GHz - 24GB - GTX680 DirectCU II TOP - Crucial M4 128GB - 3x2TB Seagate - Creative X-Fi Platinum - Zalman ZM1000HP
ArchLinux i686 PAE (passive cooled): i3 540 - 4GB - GT610 Silent - Crucial M4 64GB - Creative X-Fi XtremeMusic
ArchLinux i686 (HTPC): Core 2 Duo E6400 - 2GB - GT520 Silent - 80GB Seagate

Offline

#1289 2012-11-02 00:37:31

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

And chenxiaolong must have rebased the repo a lot. I'm quite sure I saw zeitgeist-extensions 3 days ago, but now I checked the commits which show that zeitgeist-extensions was deleted 9 days ago.

Offline

#1290 2012-11-02 00:38:30

pekmop1024
Member
From: Kiev/Feodosia
Registered: 2010-04-21
Posts: 125
Website

Re: Progress on Unity under Arch Linux!

He just merged gnome 3.6 branch to master


ArchLinux x86_64 (desktop): i7 970@4.3GHz - 24GB - GTX680 DirectCU II TOP - Crucial M4 128GB - 3x2TB Seagate - Creative X-Fi Platinum - Zalman ZM1000HP
ArchLinux i686 PAE (passive cooled): i3 540 - 4GB - GT610 Silent - Crucial M4 64GB - Creative X-Fi XtremeMusic
ArchLinux i686 (HTPC): Core 2 Duo E6400 - 2GB - GT520 Silent - 80GB Seagate

Offline

#1291 2012-11-02 01:28:21

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

qiuwei wrote:

And chenxiaolong must have rebased the repo a lot. I'm quite sure I saw zeitgeist-extensions 3 days ago, but now I checked the commits which show that zeitgeist-extensions was deleted 9 days ago.

Both the git history and you are right smile git did a fast-forward merge, which means that all the history was retained when merging. If I deleted zeitgeist-extensions 9 days ago in GNOME3.6 and I merge it, the master branch will show that I deleted it 9 days ago as well.


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#1292 2012-11-02 01:31:29

quiro91
Member
Registered: 2012-06-13
Posts: 29

Re: Progress on Unity under Arch Linux!

I walked into this error while compiling gnome-settings-daemon-ubuntu

Requested 'ibus-1.0 >= 1.4.99' but version of IBus is 1.4.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables KEYBOARD_CFLAGS
and KEYBOARD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Offline

#1293 2012-11-02 01:58:56

RockrKnight
Member
Registered: 2011-06-03
Posts: 10

Re: Progress on Unity under Arch Linux!

Another build error. Now is the last package, Unity itself... here is the output:

-- Detecting CXX compiler ABI info - done
-- Found Gettext: /usr/bin/msgmerge (found version "0.18.1") 
CMake Error at CMakeLists.txt:106 (if):
  if given arguments:

    "STREQUAL" "TRUE"

  Unknown arguments specified


-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().
    Aborting...

Lines 106 to 111 from CMakeLists.txt have an if statement:

if (${GETTEXT_FOUND} STREQUAL "TRUE")
        set (HAVE_GETTEXT true)
        file (GLOB _translations ${CMAKE_SOURCE_DIR}/po/*.po)
        GETTEXT_CREATE_TRANSLATIONS (${CMAKE_SOURCE_DIR}/po/${PROJECT_NAME}.pot
                ALL ${_translations})
endif (${GETTEXT_FOUND} STREQUAL "TRUE")

Edit: Add xapian-core to unity-lens-applications as a dependency.

Last edited by RockrKnight (2012-11-02 05:19:17)

Offline

#1294 2012-11-02 05:12:27

oi_wtf
Member
From: /home/wtf
Registered: 2012-03-11
Posts: 190

Re: Progress on Unity under Arch Linux!

quiro91 wrote:

I walked into this error while compiling gnome-settings-daemon-ubuntu

Requested 'ibus-1.0 >= 1.4.99' but version of IBus is 1.4.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables KEYBOARD_CFLAGS
and KEYBOARD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Just install ibus 1.4.99 from the official arch repos...


Laptop:   Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-3630QM @ 2.40GHz, 8 GiB RAM, NViDiA GeForce GT 650M 2 GiB
Desktop: Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-4771  @ 3.50GHz, 8 GiB RAM, NViDiA GeForce GTX 660 Ti 2GiB

Offline

#1295 2012-11-02 06:59:23

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

RockrKnight wrote:

Another build error. Now is the last package, Unity itself... here is the output:

-- Detecting CXX compiler ABI info - done
-- Found Gettext: /usr/bin/msgmerge (found version "0.18.1") 
CMake Error at CMakeLists.txt:106 (if):
  if given arguments:

    "STREQUAL" "TRUE"

  Unknown arguments specified


-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().
    Aborting...

Lines 106 to 111 from CMakeLists.txt have an if statement:

if (${GETTEXT_FOUND} STREQUAL "TRUE")
        set (HAVE_GETTEXT true)
        file (GLOB _translations ${CMAKE_SOURCE_DIR}/po/*.po)
        GETTEXT_CREATE_TRANSLATIONS (${CMAKE_SOURCE_DIR}/po/${PROJECT_NAME}.pot
                ALL ${_translations})
endif (${GETTEXT_FOUND} STREQUAL "TRUE")

I'll have to test this tomorrow. Does your system have a /usr/share/cmake*/Modules/FindGettext.cmake file?

It's weird that HAVE_GETTEXT is not being set, since the file above has a very simple if statement that guarantees it's either set to "TRUE" or "FALSE" (if msgmerge and msgfmt exist).

RockrKnight wrote:

Edit: Add xapian-core to unity-lens-applications as a dependency.

Done smile


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#1296 2012-11-02 07:00:59

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

oi_wtf wrote:
quiro91 wrote:

I walked into this error while compiling gnome-settings-daemon-ubuntu

Requested 'ibus-1.0 >= 1.4.99' but version of IBus is 1.4.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables KEYBOARD_CFLAGS
and KEYBOARD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Just install ibus 1.4.99 from the official arch repos...

Do you think I should include a gsettings override (ie. default settings) file that whitelists the ibus systray icon? Ubuntu hasn't ported it's ibus appindicator patches to 1.4.99 yet and I think we should see some sort of icon by default smile


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#1297 2012-11-02 10:02:30

\〠/
Member
Registered: 2011-02-26
Posts: 29

Re: Progress on Unity under Arch Linux!

RockrKnight wrote:

Another build error. Now is the last package, Unity itself... here is the output:

-- Detecting CXX compiler ABI info - done
-- Found Gettext: /usr/bin/msgmerge (found version "0.18.1") 
CMake Error at CMakeLists.txt:106 (if):
  if given arguments:

    "STREQUAL" "TRUE"

  Unknown arguments specified


-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().
    Aborting...

Same issue here, downgrading to older cmake (2.8.9-1) fix it.

Offline

#1298 2012-11-02 14:19:59

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

Hi, does unity-lens-videos still depend on gstreamer0.10? I didn't manage to compile it without gstreamer.

Offline

#1299 2012-11-02 16:52:06

RockrKnight
Member
Registered: 2011-06-03
Posts: 10

Re: Progress on Unity under Arch Linux!

\〠/ wrote:

Same issue here, downgrading to older cmake (2.8.9-1) fix it.

Yeah, that worked. But still... what happened?

chenxiaolong wrote:

I'll have to test this tomorrow. Does your system have a /usr/share/cmake*/Modules/FindGettext.cmake file?

It's weird that HAVE_GETTEXT is not being set, since the file above has a very simple if statement that guarantees it's either set to "TRUE" or "FALSE" (if msgmerge and msgfmt exist).

I had /usr/share/cmake-2.8/Modules/FindGettext.cmake in my system, before and after downgrade.

---
Unity installed
---

Offline

#1300 2012-11-02 17:37:29

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

qiuwei wrote:

Hi, does unity-lens-videos still depend on gstreamer0.10? I didn't manage to compile it without gstreamer.

Could you post the build log? Looking at the source code, it doesn't seem like unity-lens-video depends on gstreamer.


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

Board footer

Powered by FluxBB