You are not logged in.

#2276 2013-08-15 04:33:47

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

divansantana wrote:
divansantana wrote:

Does anyone else have an issue with the unity panel sometimes consuming 100% of a processor and freeze up every now and then?

I notice for example, my time is lagging/outdated/frozen and the panel hangs every now and then.

I then have to issue this command to fix it:
kill -9 `ps -ef |grep unity-panel|awk '{print $2}'|tr '\n' ' '` ; sleep 1 && unity --replace&

It's a real pain...

Could be as a result of me using hud=13.04.0daily13.04.03-103...

Ok I believe the only thing hanging the unity panel and sometimes causing a complete desktop freeze is the pidgin integration into the panel.
If I remove pidgin-libnotify-ubuntu and restart pidgin the intermittent problem goes away.

I'll see if I can provide more info. It could be when there is some sort of network issue pidgin hangs the panel.

It seems that there was a new version of pidgin-libnotify. I've updated the package. Hopefully this will fix your freezing issues smile


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#2277 2013-08-15 04:37:45

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

gianluca.pettinello wrote:

unity-lens-applications doesn't work. Had to revert back.
metacity-ubuntu doesn't compile because of automake 1.14

Ciao
Gianluca

Edit:



to make metacity-ubuntu to compile correctly it is necessary first to install automake-1.12 from AUR.
In case it gives problems it is necessary to remove the links in /usr/bin called aclocal-1.12 and automake-1.12
Then you have to add in PKGBUILD, before make,
export AUTOMAKE=/usr/bin/automake-1.12
export ACLOCAL=/usr/bin/aclocal-1.12

After that unity-lens-applications works.

I also compiled and installed compiz-ubuntu last release

I'm trying to compile qt 4.8.5 without success
I need the help of a lord of IT as Chen...

Ciao
Gianluca
Ciao
Gianluca

Are you installing another version of metacity-ubuntu? The one I have right now doesn't call any of the automake tools.

I tried to port the Ubuntu patches to Qt 4.8.5 too, but I wasn't able to do it sad Too much has changed since 4.8.4.


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#2278 2013-08-15 12:55:38

divansantana
Member
Registered: 2011-01-21
Posts: 117

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:

It seems that there was a new version of pidgin-libnotify. I've updated the package. Hopefully this will fix your freezing issues smile

Wahoo will try and let you know - thanks!

BTW, this is a pretty cool package you might be interested in packaging? smile
https://launchpad.net/indicator-remindor

Offline

#2279 2013-08-16 04:11:57

gianluca.pettinello
Member
Registered: 2013-04-16
Posts: 57

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:
gianluca.pettinello wrote:

unity-lens-applications doesn't work. Had to revert back.
metacity-ubuntu doesn't compile because of automake 1.14

Ciao
Gianluca

Edit:



to make metacity-ubuntu to compile correctly it is necessary first to install automake-1.12 from AUR.
In case it gives problems it is necessary to remove the links in /usr/bin called aclocal-1.12 and automake-1.12
Then you have to add in PKGBUILD, before make,
export AUTOMAKE=/usr/bin/automake-1.12
export ACLOCAL=/usr/bin/aclocal-1.12

After that unity-lens-applications works.

I also compiled and installed compiz-ubuntu last release

I'm trying to compile qt 4.8.5 without success
I need the help of a lord of IT as Chen...

Ciao
Gianluca
Ciao
Gianluca

Are you installing another version of metacity-ubuntu? The one I have right now doesn't call any of the automake tools.

I tried to port the Ubuntu patches to Qt 4.8.5 too, but I wasn't able to do it sad Too much has changed since 4.8.4.

No I use the metacity-ubuntu from your git. I'll try again to compile
At the endt I installed Qt 4.8.5  withouth patches

Offline

#2280 2013-08-18 05:58:43

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 137

Re: Progress on Unity under Arch Linux!

Hey Chen. I've noticed a problem in Unity... the workspace switcher will not switch up and down using the hotkeys. I use the workspace switcher all the time, I hope you can help me fix it!!!

Offline

#2281 2013-08-18 19:28:13

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

UPDATE: It's safe to update now smile

IMPORTANT: Do not update until the following packages are available:

* bamf 0.5.0daily13.08.12.1-100 (Status: Published to repo)
* indicator-appmenu 13.01.0daily13.08.12-101 (Status: Published to repo)
* hud 13.10.1daily13.08.16.1-101 (Status: Published to repo)
* unity 7.1.0.13.10.20130816.3-100 (Status: Published to repo)

The bamf developers broke the ABI, so libbamf3.so.1 was renamed to libbamf3.so.2. Those four packages need to be rebuilt to account for this.

Last edited by chenxiaolong (2013-08-18 21:01:15)


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#2282 2013-08-18 19:59:59

Thaodan
Member
From: Dortmund, Nordrein-Westfalen
Registered: 2012-04-28
Posts: 439

Re: Progress on Unity under Arch Linux!

Has noonne similar issues with the Globabalmenu patch for firefox?


Linux odin 3.13.1-pf #1 SMP PREEMPT Wed Mar 5 21:47:28 CET 2014 x86_64 GNU/Linux

Offline

#2283 2013-08-18 21:25:10

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

divansantana wrote:
chenxiaolong wrote:

It seems that there was a new version of pidgin-libnotify. I've updated the package. Hopefully this will fix your freezing issues smile

Wahoo will try and let you know - thanks!

BTW, this is a pretty cool package you might be interested in packaging? smile
https://launchpad.net/indicator-remindor

sudo pacman -Sy indicator-remindor

big_smile


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#2284 2013-08-19 04:56:20

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 137

Re: Progress on Unity under Arch Linux!

horsemanoffaith wrote:

Hey Chen. I've noticed a problem in Unity... the workspace switcher will not switch up and down using the hotkeys. I use the workspace switcher all the time, I hope you can help me fix it!!!

I feel so stupid!!! I fixed the problem on my own. The default keybindings were not what I had been using in previous distros. I reassigned them and I can switch properly again. Imagine that!

Offline

#2285 2013-08-19 05:07:45

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

horsemanoffaith wrote:
horsemanoffaith wrote:

Hey Chen. I've noticed a problem in Unity... the workspace switcher will not switch up and down using the hotkeys. I use the workspace switcher all the time, I hope you can help me fix it!!!

I feel so stupid!!! I fixed the problem on my own. The default keybindings were not what I had been using in previous distros. I reassigned them and I can switch properly again. Imagine that!

Sorry, I must have missed your previous post sad

Glad you got it working though big_smile By the way, which keybindings did you change? I might be able to change the defaults inside the packages.


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#2286 2013-08-19 19:08:30

giricz81
Member
Registered: 2013-08-19
Posts: 2

Re: Progress on Unity under Arch Linux!

Hi, I am writing this message because I would like to see Unity desktop officially in Archlinux.
First of all I would like to thank for excellent work from people who take care about "porting" unity desktop to other distros. You are doing really good job!
But there some "BUTs.." as always. Nothing I plan to write is intentionally offensive and etc. it is only my point of view, my thinking about current situation.

From my prospective it is about chasing newer and newer packages version from Ubuntu. There are always many problems, regressions, error what ever you like to call it. And that is not acceptable for daily use. If you work with some data. I know archlinux is reading about manuals and do it your way on your own, because Archlinux is advanced distro. It is not for newbie. Even if I step over it I think this situations doesn't support the unity way to Archlinux.

I have already tried to install and run unity but I think there should be different goal. Something like forking of unity dekstop. Because again from my prospective if we want relatively stable desktop we cannot hunt newer packages (ubuntu has its own way) instead of stabilizing packages to get flawlessly running desktop.

What about to froze packages for a while, make them stable and push in dropbox repo, lets say after 2 months release another version polished unity desktop. It is only idea not a plan. Hope you all are getting my point. I do not want to see Debian way release plan. But there should be some releasing schedule, plan.

If someone has other points, lets share it here because it can help to sharp unity and all people here can see what they can expect. Because I am not sure what to expect know.

And sorry for my English I am not a native speaker.

Offline

#2287 2013-08-20 07:53:17

divansantana
Member
Registered: 2011-01-21
Posts: 117

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:
divansantana wrote:
chenxiaolong wrote:

It seems that there was a new version of pidgin-libnotify. I've updated the package. Hopefully this will fix your freezing issues smile

Wahoo will try and let you know - thanks!

BTW, this is a pretty cool package you might be interested in packaging? smile
https://launchpad.net/indicator-remindor

sudo pacman -Sy indicator-remindor

big_smile

Thanks! smile

Offline

#2288 2013-08-20 07:55:29

divansantana
Member
Registered: 2011-01-21
Posts: 117

Re: Progress on Unity under Arch Linux!

Ok update on unity's hud not searching the indicators.
The bug is reported here https://bugs.launchpad.net/hud/+bug/1165420 and developers are aware of it. But not sure that they are too concerned about it though sad
So feel free to vote/follow the bug.
Not yet fixed in saucy builds 13.10.1daily13.08.16.1-101.
Downgrading hud to 13.04.0daily13.04.03-103 stopped working for me. I'll just live with the regression.

Offline

#2289 2013-08-20 07:58:35

divansantana
Member
Registered: 2011-01-21
Posts: 117

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:
divansantana wrote:
divansantana wrote:

Does anyone else have an issue with the unity panel sometimes consuming 100% of a processor and freeze up every now and then?

I notice for example, my time is lagging/outdated/frozen and the panel hangs every now and then.

I then have to issue this command to fix it:
kill -9 `ps -ef |grep unity-panel|awk '{print $2}'|tr '\n' ' '` ; sleep 1 && unity --replace&

It's a real pain...

Could be as a result of me using hud=13.04.0daily13.04.03-103...

Ok I believe the only thing hanging the unity panel and sometimes causing a complete desktop freeze is the pidgin integration into the panel.
If I remove pidgin-libnotify-ubuntu and restart pidgin the intermittent problem goes away.

I'll see if I can provide more info. It could be when there is some sort of network issue pidgin hangs the panel.

It seems that there was a new version of pidgin-libnotify. I've updated the package. Hopefully this will fix your freezing issues smile

Ok unfortunately my desktop and unity panel still freezes everynow and then (at least once a day) when using pidgin and unity together even without pidgin-libnotify-ubuntu installed, and with and various other things I've tried.
Not sure how to debug this further to send a bug report?

But for now I can confirm that pidgin creates issues and when using empathy the unity panel is stable so far.
But I really don't like empathy and it's lacking a lot of features so I'll try to get pidgin working somehow.

Offline

#2290 2013-08-20 12:23:50

gianluca.pettinello
Member
Registered: 2013-04-16
Posts: 57

Re: Progress on Unity under Arch Linux!

Hello everybody. I notice that, when you move a window, with wobbly activated, there is a glitch between the titlebar and the menubar. I have nvidia proprietary drivers and I think it is related to that. Do you experience the same? Any trick to solve it?

Offline

#2291 2013-08-21 04:43:38

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 137

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:

Glad you got it working though big_smile By the way, which keybindings did you change? I might be able to change the defaults inside the packages.

I can't remember what the original bindings were, but I've always used Control Alt and the arrow key of choice to change the desktops. That was the default in Ubuntu and Linux Mint. Left and right were fine. Up and down were the issue.

Thanks for getting back to me, Chen!!! By the way, thanks for all your hard work!!! I love the Unity interface, and so far, even though it's not quite as fast as Ubuntu, it seems to be more stable. All the little issues I've had in Ubuntu don't seem to be present in Arch!

Offline

#2292 2013-08-21 22:24:16

jaynis
Member
Registered: 2013-08-06
Posts: 2

Re: Progress on Unity under Arch Linux!

divansantana wrote:
chenxiaolong wrote:
divansantana wrote:

Ok I believe the only thing hanging the unity panel and sometimes causing a complete desktop freeze is the pidgin integration into the panel.
If I remove pidgin-libnotify-ubuntu and restart pidgin the intermittent problem goes away.

I'll see if I can provide more info. It could be when there is some sort of network issue pidgin hangs the panel.

It seems that there was a new version of pidgin-libnotify. I've updated the package. Hopefully this will fix your freezing issues smile

Ok unfortunately my desktop and unity panel still freezes everynow and then (at least once a day) when using pidgin and unity together even without pidgin-libnotify-ubuntu installed, and with and various other things I've tried.
Not sure how to debug this further to send a bug report?

But for now I can confirm that pidgin creates issues and when using empathy the unity panel is stable so far.
But I really don't like empathy and it's lacking a lot of features so I'll try to get pidgin working somehow.

I have the same problem with the unity panel and I neither use pidgin nor have it installed at all! This misbehaviour must have different reasons. I think in my case it must have something to do with nemo file browser, because every time (not every time, but most of the time) I browse through my folders the panel goes crazy and if I close nemo, the panel calms down after a short while. However, sometimes the panel freeze occurs without nemo even running. As I mentioned before: Different reasons...

Offline

#2293 2013-08-23 17:15:59

giricz81
Member
Registered: 2013-08-19
Posts: 2

Re: Progress on Unity under Arch Linux!

there was an update for date-time indicator, but I get only message "unsupported date format"
35xb.png

Offline

#2294 2013-08-23 21:29:55

zanegrey
Member
Registered: 2013-08-23
Posts: 12

Re: Progress on Unity under Arch Linux!

Hi all,

Would love to run unity on arch...  I got nearly all the way through compiling until I got to the unity package.

Has anyone seen the following build error?

$ makepgk -Lsci
....
....
-- checking for modules 'x11;xext'
--   found x11, version 1.6.1
--   found xext, version 1.3.2
-- checking for modules 'x11;xext'
--   found x11, version 1.6.1
--   found xext, version 1.3.2
-- checking for modules 'glib-2.0;gio-2.0;dee-1.0;sigc++-2.0;nux-core-4.0;unity-protocol-private'
--   found glib-2.0, version 2.37.5
--   found gio-2.0, version 2.37.5
--   found dee-1.0, version 1.2.6
--   found sigc++-2.0, version 2.3.1
--   found nux-core-4.0, version 4.0.2
--   found unity-protocol-private, version 7.0.11
-- checking for module 'unity-protocol-private'
--   found unity-protocol-private, version 7.0.11
-- GSettings schemas will be installed into /usr/share/glib-2.0/schemas/
-- Found Doxygen: /usr/bin/doxygen (found version "1.8.4")
-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().
       Aborting...

I can't quite figure out what its complaining about.  Any help/pointers in the right direction would be much appreciated

Offline

#2295 2013-08-23 22:00:32

oi_wtf
Member
From: /home/wtf
Registered: 2012-03-11
Posts: 190

Re: Progress on Unity under Arch Linux!

I don't see anything in that part of your log, too. Could you paste the full log?

Oh, and please use code-Tags when posting logs, code, or similar...
much easier to spot, read and it gets a scrollbar when posting long things.

Last edited by oi_wtf (2013-08-23 22:01:56)


Laptop:   Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-3630QM @ 2.40GHz, 8 GiB RAM, NViDiA GeForce GT 650M 2 GiB
Desktop: Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-4771  @ 3.50GHz, 8 GiB RAM, NViDiA GeForce GTX 660 Ti 2GiB

Offline

#2296 2013-08-23 22:30:31

zanegrey
Member
Registered: 2013-08-23
Posts: 12

Re: Progress on Unity under Arch Linux!

Here is the full log and with proper code markup smile

removed ‘build/CMakeFiles/CMakeOutput.log’
removed ‘build/CMakeFiles/2.8.11.2/CMakeSystem.cmake’
removed ‘build/CMakeFiles/2.8.11.2/CompilerIdC/CMakeCCompilerId.c’
removed ‘build/CMakeFiles/2.8.11.2/CompilerIdC/a.out’
removed directory: ‘build/CMakeFiles/2.8.11.2/CompilerIdC’
removed ‘build/CMakeFiles/2.8.11.2/CompilerIdCXX/CMakeCXXCompilerId.cpp’
removed ‘build/CMakeFiles/2.8.11.2/CompilerIdCXX/a.out’
removed directory: ‘build/CMakeFiles/2.8.11.2/CompilerIdCXX’
removed ‘build/CMakeFiles/2.8.11.2/CMakeDetermineCompilerABI_C.bin’
removed ‘build/CMakeFiles/2.8.11.2/CMakeCCompiler.cmake’
removed ‘build/CMakeFiles/2.8.11.2/CMakeDetermineCompilerABI_CXX.bin’
removed ‘build/CMakeFiles/2.8.11.2/CMakeCXXCompiler.cmake’
removed directory: ‘build/CMakeFiles/2.8.11.2’
removed directory: ‘build/CMakeFiles/CMakeTmp’
removed ‘build/CMakeFiles/cmake.check_cache’
removed directory: ‘build/CMakeFiles’
removed ‘build/config.h’
removed directory: ‘build/unity-shared/CMakeFiles’
removed directory: ‘build/unity-shared’
removed directory: ‘build/dash/CMakeFiles’
removed directory: ‘build/dash/previews/CMakeFiles’
removed directory: ‘build/dash/previews’
removed directory: ‘build/dash’
removed directory: ‘build/launcher/CMakeFiles’
removed directory: ‘build/launcher’
removed directory: ‘build/hud/CMakeFiles’
removed directory: ‘build/hud’
removed directory: ‘build/panel/CMakeFiles’
removed directory: ‘build/panel’
removed directory: ‘build/plugins/unityshell/CMakeFiles’
removed directory: ‘build/plugins/unityshell’
removed directory: ‘build/plugins/networkarearegion/CMakeFiles’
removed directory: ‘build/plugins/networkarearegion’
removed directory: ‘build/plugins/unitydialog/CMakeFiles’
removed directory: ‘build/plugins/unitydialog’
removed directory: ‘build/plugins/unity-mt-grab-handles/CMakeFiles’
removed directory: ‘build/plugins/unity-mt-grab-handles’
removed directory: ‘build/plugins’
removed directory: ‘build/generated’
removed ‘build/cmake_uninstall.cmake’
removed directory: ‘build/shortcuts/CMakeFiles’
removed directory: ‘build/shortcuts’
removed directory: ‘build/shutdown/CMakeFiles’
removed directory: ‘build/shutdown’
removed directory: ‘build/unity-standalone/CMakeFiles’
removed directory: ‘build/unity-standalone’
removed directory: ‘build/doc/CMakeFiles’
removed directory: ‘build/doc’
removed directory: ‘build/services/CMakeFiles’
removed ‘build/services/unity-panel-service.conf’
removed directory: ‘build/services’
removed directory: ‘build/tests/CMakeFiles’
removed ‘build/tests/data/applications/ubuntuone-installer.desktop’
removed ‘build/tests/data/applications/ubuntu-software-center.desktop’
removed ‘build/tests/data/applications/update-manager.desktop’
removed ‘build/tests/data/applications/bzr-handle-patch.desktop’
removed ‘build/tests/data/applications/no-icon.desktop’
removed ‘build/tests/data/applications/kde4/afile.desktop’
removed directory: ‘build/tests/data/applications/kde4’
removed directory: ‘build/tests/data/applications’
removed ‘build/tests/data/unity/scopes/testscope1.scope’
removed ‘build/tests/data/unity/scopes/testscope2.scope’
removed ‘build/tests/data/unity/scopes/testscope3.scope’
removed ‘build/tests/data/unity/scopes/testscope4.scope’
removed directory: ‘build/tests/data/unity/scopes’
removed ‘build/tests/data/unity/sounds/brownnoise.mp3’
removed ‘build/tests/data/unity/sounds/pinknoise.mp3’
removed ‘build/tests/data/unity/sounds/whitenoise.mp3’
removed directory: ‘build/tests/data/unity/sounds’
removed directory: ‘build/tests/data/unity’
removed directory: ‘build/tests/data’
removed directory: ‘build/tests/test-input-remover/CMakeFiles’
removed directory: ‘build/tests/test-input-remover’
removed directory: ‘build/tests/test-minimize-window-handler/CMakeFiles’
removed directory: ‘build/tests/test-minimize-window-handler’
removed directory: ‘build/tests/test-get-transients/CMakeFiles’
removed directory: ‘build/tests/test-get-transients’
removed directory: ‘build/tests/test-gestures/CMakeFiles’
removed directory: ‘build/tests/test-gestures’
removed directory: ‘build/tests’
removed directory: ‘build/tools/CMakeFiles’
removed directory: ‘build/tools’
removed ‘build/bin/unity’
removed directory: ‘build/bin’
removed directory: ‘build/UnityCore/CMakeFiles’
removed ‘build/UnityCore/unity-core-6.0.pc’
removed directory: ‘build/UnityCore’
removed directory: ‘build/guides/CMakeFiles’
removed directory: ‘build/guides’
removed directory: ‘build/gnome/CMakeFiles’
removed directory: ‘build/gnome’
removed ‘build/settings/com.canonical.Unity.gschema.xml’
removed ‘build/settings/external.gschema.xml’
removed ‘build/settings/gschemas.compiled’
removed directory: ‘build/settings’
removed ‘build/Doxyfile’
removed ‘build/CMakeCache.txt’
removed directory: ‘build/’
-- The C compiler identification is GNU 4.8.1
-- The CXX compiler identification is GNU 4.8.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Not using precompiled headers.
Unity is configured with support for X.org
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.28") 
-- Found Gettext: /usr/bin/msgmerge (found version "0.18.3") 
-- checking for modules 'unity-protocol-private>=7.0.8;atk;atk-bridge-2.0;dbusmenu-glib-0.4;dee-1.0;gio-2.0>=2.30.0;gio-unix-2.0;gmodule-2.0;gthread-2.0;gtk+-3.0>=3.1;indicator3-0.4>=0.4.90;json-glib-1.0;libbamf3>=0.5.0;libnotify;libstartup-notification-1.0;nux-4.0>=4.0.1;sigc++-2.0;unity-misc>=0.4.0;xpathselect>=1.2;zeitgeist-1.0>=0.3.18;compiz>=0.9.9;libgeis;x11;xfixes;xi>=1.6.99.1;xrender>=0.9'
--   found unity-protocol-private, version 7.0.11
--   found atk, version 2.8.0
--   found atk-bridge-2.0, version 2.8.1
--   found dbusmenu-glib-0.4, version 12.10.2
--   found dee-1.0, version 1.2.6
--   found gio-2.0, version 2.37.5
--   found gio-unix-2.0, version 2.37.5
--   found gmodule-2.0, version 2.37.5
--   found gthread-2.0, version 2.37.5
--   found gtk+-3.0, version 3.8.2
--   found indicator3-0.4, version 12.10.2
--   found json-glib-1.0, version 0.16.0
--   found libbamf3, version 0.5.0
--   found libnotify, version 0.7.5
--   found libstartup-notification-1.0, version 0.12
--   found nux-4.0, version 4.0.2
--   found sigc++-2.0, version 2.3.1
--   found unity-misc, version 4.0.4
--   found xpathselect, version 1.3
--   found zeitgeist-1.0, version 0.3.18
--   found compiz, version 0.9.9.0
--   found libgeis, version 2.2.16
--   found x11, version 1.6.1
--   found xfixes, version 5.0.1
--   found xi, version 1.7.2
--   found xrender, version 0.9.8
-- checking for module 'unity-protocol-private>=7.0.8'
--   found unity-protocol-private, version 7.0.11
-- checking for module 'compiz'
--   found compiz, version 0.9.9.0
-- Performing Test HAVE_SCANDIR_POSIX
-- Performing Test HAVE_SCANDIR_POSIX - Success
-- checking for module 'compiz-composite'
--   found compiz-composite, version 0.9.9.0
-- checking for module 'compiz-opengl'
--   found compiz-opengl, version 0.9.9.0
-- checking for module 'compiz-compiztoolbox'
--   found compiz-compiztoolbox, version 0.9.9.0
-- checking for module 'compiz-scale'
--   found compiz-scale, version 0.9.9.0
-- checking for module 'unity-protocol-private>=7.0.8'
--   found unity-protocol-private, version 7.0.11
-- checking for module 'atk'
--   found atk, version 2.8.0
-- checking for module 'atk-bridge-2.0'
--   found atk-bridge-2.0, version 2.8.1
-- checking for module 'dbusmenu-glib-0.4'
--   found dbusmenu-glib-0.4, version 12.10.2
-- checking for module 'dee-1.0'
--   found dee-1.0, version 1.2.6
-- checking for module 'gio-2.0>=2.30.0'
--   found gio-2.0, version 2.37.5
-- checking for module 'gio-unix-2.0'
--   found gio-unix-2.0, version 2.37.5
-- checking for module 'gmodule-2.0'
--   found gmodule-2.0, version 2.37.5
-- checking for module 'gthread-2.0'
--   found gthread-2.0, version 2.37.5
-- checking for module 'gtk+-3.0>=3.1'
--   found gtk+-3.0, version 3.8.2
-- checking for module 'indicator3-0.4>=0.4.90'
--   found indicator3-0.4, version 12.10.2
-- checking for module 'json-glib-1.0'
--   found json-glib-1.0, version 0.16.0
-- checking for module 'libbamf3>=0.5.0'
--   found libbamf3, version 0.5.0
-- checking for module 'libnotify'
--   found libnotify, version 0.7.5
-- checking for module 'libstartup-notification-1.0'
--   found libstartup-notification-1.0, version 0.12
-- checking for module 'nux-4.0>=4.0.1'
--   found nux-4.0, version 4.0.2
-- checking for module 'sigc++-2.0'
--   found sigc++-2.0, version 2.3.1
-- checking for module 'unity-misc>=0.4.0'
--   found unity-misc, version 4.0.4
-- checking for module 'xpathselect>=1.2'
--   found xpathselect, version 1.3
-- checking for module 'zeitgeist-1.0>=0.3.18'
--   found zeitgeist-1.0, version 0.3.18
-- checking for module 'compiz>=0.9.9'
--   found compiz, version 0.9.9.0
-- checking for module 'libgeis'
--   found libgeis, version 2.2.16
-- checking for module 'x11'
--   found x11, version 1.6.1
-- checking for module 'xfixes'
--   found xfixes, version 5.0.1
-- checking for module 'xi>=1.6.99.1'
--   found xi, version 1.7.2
-- checking for module 'xrender>=0.9'
--   found xrender, version 0.9.8
-- checking for module 'compiz'
--   found compiz, version 0.9.9.0
-- checking for module 'cairo'
--   found cairo, version 1.12.14
-- checking for module 'cairo-xlib-xrender'
--   found cairo-xlib-xrender, version 1.12.14
-- checking for module 'gtk+-3.0'
--   found gtk+-3.0, version 3.8.2
-- checking for module 'nux-4.0>=4.0.0'
--   found nux-4.0, version 4.0.2
CMake Error at CMakeLists.txt:311 (add_subdirectory):
  add_subdirectory given source "/usr/src/gmock" which is not an existing
  directory.


-- checking for modules 'atk;atk-bridge-2.0;gio-2.0>=2.30.0;gobject-2.0;gthread-2.0;gtk+-3.0>=3.3;indicator3-0.4>=12.10.2;x11;libido3-0.1>=13.0.0'
--   found atk, version 2.8.0
--   found atk-bridge-2.0, version 2.8.1
--   found gio-2.0, version 2.37.5
--   found gobject-2.0, version 2.37.5
--   found gthread-2.0, version 2.37.5
--   found gtk+-3.0, version 3.8.2
--   found indicator3-0.4, version 12.10.2
--   found x11, version 1.6.1
--   found libido3-0.1, version 13.10.1
-- checking for modules 'unity-protocol-private>=7.0.8;atk;atk-bridge-2.0;dbusmenu-glib-0.4;dee-1.0;gio-2.0>=2.30.0;gio-unix-2.0;gmodule-2.0;gthread-2.0;gtk+-3.0>=3.1;indicator3-0.4>=0.4.90;json-glib-1.0;libbamf3>=0.5.0;libnotify;libstartup-notification-1.0;nux-4.0>=4.0.1;sigc++-2.0;unity-misc>=0.4.0;xpathselect>=1.2;zeitgeist-1.0>=0.3.18;compiz>=0.9.9;libgeis;x11;xfixes;xi>=1.6.99.1;xrender>=0.9;unity>=4.99.0'
--   found unity-protocol-private, version 7.0.11
--   found atk, version 2.8.0
--   found atk-bridge-2.0, version 2.8.1
--   found dbusmenu-glib-0.4, version 12.10.2
--   found dee-1.0, version 1.2.6
--   found gio-2.0, version 2.37.5
--   found gio-unix-2.0, version 2.37.5
--   found gmodule-2.0, version 2.37.5
--   found gthread-2.0, version 2.37.5
--   found gtk+-3.0, version 3.8.2
--   found indicator3-0.4, version 12.10.2
--   found json-glib-1.0, version 0.16.0
--   found libbamf3, version 0.5.0
--   found libnotify, version 0.7.5
--   found libstartup-notification-1.0, version 0.12
--   found nux-4.0, version 4.0.2
--   found sigc++-2.0, version 2.3.1
--   found unity-misc, version 4.0.4
--   found xpathselect, version 1.3
--   found zeitgeist-1.0, version 0.3.18
--   found compiz, version 0.9.9.0
--   found libgeis, version 2.2.16
--   found x11, version 1.6.1
--   found xfixes, version 5.0.1
--   found xi, version 1.7.2
--   found xrender, version 0.9.8
--   found unity, version 7.0.11
-- checking for modules 'x11;xext'
--   found x11, version 1.6.1
--   found xext, version 1.3.2
-- checking for modules 'x11;xext'
--   found x11, version 1.6.1
--   found xext, version 1.3.2
-- checking for modules 'x11;xext'
--   found x11, version 1.6.1
--   found xext, version 1.3.2
-- checking for modules 'glib-2.0;gio-2.0;dee-1.0;sigc++-2.0;nux-core-4.0;unity-protocol-private'
--   found glib-2.0, version 2.37.5
--   found gio-2.0, version 2.37.5
--   found dee-1.0, version 1.2.6
--   found sigc++-2.0, version 2.3.1
--   found nux-core-4.0, version 4.0.2
--   found unity-protocol-private, version 7.0.11
-- checking for module 'unity-protocol-private'
--   found unity-protocol-private, version 7.0.11
-- GSettings schemas will be installed into /usr/share/glib-2.0/schemas/
-- Found Doxygen: /usr/bin/doxygen (found version "1.8.4") 
-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().
    Aborting...

EDIT:  Here is the prepare log as well (the above is just the build log), although it seems fine.

patching file panel/PanelMenuView.cpp
patching file tests/autopilot/unity/tests/launcher/test_keynav.py
patching file com.canonical.Unity.gschema.xml
Hunk #1 succeeded at 59 (offset 5 lines).
patching file panel/PanelTray.cpp
patching file panel/PanelTray.h
patching file tests/CMakeLists.txt
Hunk #1 succeeded at 263 with fuzz 2 (offset 5 lines).
patching file tests/test_panel_tray.cpp
patching file CMakeLists.txt
Hunk #1 succeeded at 194 (offset 1 line).
patching file services/CMakeLists.txt
Hunk #1 succeeded at 34 (offset 1 line).
patching file com.canonical.Unity.gschema.xml
Hunk #1 succeeded at 49 (offset 5 lines).
patching file debian/libunity-core-6.0-dev.install
patching file debian/unity-services.install
patching file debian/unity-autopilot.install
patching file debian/watch
patching file debian/unity-common.maintscript
patching file debian/unity.lintian-overrides
patching file debian/copyright
patching file debian/source_unity.py
patching file debian/libunity-core-6.0-7.lintian-overrides
patching file debian/control
patching file debian/scopes-recommends-generator
patching file debian/compat
patching file debian/rules
patching file debian/unity7.conf
patching file debian/libunity-core-6.0-7.install
patching file debian/changelog
patching file debian/unity.install
patching file debian/unity.migrations
patching file debian/unity-crashdb.conf
grep: debian/patches/series: No such file or directory
==> Merging translations from 20130418 
patching file panel/PanelMenuView.cpp
patching file tests/autopilot/unity/tests/launcher/test_keynav.py
patching file com.canonical.Unity.gschema.xml
Hunk #1 succeeded at 59 (offset 5 lines).
patching file panel/PanelTray.cpp
patching file panel/PanelTray.h
patching file tests/CMakeLists.txt
Hunk #1 succeeded at 263 with fuzz 2 (offset 5 lines).
patching file tests/test_panel_tray.cpp
patching file CMakeLists.txt
Hunk #1 succeeded at 194 (offset 1 line).
patching file services/CMakeLists.txt
Hunk #1 succeeded at 34 (offset 1 line).
patching file com.canonical.Unity.gschema.xml
Hunk #1 succeeded at 49 (offset 5 lines).
patching file debian/libunity-core-6.0-dev.install
patching file debian/unity-services.install
patching file debian/unity-autopilot.install
patching file debian/watch
patching file debian/unity-common.maintscript
patching file debian/unity.lintian-overrides
patching file debian/copyright
patching file debian/source_unity.py
patching file debian/libunity-core-6.0-7.lintian-overrides
patching file debian/control
patching file debian/scopes-recommends-generator
patching file debian/compat
patching file debian/rules
patching file debian/unity7.conf
patching file debian/libunity-core-6.0-7.install
patching file debian/changelog
patching file debian/unity.install
patching file debian/unity.migrations
patching file debian/unity-crashdb.conf
grep: debian/patches/series: No such file or directory
==> Merging translations from 20130418

Last edited by zanegrey (2013-08-23 22:35:22)

Offline

#2297 2013-08-24 01:52:41

oi_wtf
Member
From: /home/wtf
Registered: 2012-03-11
Posts: 190

Re: Progress on Unity under Arch Linux!

That's the problematic part:

CMake Error at CMakeLists.txt:311 (add_subdirectory):
  add_subdirectory given source "/usr/src/gmock" which is not an existing
  directory.

Try installing gmock (it's in the TESTPKG-gmock-ubuntu folder)...

@chen, I think there's a missing checkdepend or something like that...?

Last edited by oi_wtf (2013-08-24 01:53:55)


Laptop:   Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-3630QM @ 2.40GHz, 8 GiB RAM, NViDiA GeForce GT 650M 2 GiB
Desktop: Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-4771  @ 3.50GHz, 8 GiB RAM, NViDiA GeForce GTX 660 Ti 2GiB

Offline

#2298 2013-08-24 09:06:00

zanegrey
Member
Registered: 2013-08-23
Posts: 12

Re: Progress on Unity under Arch Linux!

oi_wtf wrote:

Try installing gmock (it's in the TESTPKG-gmock-ubuntu folder)...

Yep.  Fixed the issue.  Nice catch and thank you!

Offline

#2299 2013-08-26 01:41:11

gianluca.pettinello
Member
Registered: 2013-04-16
Posts: 57

Re: Progress on Unity under Arch Linux!

I installed compiz 0.9.10. No need for patch 0001. Seems faster

Offline

#2300 2013-08-26 11:59:52

gadelat
Member
Registered: 2013-03-11
Posts: 49

Re: Progress on Unity under Arch Linux!

What is best way to uninstall unity without reinstalling whole system (gnome etc)?

Offline

Board footer

Powered by FluxBB